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1 INTRODUCTION 
The purpose of this document is to provide information on how to use Extensible Markup 
Language (XML) files in the Accountable Care Organization (ACO) Group Practice Reporting 
Option (GPRO) Web Interface with Excel 2010.  

The XML files exported from the ACO GPRO Web Interface may be imported into an Excel 
spreadsheet. All XML files exported from the ACO GPRO Web Interface may be imported into 
an Excel workbook. The Excel spreadsheets may be used to update the Patient XML data before 
exporting the Excel spreadsheet to the Patient XML format required for upload into the ACO 
GPRO Web Interface. All other XML files may be viewed in the Excel workbook, but XML files 
may not be exported. 

The changes to Excel 2010 prohibit resolving external resources. This document provides the 
steps to map the XML Schema Definition (XSD) file in an Excel 2010 workbook that can be 
used to import and export the Patients XML files and to import the Patient Discharge XML. 
Although the Patient Discharge cannot be generated using Excel, importing the XML file 
provides a means of reading the file exported from the ACO GPRO Web Interface and to gather 
data to be input into an XML file for upload into the ACO GPRO Web Interface. 
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2 REFERENCED DOCUMENTS 
The documents listed in Table 2-1 were used in whole or in part to develop the content within 
this document. 

Table 2-1. Referenced Documents 

Document Name Document Number Issuance 
Date 

PQRS-GPRO-ACO 2012 XML SPECIFICATION 
011813.pdf 

 01/18/13 
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3 XML TO EXCEL 2010 PROCESSING 
The Patient, Patient Discharge, Patient Ranking, Clinic, and Provider XML files exported for the 
ACO GPRO Web Interface may be imported into an Excel file. The Excel file may also be used 
to create the Patient XML file to be uploaded into the ACO GPRO Web Interface. 

The sections below describe how to perform the following tasks: 

3.1 General Steps 

An Excel 2010 workbook with XML Mapping cannot be saved and reopened. To work with the 
data in Excel 2010 in multiple sessions, a new Excel workbook with the mapping must be 
created for each session. The XML may be exported in one session and then imported in the new 
Excel workbook at the next session. 

To use Excel with the Patient XML files: 

1. Create the Excel workbook with XML Mapping. 

2. Import the Patient XML file. 

3. Update the data for the patients using the values defined in the PQRS-GPRO-ACO 2012 
XML SPECIFICATION 011813.pdf . 

4. Export the data to an XML file. 

5. To edit the XML file in another session, create a new Excel workbook with the same 
mappings and repeat steps 2, 3, and 4. 

3.2 Add the Developer Ribbon to Excel 

If the Developer Ribbon is not displayed within Excel ribbon it can be added. Figure 3-1 show 
the Excel ribbon with the Developer Tab displayed 

Figure 3-1. Developer Ribbon in Excel 2010 
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Steps to display the Developer Ribbon: 

1. Click the File Tab. 

2. Click Options. 

3. Click Customize Ribbon on the Excel Options window. 

4. Select the Developer checkbox under the Main Tabs list if not already checked. 

5. Click OK to apply the setting. 

Figure 3-2 shows the File Tab with the Options selection highlighted. 

Figure 3-2. Excel File Tab for Excel 2010 
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Figure 3-3 shows the Excel Options screen with the Customize Ribbon and the 
Developer checkbox highlighted. 

Figure 3-3. Excel Options in Excel 2010 
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3.3 Add the XSD Mapping 

Once the Developer Ribbon is available, the Patient XSD or Patient Discharge XSD Mapping 
can be added to a new Excel Workbook. 

To add the XSD Mapping: 

1. From the File Tab, select New >> Blank workbook. 
Figure 3-4 shows the File Tab with New >> Blank workbook selection highlighted. 

Figure 3-4. Opening a New Blank Workbook 
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2. From the Developer Ribbon, select Source. The XML Source is added to the workbook. 

Figure 3-5 shows the Developer Ribbon with the Source option highlighted. 

Figure 3-5. Source Option in the Developer Ribbon 

 

 

Figure 3-6 shows the blank workbook with the XML Source. 

Figure 3-6. Blank Workbook with XML Source 
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3. Select the XML Maps… button. 

4. Select the Add… button on the XML Maps screen. 

Figure 3-7 shows the XML Maps screen before adding the Patient XSD to the maps. 

Figure 3-7. XML Maps Screen 

 

 

5. Select the Patient XSD or Patient Discharge XSD file to be imported and click Open. 

Figure 3-8 shows the Select XML Source window. 

Figure 3-8. Select XML Source Window 
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6. Select OK in the XML Maps screen. 

Figure 3-9 shows the XML Maps screen after adding the Patient XSD file. 

Figure 3-9. XML Maps after adding Patient XSD File 

 

 

Figure 3-10 shows the XML Maps screen after adding the Patient Discharge XSD file. 

Figure 3-10. XML Maps after adding Patient discharge XSD File 
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Figure 3-11 shows the workbook after adding the Patient XML Source. 

Figure 3-11. XML Maps with Patient XML Source 
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7. Select the ns1:patient line on the XML Source with the left mouse button.  Both the 
Patient XML Source and the Patient Discharge XML Source will have the ns1:patient 
line, but the data following the line will be different for each XSD. 

Figure 3-12 shows the mapping after selecting the ns1:patient line in the Patient XML 
Source. 

Figure 3-12. Patient XML Source with the ns1:patient Line Selected 
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Figure 3-13 shows the mapping after selecting the ns1:patient line in the Patient Discharge XML 
Source. 

Figure 3-13. Patient Discharge XML Source with the ns1:patient Line Selected 
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8. Holding the left mouse button, drag the ns1:patient line to the A1 cell in the workbook 
and then release the mouse button. 

Figure 3-14 shows the workbook after dragging and dropping the Patient XML Mapping 
to the workbook. 

Figure 3-14. Workbook with Patient Mapping Completed 
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9. Close the XML Source by selecting the Source option in the Developer Ribbon, or 
selecting the “X” in the upper right corner of the XML Source. 

Figure 3-15 shows the Excel workbook after closing the XML Source. 

Figure 3-15. Workbook after XML Source Closed 

 

 

3.4 Import the XML File 

Once the XML Mapping is complete, the XML file may be imported into the workbook. To 
import the file: 

1. From Developer Ribbon, click Import. 
Figure 3-16 shows the Excel ribbon with Developer Ribbon with the Import option 
highlighted. 

Figure 3-16. Import Using Developer Ribbon in Excel 2010 

2. Select the desired XML file from the file selection window. 

3. Click Import. 
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3.5 Export the Modified Data (Patient XML Only) 

After editing the imported data, the modified data can be exported into the XML format. The file 
will require modification after exporting from Excel and before uploading into the ACO GPRO 
Web Interface. To export the file: 

1. From the Developer Ribbon, click Export. 
2. Type the filename to be used for the XML file. 

3. Set Save as … type: to XML file if not set and click Export. 
Figure 3-17 shows the Excel worksheet with the Export options highlighted. 

Figure 3-17. Exporting XML from Excel 2010 

 

4. Refer to the steps in Section 3.8to remove the Excel generated namespace (ns1) in the 
exported file and to add the required header. Files with the namespace or without the 
correct header will fail the XML validation when uploaded to the ACO GPRO Web 
Interface. 
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3.6 Errors using Excel 2010 

3.6.1 Patient XML 

If you save the Excel workbook with your imported and updated Patient XML data, open the 
saved file, and then attempt to export the file after additional updates, you will receive an error. 
The updated XML file must be exported, a new workbook mapped, then the updated XML 
imported into the new Excel mapped workbook. 

Because of the error received when exporting with a saved workbook with XML mapping in 
Excel 2010, the template distributed with the XML Specifications will only work with Excel 
2003 or Excel 2007. If the template is opened in Excel 2010 an error will be received when 
attempting to import an XML file. 

Figure 3-18 shows the error received when attempting to import from a saved Excel workbook. 

Figure 3-18. Error when Importing from a Saved Excel Workbook 

 

 

3.6.2 Patient Discharge XML 

The Patient Discharge XML cannot be created with Excel because multiple discharges may exist 
for each patient. If the Patient Discharge XML is imported and an attempt is made to export the 
data an error indicating that the XML maps in the workbook are not exportable. 

Figure 3-19 shows the error received when attempting to export from a saved Excel workbook. 

Figure 3-19. Error when Exporting from a Saved Excel Workbook 
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3.7 Removing the XML Mapping (Patient Discharge Only) 

The Patient Discharge Excel workbook cannot be used to create XML, so the XML mapping 
may be deleted in order to allow the workbook to be saved and reopened. Once the XML 
mapping is removed, the file has the same functionality as an Excel workbook that does not use 
XML mapping. 

To remove the XML mapping: 

1. If the XML Source has been closed, select the Developer Ribbon, then select Source. 

2. Select the XML Maps… button. 

3. Select the Delete button. 

4. Select the OK button on the Microsoft Excel confirmation popup. 

Figure 3-21 shows the confirmation received after selecting the Delete button on the 
XML Maps window. 

Figure 3-20. Confirmation to Delete XML Map 

 

5. Select the OK button on the XML Maps window. 

6. Close the XML Source by selecting the Source option in the Developer tab, or selecting 
the “X” in the upper right corner of the XML Source. 

3.8 Editing the Exported Patient XML File 

Excel adds a target name space to the exported XML tags. These tags must be removed before 
uploading the file into the ACO GPRO Web Interface. 

The template for the Patient XML file has had the header information removed to allow import 
of the XML files into Excel. The header needs to be added prior to uploading the file into the 
ACO GPRO Web Interface. 
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3.8.1 Remove the Name Space from the XML Tags 

The directions below provide the information to remove the name space using WordPad. If any 
other editor is used, care should be exercised when saving the file to ensure that hidden 
characters or non UTF-8 characters are not added to the file. Files should be saved using UTF-8 
encoding. 

To remove the name space added by Excel: 

1. Open the file with WordPad and click Edit. 
2. Click Replace from the Edit toolbar option. 

Figure 3-21 shows a file in WordPad with the Replace option highlighted. 

Figure 3-21. Editing XML File Using WordPad 

 

 

3. The Replace screen is displayed 

4. Enter “ns1:” in the Find What: field 

5. Leave the Replace with: field blank 

6. Click Replace All 
Figure 3-1 shows the Replace screen in WordPad used to remove the name space. 

Figure 3-22. Removing Name Space Using WordPad 
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3.8.2 Add the Header, Audit Data, and Group Identification Data to the XML File 

The Header and Group Identification Data are required in the file. The Audit Data is optional to 
provide tracking information on the file. The lines below should be added to the beginning of the 
file. The header must be an exact match to the header provided below. Replace the 
“MM/DD/YYYY”, “HH:MM”, “XXXXX” in the lines below appropriate data in the file. The 
Taxpayer Identification Number in the file must match the Taxpayer Identification Number 
associated to the IACS ID of the user uploading the data. 

The following three lines are added when the XML file is created by Excel. They should be 
removed. 
 
<?xml version="1.0" encoding="UTF-8" standalone="yes"?> 
<ns1:submission xmlns:ns1="gov/cms/pqrs/gpro/patient/v1"> 
    <ns1:aco-gpro> 
 
After removing those lines, insert the following lines at the top of the file. Note that the 
<submission> element should be on one line without line returns. 
 
<?xml version="1.0" encoding="UTF-8"?>  
<submission version="1.0" type="ACO-GPRO-PATIENT" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
xmlns:noNamespaceSchemaLocation="PQRS-ACO_Patient.xsd" 
xmlns="gov/cms/pqrs/aco/patient/v1"> 
    <file-audit-data> 
         <file-number>1</file-number> 
         <create-date>MM/DD/YYYY</create-date> 
         <create-time>HH:MM</create-time> 
         <create-by>XXXXXX</create-by> 
         <version>1.0</version> 
    </file-audit-data> 
    <submission-period-from-date>01/01/2012</submission-period-from-date> 
    <submission-period-to-date>12/31/2012</submission-period-to-date> 
    <aco-gpro> 
        <aco-tin>XXXXXX</aco-tin> 
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3.8.3 Save the Modified File with UTF-8 Encoding 

After modifying the file to remove the Namespace and replace the header, the file must be saved 
with UTF-8 Encoding. Files that are not saved with UTF-8 encoding will fail the XML format 
validation. 

To save the file with UTF-8 Encoding in Notepad: 

1. Click File. 

2. Click Save As. 

3. Enter the file name with a .xml extension in the File name: field. 

4. Select All Files in the Save as type: pull down menu. 

5. Select UTF-8 in the Encoding: pull down menu. 

6. Select Save. 

Figure 3-23 shows the Save As window with the UTF-8 selections needed when saving 
the file. 

Figure 3-23. Saving File with UTF-8 Encoding 
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APPENDIX A – ACRONYMS 
This section describes the acronyms used in this document. 

Acronym Description 

ACO 

GPRO 

Accountable Care Organization 

Group Practice Reporting Option 

XSD XML Schema Definition 

XML Extensible Markup Language 
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