
 

DEPARTMENT OF HEALTH & HUMAN SERVICES 

Centers for Medicare & Medicaid Services 

7500 Security Boulevard 

Baltimore, Maryland 21244-1850 

 

 
 
 

 

 

 
 
 

CENTERS FOR MEDICARE & MEDICAID SERVICES (CMS) 

Office of Information Services (OIS) 
7500 Security Blvd 

Baltimore, MD 21244-1850 

DOORS v 8.3 User Guide 

 22 September 2008 

Centers for Medicare & Medicaid Services (CMS) 



Centers for Medicare & Medicaid Services  
  

2  

 

TABLE OF CONTENTS 

 

CHAPTER 1 BASICS ............................................................................................................................................ 8 
STARTING DOORS ........................................................................................................ 8 
CHANGING THE DOORS EXPLORER'S  DISPLAY .............................................................. 11 
MAKING SELECTIONS IN THE DOORS EXPLORER ........................................................... 12 
SELECTING MULTIPLE ITEMS .......................................................................................... 13 
CHANGING THE APPEARANCE OF THE MODULE TOOLBAR .................................................. 13 
MODULE BUTTONS DEFINED: ........................................................................................ 14 
UNDERSTANDING LOCATION .......................................................................................... 18 
UNDERSTANDING FAVORITES......................................................................................... 20 
ORGANIZING YOUR FAVORITES LIST................................................................................ 21 
HOW CHANGES TO THE DATABASE AFFECT FAVORITES .................................................... 22 
OPENING A MODULE ..................................................................................................... 23 
REQUESTING A MODULE LOCK ....................................................................................... 25 
MAKING SELECTIONS IN A MODULE WINDOW .................................................................... 26 

Selecting multiple objects ................................................................................................................................... 26 
Selecting everything ........................................................................................................................................... 27 

USING DRAG-AND-DROP ................................................................................................ 27 
In the DOORS Explorer ..................................................................................................................................... 27 
In a module window ........................................................................................................................................... 28 

CUTTING, COPYING AND PASTING ................................................................................... 30 
In the DOORS Explorer ..................................................................................................................................... 31 
In a module window ........................................................................................................................................... 32 

CLOSING A MODULE ...................................................................................................... 33 
STOPPING DOORS...................................................................................................... 34 

CHAPTER 2 MANAGING FOLDERS .............................................................................................................. 34 
CREATING A FOLDER .................................................................................................... 35 
CONTROLLING ACCESS TO A FOLDER ............................................................................. 36 

Editing folder properties .................................................................................................................................... 38 
Deleting, un-deleting and purging a folder ........................................................................................................ 38 
Managing locks .................................................................................................................................................. 39 

CHAPTER 3 MANAGING FORMAL MODULES .......................................................................................... 41 
CREATING A FORMAL MODULE ....................................................................................... 41 

Controlling access to a formal module .............................................................................................................. 43 
Paste special ...................................................................................................................................................... 45 
Showing module properties ................................................................................................................................ 48 
Showing module statistics .................................................................................................................................. 50 
Deleting, un-deleting and purging a module...................................................................................................... 51 
Managing open modules .................................................................................................................................... 52 

CHAPTER 4 EDITING ....................................................................................................................................... 54 
UNDERSTANDING EDIT MODES ....................................................................................... 55 
CHANGING THE EDIT MODE ............................................................................................ 55 



Centers for Medicare & Medicaid Services  
  

3  

UNDERSTANDING EDITABLE SECTIONS ............................................................................ 56 
SETTING UP A MODULE FOR SHARING ............................................................................. 57 
WORKING IN SHAREABLE EDIT MODE .............................................................................. 58 

Saving changes when editing in shareable mode ............................................................................................... 59 
Colors of locked and unlocked sections ............................................................................................................. 60 

REQUESTING A SECTION LOCK ....................................................................................... 60 
IN-PLACE EDITING ......................................................................................................... 60 

Selecting and editing .......................................................................................................................................... 61 
Formatting text ................................................................................................................................................... 62 

EDITING USING THE OBJECT PROPERTIES SHEET ............................................................. 63 
UNDOING EDITS............................................................................................................ 68 
EXTENDED UNDO.......................................................................................................... 68 
SAVING YOUR CHANGES ................................................................................................ 70 
CREATING OBJECTS ...................................................................................................... 71 
CONTROLLING ACCESS TO AN OBJECT ............................................................................ 71 
PROMOTING AND DEMOTING OBJECTS ............................................................................ 73 
SWAPPING OBJECT HEADING AND OBJECT TEXT ATTRIBUTES .......................................... 74 
SPLITTING OBJECT HEADING FROM OBJECT TEXT ........................................................... 74 
DELETING, UN-DELETING AND PURGING OBJECTS ............................................................ 75 
UNDERSTANDING THE SPELLING CHECKER ...................................................................... 77 
CHECKING SPELLING .................................................................................................... 77 
INSERTING SYMBOLS .................................................................................................... 80 
INSERTING URLS ......................................................................................................... 80 

CHAPTER  5  EDITING USING FORMS ......................................................................................................... 81 
OVERVIEW ................................................................................................................... 82 
CREATING A NEW FORM ................................................................................................ 82 
EDITING FORMS ............................................................................................................ 83 
RUNNING FORMS .......................................................................................................... 83 
DELETING FORMS ......................................................................................................... 84 

CHAPTER  6  USING VIEWS ............................................................................................................................. 85 
UNDERSTANDING VIEWS ............................................................................................... 86 
SAVING YOUR CURRENT VIEW ........................................................................................ 87 
UNDERSTANDING INHERITANCE IN VIEWS ........................................................................ 89 
VIEWS INHERITANCE AND ACCESS CONTROLS ................................................................. 90 
SETTING DEFAULT VIEWS .............................................................................................. 91 
EDITING A VIEW ............................................................................................................ 92 
CONTROLLING ACCESS TO A VIEW .................................................................................. 94 
DELETING A VIEW ......................................................................................................... 96 

CHAPTER  7  FILTERING AND SEARCHING............................................................................................... 97 
SEARCHING WITH THE DOORS EXPLORER .................................................................... 98 
FINDING TEXT IN A MODULE ........................................................................................... 99 
FINDING AND REPLACING TEXT ..................................................................................... 100 
GOING TO A PARTICULAR OBJECT................................................................................. 102 
UNDERSTANDING FILTERS ........................................................................................... 103 

Simple filters .................................................................................................................................................... 103 



Centers for Medicare & Medicaid Services  
  

4  

Advanced filters................................................................................................................................................ 103 
USING A SIMPLE FILTER ............................................................................................... 104 

Statistics ........................................................................................................................................................... 105 
USING AN ADVANCED FILTER ....................................................................................... 106 
TURNING FILTERING ON AND OFF ................................................................................. 107 

CHAPTER  8  USING ATTRIBUTES .............................................................................................................. 109 
UNDERSTANDING SYSTEM ATTRIBUTES......................................................................... 110 
UNDERSTANDING ATTRIBUTE TYPES ............................................................................. 112 
SHOWING ATTRIBUTE TYPES ........................................................................................ 114 
CREATING AN ATTRIBUTE TYPE .................................................................................... 114 

Controlling access to an attribute type ............................................................................................................ 115 
Editing an attribute type................................................................................................................................... 117 
Deleting an attribute type................................................................................................................................. 118 
Showing attribute definitions ........................................................................................................................... 119 
Creating an attribute definition ....................................................................................................................... 119 
Creating a new DXL attribute .......................................................................................................................... 121 
Controlling access to an attribute definition .................................................................................................... 122 
Controlling access to an attribute value .......................................................................................................... 124 
Editing an attribute definition .......................................................................................................................... 126 
Editing a DXL attribute definition ................................................................................................................... 128 

SHARING ATTRIBUTE AND TYPE DEFINITIONS ................................................................. 130 
Deleting an attribute definition ........................................................................................................................ 131 
Understanding DXL attributes and layout DXL columns ................................................................................ 132 
Copying attribute values .................................................................................................................................. 133 

CHAPTER  9  VIEWING DATA IN A FORMAL MODULE ........................................................................ 134 
NAVIGATING USING THE KEYBOARD .............................................................................. 135 
USING THE MODULE EXPLORER.................................................................................... 135 
UNDERSTANDING DISPLAY MODES ............................................................................... 136 

Changing the display mode .............................................................................................................................. 138 
Controlling table attribute display ................................................................................................................... 140 
Using outlining ................................................................................................................................................. 141 
Using compression ........................................................................................................................................... 142 
Working with columns ...................................................................................................................................... 143 
Showing column information ........................................................................................................................... 144 
Adding a column .............................................................................................................................................. 144 
Editing column information ............................................................................................................................. 146 

CHAPTER  10  WORKING WITH TABLES ............................................................................................... 148 
UNDERSTANDING TABLES ............................................................................................ 149 

Creating a table ............................................................................................................................................... 150 
Inserting a module as a table ........................................................................................................................... 151 
Inserting rows .................................................................................................................................................. 152 
Inserting columns ............................................................................................................................................. 152 
Changing table properties................................................................................................................................ 153 
Deleting, un-deleting and purging tables ......................................................................................................... 157 

CHAPTER  11  WORKING WITH PICTURES AND OLE OBJECTS ..................................................... 160 
WORKING WITH PICTURES ........................................................................................... 161 

To insert a picture: ........................................................................................................................................... 161 
Understanding OLE objects ............................................................................................................................. 162 
Activating and deactivating an OLE object ..................................................................................................... 163 



Centers for Medicare & Medicaid Services  
  

5  

Inserting a new OLE object .............................................................................................................................. 164 
Inserting an existing file as an OLE object ...................................................................................................... 165 
Resizing OLE objects ....................................................................................................................................... 167 
Cutting, copying and pasting OLE objects ....................................................................................................... 168 
Editing OLE object properties ......................................................................................................................... 168 
Deleting OLE objects ....................................................................................................................................... 170 
OLE objects and history ................................................................................................................................... 170 
Setting the OLE open limit ............................................................................................................................... 170 
Registered and Unregistered OLE Objects ...................................................................................................... 171 
Actions affected by changes to the handling of OLE objects ........................................................................... 172 

CHAPTER  12  USING LINKS ....................................................................................................................... 179 
UNDERSTANDING LINKS .............................................................................................. 180 

Understanding external links ........................................................................................................................... 180 
Using link arrows ............................................................................................................................................. 181 
Creating links ................................................................................................................................................... 182 
Creating external links ..................................................................................................................................... 184 
Clearing the link start ...................................................................................................................................... 186 
Understanding link modules and linksets ......................................................................................................... 187 
DOORS Links, the default link modules ........................................................................................................... 187 
Controlling access to a link module ................................................................................................................. 188 
Understanding how copy and move affect links ............................................................................................... 190 
Editing links ..................................................................................................................................................... 193 
Deleting links ................................................................................................................................................... 196 
Linking by attribute .......................................................................................................................................... 200 
Understanding link module defaults ................................................................................................................ 202 
Creating default linkset pairings ...................................................................................................................... 203 
Control on links for process management ........................................................................................................ 204 
Creating a link module ..................................................................................................................................... 206 
Working with link modules ............................................................................................................................... 207 
Creating a linkset ............................................................................................................................................. 209 
Deleting a linkset ............................................................................................................................................. 210 

CHAPTER  13  TRACEABILITY .................................................................................................................. 212 
UNDERSTANDING DOORS URLS ................................................................................ 213 

Following a DOORS URL ................................................................................................................................ 215 
UNDERSTANDING LINK ANALYSIS ................................................................................. 218 

Running a link analysis .................................................................................................................................... 218 
Understanding traceability columns ................................................................................................................ 219 
Adding a traceability column ........................................................................................................................... 221 
Using the traceability explorer ........................................................................................................................ 225 

CHAPTER  14  SUSPECT LINKS ................................................................................................................. 228 
Showing suspect links ....................................................................................................................................... 230 
Filtering on suspect links ................................................................................................................................. 230 
Displaying suspect link indicators ................................................................................................................... 230 
Displaying the last change ............................................................................................................................... 231 
Displaying all suspect link information ........................................................................................................... 232 
Clearing suspect links ...................................................................................................................................... 234 

CHAPTER  15  HISTORY .............................................................................................................................. 237 
UNDERSTANDING CHANGE BARS .................................................................................. 238 
SHOWING MODULE HISTORY ........................................................................................ 239 
UNDERSTANDING REDLINING ....................................................................................... 241 



Centers for Medicare & Medicaid Services  
  

6  

CHAPTER  16  BASELINES .......................................................................................................................... 243 
UNDERSTANDING BASELINES ....................................................................................... 244 
USING BASELINES TO IMPROVE PERFORMANCE ............................................................. 244 
VIEWING A BASELINE .................................................................................................. 244 
CREATING A BASELINE ................................................................................................ 245 
COPYING A BASELINE .................................................................................................. 245 
BASELINE COMPARE ................................................................................................... 246 

CHAPTER  17  PRINTING & REPORTS ..................................................................................................... 248 
USING PRINT PREVIEW ................................................................................................ 249 
PRINTING................................................................................................................... 250 

Applying saved page setups ............................................................................................................................. 250 
Creating page setups ........................................................................................................................................ 250 

CREATING A REPORT .................................................................................................. 255 
PRINTING AND MANAGING REPORTS............................................................................. 256 

CHAPTER  18  IMPORTING ......................................................................................................................... 258 
HOW TO CREATE A WORD DOCUMENT FOR EASY EXPORT TO DOORS ........................... 259 

Introduction ...................................................................................................................................................... 259 
Writing Good Requirements ............................................................................................................................. 259 
Basic Use of Word ............................................................................................................................................ 259 
Word to DOORS Mapping ............................................................................................................................... 260 
Styles and Structure ......................................................................................................................................... 260 
Reviewing the Structure ................................................................................................................................... 260 
Paragraph Styles .............................................................................................................................................. 261 
No Double Line Breaks .................................................................................................................................... 262 
One Requirement per Line ............................................................................................................................... 263 
Numbering and Bullets ..................................................................................................................................... 263 
Front and Back Matter ..................................................................................................................................... 264 
Indented Paragraphs ........................................................................................................................................ 264 
Requirements Attributes ................................................................................................................................... 264 
Non-Text Content ............................................................................................................................................. 265 
Captions ........................................................................................................................................................... 265 
Tables ............................................................................................................................................................... 265 
Whole Table ..................................................................................................................................................... 265 
Layout of Pictures and OLE Objects ................................................................................................................ 266 
Pictures ............................................................................................................................................................ 266 
OLE Objects ..................................................................................................................................................... 267 

EXPORTING FROM MICROSOFT WORD ......................................................................... 268 
IMPORTING RTF FILES ................................................................................................ 270 
IMPORTING SPREADSHEET FILES .................................................................................. 271 

Importing a spreadsheet or database file ......................................................................................................... 273 
Defining attribute lists for import .................................................................................................................... 274 
Using attribute list elements for import ........................................................................................................... 275 
Loading saved attribute lists for import ........................................................................................................... 275 
Choosing attribute types .................................................................................................................................. 275 

IMPORTING SPREADSHEETS ........................................................................................ 276 
Existing information ......................................................................................................................................... 276 
Import spreadsheet ........................................................................................................................................... 276 
Outline Level dxl script .................................................................................................................................... 276 
Summary .......................................................................................................................................................... 276 

CHAPTER  19  EXPORTING ......................................................................................................................... 278 



Centers for Medicare & Medicaid Services  
  

7  

EXPORTING TO MICROSOFT WORD .............................................................................. 279 
EXPORTING TO MICROSOFT EXCEL .............................................................................. 281 

To export to Excel: ........................................................................................................................................... 282 
EXPORTING TO SPREADSHEET ..................................................................................... 282 

To export to a CSV or TSV file: ....................................................................................................................... 283 
CHAPTER  20  USING SUPPORT TOOLS .................................................................................................. 285 

EDITING IMPORTED WORD STYLE INFORMATION ............................................................ 286 
RESIZING OLE OBJECTS ............................................................................................. 287 
CONVERTING LAYOUT DXL TO ATTRIBUTE DXL ............................................................ 287 

CHAPTER  21   KEYBOARD SHORTCUTS ................................................................................................ 288 
CTRL KEYS ............................................................................................................... 289 
RICH TEXT ................................................................................................................. 292 
FUNCTION KEYS ......................................................................................................... 292 
KEYPAD KEYS ............................................................................................................ 293 
NAVIGATION KEYS ...................................................................................................... 294 

CHAPTER  22  CONTACTING CUSTOMER SUPPORT .......................................................................... 296 
WHAT TO DO BEFORE YOU CONTACT CUSTOMER SUPPORT ............................................. 297 
HOW TO CONTACT CUSTOMER SUPPORT ...................................................................... 297 
SENDING AN AUTOMATED PROBLEM REPORT FORM ........................................................ 297 

Guidelines for writing a problem report .......................................................................................................... 298 
Automatic responses and recording defects ..................................................................................................... 298 
Automatically generated problem reports ........................................................................................................ 298 

 

 



Centers for Medicare & Medicaid Services  
  

8  

Chapter 1 Basics  

 

This chapter contains the following topics: 

• Starting DOORS 

• Changing the DOORS Explorer display 

• Making selections in the DOORS Explorer 

• Changing the appearance of the module toolbar 

• Understanding location 

• Understanding favorites 

• Opening a module 

• Requesting a module lock 

• Making selections in a module window 

• Using drag-and-drop 

• Cutting, copying and pasting 

• Closing a module 

• Stopping DOORS 

 

Starting DOORS  

 

To start DOORS: 
 
1. On Windows computers, click Start > Programs > Telelogic > DOORS 

     8.3. 

 

2. When the DOORS Login screen is displayed, type in your DOORS 

username and password, and click OK. 
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Note Your username and password are case sensitive. 

If the username or password box is unavailable, you don’t have to type your 

username or password. 

 

3. The first time you log into DOORS you should not enter a Password just enter 

your Username and press OK. 

4. If a message is displayed telling you that your password has expired, go to 

Step 4. This message is displayed if you have not run DOORS before.  

 

If this message is not displayed, go to Step 5.  

 

5. Change your password:  

 
 

 

a. Click OK to dismiss the message.  
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b. In the Old password box, type your current password. If you have not 

logged in to DOORS before and do not have a password, leave the Old 
password box blank.  

c. In the New password and Confirm new password boxes, type the new 

password you want to use.  

d. Click OK.  

e. Click OK.  

6. The DOORS Explorer window is displayed.  

Your username and user type are shown on the status bar at the bottom of the 

window.  

 
Note: When your password expires, the next time you log in to DOORS, you'll be 

asked to change your password. If you want to change it before it expires, 
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in the DOORS Explorer, click Tools > Options. Then click the Password 

tab, and click Change Password.  

Changing the DOORS Explorer's  display 

Use the following options on the DOORS Explorer’s view menu to change the 

way your screen looks and control what data is displayed. 

 
 

View menu 
Description  

option  

Project View  Switches between Project view and Database view.  

 When you start DOORS, the top-level items that are displayed in the 

Database View  left pane of the DOORS Explorer depend on your view:  

• In Project view, a list of the projects you’re allowed to access is 

displayed. 

• In Database view, the root of the database tree  is displayed. 

Below this, the parts of the database you’re allowed to access 

are displayed.  

Show Projects  Controls whether projects are displayed. Projects have icons like  

this:  

Show Folders  Controls whether folders are displayed. Folders have icons like  

this 

Show Formal 

Modules  

.  

Controls whether formal modules are displayed. Formal modules have 

icons like this .  

Show Link 

Modules  

Controls whether link modules are displayed. Link modules have icons 

like this .  

Show Descriptive 

Modules  

Controls whether descriptive modules are displayed. Descriptive 

modules have icons like this .  
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View menu 
option  

Description  

Show Deleted 

Items  

Controls whether deleted projects, folders and modules are displayed. 

A deleted item has a red cross in the corner of its icon. For example, 

the icon for a deleted formal module looks like this .  

Sort by Name  Sorts the items in the right pane using the values in the Name column. 

It sorts folders and projects first, followed by a sorted list of modules.  

 

 

View menu option  Description  

Sort by Type  Sorts the items in the right pane using the values in the Type column.  

Sort by Description  Sorts the items in the right pane using the values in the Description 
column.  

Sort by Deleted  Sorts the items in the right pane using the values in the Deleted 
column.  

Refresh  Refreshes the screen display.  

  

Making selections in the DOORS Explorer  

 

The DOORS Explorer works like Windows Explorer: 

• In the left pane, click an item to select and open it. Its contents are displayed 

in the right pane. 

 

In Project view, the left pane contains one or more top-level projects  . In 

Database view, the left pane contains a single top-level item (Database ). 

 

• The menu options apply to whatever is currently selected. 
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For example, if you select the folder Myfolder and then you right-click 

Properties, the properties sheet for Myfolder is displayed. 

• Some project and folder options, such as Delete and Purge, are only 

available if you select the project or folder in the right pane. This is because 

the options are not available when the project or folder is open. 

 

The project or folder you select in the left pane is open. It has an open 

project   or open folder icon . 

 

• Modules are only shown in the right pane. 

 

Double-click a module to select and open it. Each module you double-click 

is opened in a separate module window. 

 Selecting multiple items 

 

To select multiple items in the right pane of the DOORS Explorer, use 

CTRL+ Click (hold down the CTRL key, and then click each item you want to 

select). 

To quickly select a group of items that are next to each other, use SHIFT+ Click: 

1. Click the first item in the group. 

2. Press and hold down SHIFT, and then click the last item in the group L 

3. Release SHIFT. 

 

Changing the appearance of the module toolbar 

 

To allow you to customize the appearance of the module toolbar, buttons are 

arranged in logical groups that you can choose to hide or display. For example, 

buttons that can control the alignment of text are grouped together on a separate 

Alignment toolbar, buttons for use when working with tables are on the Table 
toolbar, and so on. 
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Module Buttons Defined: 

 
Module Buttons Function (Keyboard Shortcut) 

 
Save (Ctrl+ S) 

Print (Ctrl+ P) 

 Module Properties 

Cut (Ctrl+ X)  

Copy (Ctrl+ C)  

 Paste (Ctrl+ V) 

 Check Spelling (Ctrl+ K) 

 Discard Changes (Esc) 

 Accept Changes (Ctrl+ M) 

Edit Object Heading (Ctrl+ H) 

 Edit Object Text (Ctrl+ T) 

 Swap Heading and Text 

 Bold (Ctrl+ B) 

 Italics (Ctrl+ I) 

 Underline (Ctrl+ U) 

Bullets 

 Increase Indent 

Decrease Indent 
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Module Buttons Function (Keyboard Shortcut) 

 Add Object as sibling (Ctrl+ N) 

 Add Object as child (Ctrl+ L) 

 Edit Object Properties (Ctrl+ E) 

 Promote Object (Ctrl+ Alt+ Left) 

 Demote Object (Ctrl+ Alt+ Right) 

 Start Link (Ctrl+ I) 

 Clear Link Start 

 Make Link From Start (Shift+ Ctrl+ F) 

 Make Link To Start (Shift+ Ctrl+ M) 

 Create External Link 

 View Selector 

 Level Selector 

 Insert New Column 

 Edit Selected Column Properties 

 Remove Selected Column 

 Left Justified 

 Right Justified 

 Centered 

 Auto Indent Main Column 

 Module Explorer On/Off 
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Module Buttons Function (Keyboard Shortcut) 

 Graphics Mode On/Off 

 Outlining Mode On/Off 

 Filter On/Off 

 Filter Properties 

 Reapply Filter 

Sorting On/Off 

Find (Ctrl+ F) 

 Find Previous (Shift+F3) 

Find Next (F3) 

 Go To (Ctrl+ G) 

 Create New Baseline 

 View Baselines 

 Copy Baseline 

 Compare Baselines 

 Edit Mode Read Only 

 Edit Mode Shareable Edit 

 Edit Mode Exclusive Edit 

Database Buttons Function (Keyboard Shortcut) 

Create New Folder 

 Create New Project 
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Module Buttons Function (Keyboard Shortcut) 

Navigate Up One Level 

Add to Favorites 

Manage Users and Groups 

Create New Formal Module (Ctrl+ M) 

Create New Link Module (Ctrl+ L) 

Open Module Read Only (Ctrl+ R) 

Open Module Shareable Edit (Ctrl+ S) 

Open Module Exclusive Edit (Ctrl+ E) 

 Delete (Del) 

You can change the appearance of the toolbar in two ways. You can either use 

the Customize Toolbars dialog box or right-click the module toolbar. 

To change the appearance of the toolbar using the Customize Toolbars 
dialog box: 

1. Either click View > Customize Toolbars or press CTRL+ O. 

The Customize Toolbars dialog box is displayed. 

2. Select or clear the check box for each group. 

3. If you want to display the default toolbars, select Reset to Default. 
The toolbars that are displayed by default are: 

• Column 

• Display 

• Link 

• Module 

• Object 
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• Object Edit 

• View 

• Click Close. 

To change the appearance of the toolbar by right-clicking the module 
toolbar: 
Right-click the module toolbar, and select or clear the check box for each 

group: 

 

Understanding location 

 

The path to the project or folder that is currently open is displayed in the 

Location field of the DOORS explorer. 

 
Note The path is from the nearest parent project, not from the 

database root 
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As you navigate around the database, the path to each project and folder that 

you 

open is stored in the location field. If you want to return to a folder or project 

 

you have opened previously, you can select it from the Location drop-down list. 

The project or folder is opened in the left pane of the explorer, and its contents 

are displayed in the right pane. 

 
Note The location field is cleared when you close your current 

DOORS session. If you want to be able to easily access a 

project, folder or module across sessions, you should add it 

to your favorites list. 

. 

If you know the path to the project, folder or module you want to open, type the 

path into the Location field and press Enter. Alternatively, you can paste the 

DOORS URL of an item into the Location field and press Enter. Projects and 

folders are opened in the left pane of the DOORS explorer, modules are opened 

in default edit mode. 
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Understanding favorites 

If you use certain projects, folders or modules regularly, you can add them to 

your Favorites list. Instead of navigating through the database hierarchy to 

access 

your data, you can select the project, folder or module from your favorites list in 

the DOORS explorer. 

 

• If you select a project or folder from your favorites list, it is opened in 

the left pane of the DOORS explorer and its contents are displayed in 

the right pane. 

• If you select a module from you favorites list, it is opened. The edit 

mode in which the module is opened depends on your access rights 

and your default edit mode. 

 
Note Your location in the database does not change when you 

open a module from your favorites list. This means you can 

open a module in a different project or folder without having 

to navigate back through the database hierarchy to your 

original location. 

 
To add a project, folder or module to your favorites list: 

 

1. In the DOORS Explorer, select the project, folder or module you want to 

add to Favorites. 

2. Either: 

• Click File > Favorites > Add to Favorites. 

• Click Add to Favorites   on the Project toolbar. 

 

The item is added to your favorites list. 
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Organizing your favorites list 

 

As your favorites list grows, you can maintain it using Organize Favorites. 

Select Favorites > Organize Favorites to open the Organize Favorites dialog 

box. 

The buttons on the Organize Favorites dialog box are described in the table 

below. 

Button  Description  

Edit  Select an item and click Edit to change its label in your favorites list. For 

example, you may want to distinguish between two  

identically named modules, or between a folder and module of the  

same name.  

Note You are not changing the actual name of the project, folder or module, 
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Button  Description  

just the label that is displayed in your favorites list. 

Remove  Select an item and click Remove to remove it from your favorites   

list.  

Refresh Click this button to redraw your favorites list. 

Arrow buttons Select an item and click the up or down arrow to move it. The order in which 

the items appear in the Organize Favorites dialog is the order in which they 

appear in the drop down list on the DOORS explorer. 

How changes to the database affect Favorites 

The following table describes how changes to the database are reflected in your 

favorites list. 

If Then  

A project, folder or 

module is moved  
DOORS automatically updates the path in your favorites list.  

A project, folder or  

module is renamed  

The name of the item in your favorites list does not change. You can 

still access it by selecting its old name from your favorites list.  
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If Then  

 

A project, folder or  

module is deleted  

 

 

The item is not removed from the drop down list in the  

explorer, but if you select it, a message informs you that the item has 

been deleted. The item is marked as deleted  

in the Organize Favorites dialog box.  

 
Your access to a  

project, folder or  

module is removed  

The project, folder or module is removed from your  

favorites list.  

Opening a module 

To open a module, do one of the following: 
 

• Double-click it in the DOORS Explorer. 
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The module is opened in your default edit mode, which is normally 

exclusive edit mode. For more information, see “Understanding edit 

modes,” on page 44. 

 

• Single-click the module in the DOORS Explorer to select it. Click File > 

Open, then either Read-only, Shareable Edit or Exclusive Edit 

depending on which edit mode you want. 

 

• Single-click the module in the DOORS Explorer to select it. Right-click 

Open, then either Read-only, Shareable Edit or Exclusive Edit 

depending on which edit mode you want. 

 

• Click the File menu in the DOORS explorer. If DOORS has been 

configured to display recently opened modules, and you have opened 

modules previously, a list of those modules is displayed in the File 

menu. 

Click on a module to open it in your default edit mode. 

 

The title bar of the module window shows the module name followed by 

either Current or Baseline, the module version and the path to the module 

from the nearest project above it in the database tree. The path starts with 

a slash (/) followed by the name of the project. 

 

This example shows the User Requirements module, which is in the 

Requirements folder of the Sports utility vehicle 4X2 project. 
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Requesting a module lock 

If you try to open a module that another user already has open, the Request 

Lock dialog box is displayed. The options on the dialog box are described in the 

following table. Select the options you want, then click OK. 

 

Select...  To...  

Open module  Enable the edit mode drop down list. 

If another user has an exclusive edit lock on the module,  

the only option available is read-only. If one or more users have 

shareable edit locks on the module, you can select whether to 

open in shareable edit mode or read-only mode. When you click 

OK, the module is opened in the selected edit mode.  

Send a message  Open a Lock Request Message dialog box when you click OK. 

You can type a message into the Lock Request Message dialog 

box, which will be displayed to the user or users who currently 

hold a lock. Those users can optionally reply to your message.  

Alert me when lock is 

available  

Receive a message alert when the lock on the module is 

released. You can open the module directly from the  

message alert.  
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Note Lock request messages are not delivered to DOORSnet 

users. However, if you select Alert me when lock is 

available, you will receive an alert when the DOORSnet user 

releases the lock. 

 

 

Making selections in a module window 

In a module window, you click an object to make it the current object. The way 

in which the current object is differentiated from other objects depends on 

which display scheme you’re using: 

 

• In the Modern display scheme, the current object has a line above and 

below it. 

• In the Classic display scheme, it is highlighted with a dark blue 

background. 

To select an object, use SHIFT+ Click. The selected object’s text turns a 

maroon color. 

Selecting multiple objects 

CTRL+ Click does not work in module windows. You can’t select objects that 

aren’t next to each other. 

 

To select a group of objects that are next to each other, use SHIFT+Click: 

 

1. Click the first object in the group. 

2. Press and hold down SHIFT, and then click the last object in the group. 

3. Release SHIFT. 

 

 

The objects that have been selected are displayed in a different color. 
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The object trees below the first and last objects that you select are automatically 

selected too. And if the first and last objects are at different levels in the database 

tree, additional objects are selected so that all selected objects have a common 

ancestor. This ensures that subsequent operations on the selected objects 

preserve the integrity of your data. 

 

If you have a filter applied to the module, and you select multiple objects, the 

selection also includes objects that are hidden by the filter, but that exist between 

the first and last object in your selection. 

 

Selecting everything 

To select all the objects in a module: 

 

1. Press HOME to go to the start of the module. 

2. Press and hold down SHIFT while using the scroll bar to go to the end of 

the module. 

3. Click the last object in the module. 

 

The text in all the objects is displayed in a different color. 

Using drag-and-drop 

You can use drag-and-drop in the DOORS Explorer and in formal module 

windows. 

 

For information on what happens to links when you use drag-and-drop, see 

“Understanding how copy and move affect links,” on page 219. 

In the DOORS Explorer 

Use drag-and-drop to move or copy projects, folders and modules: 
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• To move an item, click it and then drag it to the target location. 

You can’t move a module if it’s open. You can’t move a folder or project if 

the folder or project, or anything in it, is open. For example, you can’t move 

a folder if it contains a module that’s open. 

• To copy an item, hold down CTRL while you drag-and-drop the item. 

You can’t copy a module if it’s open in exclusive edit mode. You can’t copy a 

folder or project if the folder or project contains a module that’s open in 

exclusive edit mode. 

In a module window 

Use drag-and-drop to either: 

 

• Move objects within a module. 

• Copy objects within a module or between modules. 

• Copy then link objects within a module or between modules. 

 

You cannot use drag and drop to copy or move objects within a module if a sort 

is applied. If you are using drag and drop to copy objects between modules, the 

source module can have a sort applied but the target module must have sorting 

turned off. 

 

You can copy or move tables within a module or between modules using 

drag-and-drop. The Below and Below with hierarchy options are unavailable 

for all operations. To copy or move a table using drag-and-drop, click on any cell 

in the table, and follow the instructions below. 

 

Click the object you want to move or copy, then drag it to the target location. If 

you want to copy the current object after or below itself, drag it over the current 

object. When you release the mouse button, a pop-up menu is displayed that 

includes the following options: 
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Pop-up menu option  Description 

Move > After  Moves the selected object and all the objects in the tree 

below it to the same level as, and immediately after, the 

target object.  

Move > Below  Moves the selected object and all the objects in the tree 

below it to one level below the target object. 

If the target object already has children, the copied object 

becomes its first child.  

Copy > After (with hierarchy) 

t

Copies the selected object and all the objects in the tree 

below it to the same level as, and immediately after, the 

arget object.  

Copy > Below (with hierarchy)  Copies the selected object and all the objects in the tree 

below it to one level below the target object.  

If the target object already has children, the copied object 

becomes its first child.  

Copy > After  Copies the selected object to the same level as, and 

immediately after, the target object.  

Copy > Below  Copies the selected object to one level below the target 

object.  

If the target object already has children, the copied object 

becomes its first child.  

Copy then link from Start > 

After (with hierarchy)  

Same as the Copy after (with hierarchy) option, except it also 

creates a link from each source object to its copy.  

Copy then link from  

Start > Below (with  

hierarchy)  

Same as the Copy below (with hierarchy) option, except  

it also creates a link from each source object to its copy.  



Centers for Medicare & Medicaid Services  
  

30  

 

Pop-up menu option  Description  

Copy then link from 

Start > After  

Same as the Copy after option, except it also creates a 

link from the source object to its copy.  

Copy then link from 

Start > Below  

Same as the Copy below option, except it also creates a 

link from the source object to its copy.  

Copy then link to Start > After 

(with hierarchy)  

Same as the Copy after (with hierarchy) option, except it also 

creates a link to each source object from its copy.  

Copy then link to Start 

> Below (with  

hierarchy)  

Same as the Copy below (with hierarchy) option, except  

it also creates a link to each source object from its copy.  

Copy then link to Start 

> After  

Same as the Copy afteroption, except it also creates a 

link to the source object from its copy.  

Copy then link to Start 

> Below  

Same as the Copy belowoption, except it also creates a 

link to the source object from its copy.  

To drag multiple objects, don’t release the mouse button after making the 

multiple object selection. You lose your selection if you release the mouse button 

between selecting the objects and dragging them. 

 

When you use drag-and-drop to copy objects between modules, only the Object 

Heading, Object Text and Object Short Text attributes are copied. If you 

want to copy other attributes between modules, use the object copier  

 

When you use the Copy then link to Start and the Copy then link from Start 

options, the usual rules that control linking apply. You need to have the 

necessary access rights to make the links. 

 

Cutting, copying and pasting 

You can cut, copy and paste in the DOORS Explorer and in formal module 

windows. 
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In the DOORS Explorer 

Use the Edit menu or keyboard shortcuts to cut, copy and paste projects, folders 

and modules. 

 

Edit menu Keyboard Description 

Cut  CTRL+ X  Cuts the currently selected items, and places them on 

the DOORS Explorer clipboard.  

Copy  CTRL+ C  Copies the currently selected items to the DOORS 

Explorer clipboard.  

Paste  CTRL V  Pastes the contents of the DOORS Explorer 

clipboard to the DOORS Explorer window.  

Paste 

Special  

Provides advanced options for pasting a module. This 

option is not available when a project or folder has been copied.  

For more information, see “Paste special,” on page 33.  

Undo Cut 

Undo Copy 

CTRL+ Z Undoes the last cut or copy operation. 

Clear  Clears the DOORS Explorer clipboard. 

You should clear the clipboard after you finish pasting to avoid 

leaving share locks on modules. Share locks are not normally 

problematic, but can prevent users from changing edit modes 

within the module.  

You can’t cut a module if it’s open. You can’t cut a folder or project if the folder 

or project, or anything in it, is open. For example, you can’t cut a folder if it 

contains a module that’s open. 

You can’t copy a module if it’s open in exclusive edit mode. You can’t copy a 

folder or project if the folder or project contains a module that’s open in 

exclusive edit mode. 
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When you cut data to the DOORS Explorer clipboard, if you have not yet pasted 

it back and then do anything that could overwrite the data on the clipboard, such 

as copying other data to the clipboard, your original cut operation is 

automatically undone. 

 
Note Copying a module does not copy the baselines associated 

with the module. Copying a project containing modules that 

have baselines does not retain those baselines. 

In a module window 

In a module window, use the Edit menu or keyboard shortcuts to cut, copy and 

paste objects within a module. 

 

Note If you want to copy objects between modules, use the object 

copier. 

 

Edit 
menu  

Keyboard  Description  

Cut  CTRL+ X  Cuts the current object and all the objects in the tree below it.

The objects are removed from the module and placed on the object 

clipboard for that module. 

Copy  CTRL+ C  Copies objects to the module’s object clipboard:

• To copy the current object only, either press CTRL+C or click 

Copy > Copy. 

• To copy the current object and all the objects in the tree below it, 

click Copy > Copy with Hierarchy. 

Paste  CTRL+ V  Pastes the contents of the module’s object clipboard:

• To paste to the same level as, and immediately after, the current 

object, either press CTRL+ V or click Paste, then Paste. 
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Edit 
menu 

Keyboard Description  

• To paste to one level below the current object, click Paste > 
Paste Below. 

Clear Clears the contents of the module’s object clipboard.

 

Each module has its own object clipboard. 

 
Note When you’re editing the attributes of an object, you can also 

use the keyboard shortcuts to cut, copy and paste selected 

text in the object. This uses your computer’s system 

clipboard. You can paste the contents of the system 

clipboard to other applications, such as Microsoft Word. 

 

When you cut data to the object clipboard, if you have not yet pasted it back to 

the module and then do anything that could overwrite it, such as copying another 

object to the clipboard, a message is displayed warning that you haven’t pasted 

the data currently on the clipboard. You are offered three choices: 

• Delete 

This overwrites the data currently on the clipboard with the new data. 

• Restore 

This pastes the data currently on the clipboard back to where it was cut 

from, then writes the new data to the clipboard. 

• Cancel 

This cancels the operation, leaving the data currently on the clipboard 

unchanged. 

Closing a module 

To close a module: 
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1. In the module window, click File > Close. 

2. If you’ve made any changes that you haven’t saved yet, a message is displayed 

asking if you want to save your changes. 

Click Yes to save your changes, or No to discard them. 

 

Note Whenever you make any changes to a module, your changes 

are stored temporarily in your local computer’s memory. 

They aren’t saved in the database until you explicitly ask to 

save them. They are marked with a red change bar  or  , to 

show that they haven’t yet been saved in the database. 

As with all windows, you can also close a module by clicking 

The “X”   in the top right corner. 

Stopping DOORS 

 
To stop DOORS: 

1. In the DOORS Explorer, click File > Exit. 
All the modules you opened are automatically closed. 

2. If you edited a module and haven’t saved your changes, a dialog box is 

displayed asking if you want to save your changes before the module is 

closed. 

Click Yes to save your changes, or No to discard them. 

 

Chapter 2 Managing Folders 

This chapter contains the following topics: 

• Creating a folder 

• Controlling access to a folder 

• Editing folder properties 

• Deleting, un-deleting and purging a folder 

• Managing locks 
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For information on how to convert a folder to a project, and vice versa, see the 

DOORS online help or Managing DOORS on the Telelogic Lifecycle 

Solutions DVD. 

Creating a folder 

 
To create a folder: 

1. In the left pane of the DOORS Explorer, select the folder or project in 

which you want to create the new folder. This is the new folder’s parent. 

You must have create access to the parent. 

2. Click File > New > Folder. 
3. In the Name box, type the name of the new folder. 

 

The name is case-sensitive. For example, the names Myfolder and 

MyFOLDER are different. 

 

The name must be unique within the parent project or folder. All the 

projects, folders and modules in the parent must have different names. 

 

The name can contain the following characters: 

• Alphanumeric characters (letters of the alphabet and numbers) 

• Space characters 

• Periods (.) 

• Underscores (_) 

• Hyphens (-) 

4. If you want to give the new folder a description, type it in the Description 

box. 

5. Click OK. 

 

The folder is created. It inherits its access rights from its parent. 

Note If you receive the error Cannot create this Folder: Lock 
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request timed out when you try to create the folder, wait a 

moment, then try again. This error is generated if another 

DOORS user is performing a paste operation when you click 

OK to create the folder. 

Controlling access to a folder 

To change the access rights for a folder, you must have admin access to the 

folder. 

To change the access rights for a folder: 

1. Select the folder in the DOORS Explorer, then right-click Properties. 

2. Click the Access tab. 

The current access rights for the folder are displayed. 

 

You need this 
access right  

To...  

Read (R)  See the folder. If you don’t have read access, the folder is not displayed in 

your DOORS Explorer.  

Create (C)  Create new modules, folders and projects in the folder. Paste existing 

modules, folders and projects into the folder.  

Modify (M)  Change the name or description of the folder.  

Delete (D)  Delete, undelete and purge the folder. Cut the folder to the DOORS 

Explorer clipboard.  

Admin (A)  Change the access rights for the folder. Change the default linkset pairings 

for links from top-level modules within the folder.  

 

3. Make the changes you want. 
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Access tab  Description  

Inherit from parent  Select this check box if you want the folder to inherit its access rights from 

the project or folder that it’s in. If it’s a top-level folder, it inherits its access 

rights from the database root.  

When this check box is selected, the list of access rights is unavailable, 

and shows what access rights the folder is inheriting.  

Add  To a new entry to the list of access rights: 

a. Click Add.  

The Add Access window is displayed: 

b. In the Name box, select the name of the user or group that you want to 

add an entry for.  

c. Select the access rights you want to give them, then click OK.  

Remove  To remove an entry from the list of access rights, select the entry, and 

then click Remove.  

Edit  To edit an entry in the list of access rights:

a. Select the entry then click Edit. The Edit Access window is displayed.  

b. Select the access rights you want to give them, then click OK.  

Additional access  Select the additional access rights that you want to propagate with create 

access.  

The additional rights are propagated to the items in the tree below the 

folder that inherit their access rights from it.  

For more information, see the section topic on propagating extra access 

rights in Getting Started with DOORS, which is available on the Telelogic 

Lifecycle Solutions DVD.  

4. Click OK. 
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Editing folder properties 

To edit the properties of a folder, you must have modify access to the folder. 

To edit the properties of a folder: 

1. Select the folder in the right pane of the DOORS Explorer, then right-click 

Properties. 

2. Select the options you want. 

 

General tab  Description  

Name  The name of the folder. You can’t change the name of a folder if any of 

the folders, projects or modules in the tree below it are open. If the folder 

contains a link module, and the link module is named in any formal 

module filter that has been saved as a view, no objects will be displayed 

in the view if the folder name is changed.  

Description  Additional information about the folder.  

Type  The type of item whose properties are being displayed. In this case the 

type is Folder and it can’t be edited.  

URL  The URL of the folder.  

Copy URL  Copies the URL to the system clipboard. For more information about 

DOORS URLs see “Understanding DOORS URLs,” on page 245.  

 

For information about the options on the Access tab, see either: 

• The help for the Access tab (click the Access tab, then click Help). 

• “Controlling access to a folder,”. 

3. Click OK. 

 

Deleting, un-deleting and purging a folder 

Deleting a folder doesn’t destroy any of the data in the folder. It simply marks 

the folder as deleted, and stops users from being able to access its data. To 

destroy the data, you must purge the folder once you’ve deleted it. 

Purging deleted folders removes them permanently from the database. 
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You can’t delete a folder if the folder or anything in it is open. 

 

In the DOORS Explorer, the folder or project selected in the left pane is open 

and has an open folder icon  or an open project icon . Its parent folder or 

project is also open, and so are all the folders and projects above it in the 

database tree, although they don’t have open folder or open project icons. 

When a module is open, all the folders and projects above it in the database tree 

are also open. 

To delete, undelete or purge a folder, you must have delete access to the folder 

and to all the folders, projects and modules in it. 

To delete a folder: 
• In the right pane of the DOORS Explorer, select the folder you want to 

delete , then click File > Delete. 

You can also click Delete  on the Project toolbar, right-click Delete or 

press DELETE. 

To undelete a deleted folder: 
1. In the DOORS Explorer, make sure that deleted items are being displayed. 

If necessary, click View > Show Deleted. 

2. Select the folder you want to undelete  , then either click File > 

Undelete or right-click Undelete. 

To purge a folder: 
1. In the DOORS Explorer, make sure that deleted items are being displayed. 

If necessary, click View > Show Deleted. 

2. Select the folder you want to purge , then click File > Purge.... 

A message is displayed asking if you really want to purge the folder. 

3. Click Yes. 

The folder and all the data in it are permanently removed from the database. 

Managing locks 

If your DOORS session ends abnormally, for example, if your computer crashes: 

• Any modules that you were editing are locked. 
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No-one can edit these modules until they are unlocked. They can open 

them in read only mode, but not in shareable or exclusive edit mode. 

• Projects and folders you had open are locked. 

No-one can move, rename or delete these projects or folders until they are 

unlocked. 

 

To unlock projects, folders and modules: 
1. In the DOORS Explorer, click Tools > Manage Locks. 

A list of the items that are currently locked is displayed. 

The list does not include the locks associated with your current DOORS 

session, because you must not delete these locks. If you deleted them you 

would corrupt your data. 

If you’re a Standard user, you only see the items that you locked in previous 

DOORS sessions. If you’re a Database Manager or a Custom user with the 

power to manage the database, items locked by all database users are 

displayed. 

If you have a chain of locks from the root of the database, you only see the 

lock at the end of the chain. 

Note    By default, the Current folder only check box is 

selected. This shows locks in the current folder that have 

been partially removed, and that are not displayed 

otherwise. If you want to see all the locks in the database, 

clear this check box. 

2. Click Refresh to refresh the display. 

3. Select the items you want to unlock, then click Unlock. 

Note   When you open a module, you lock all the folders and 

projects above the module in the database tree. But on 

this screen, you only see the lock for the module, not the 

associated locks in the tree above it. When you unlock 

the module, you also remove any associated locks that 

aren’t needed by other data that is locked elsewhere in 
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the database tree. 

A message is displayed asking if you really want to unlock the items. 

4. Click Yes. 

5. Click Close. 

 

Chapter 3 Managing Formal Modules 

 

This chapter contains the following topics: 

• Creating a formal module 

• Controlling access to a formal module 

• Paste special 

• Showing module properties 

• Showing module statistics 

• Deleting, un-deleting and purging a module 

• Managing open modules 

Creating a formal module 

This topic describes how to create an empty new module. You can also create a 

module by either: 

• Copying an existing module in the DOORS Explorer, for example, using 

copy and paste. 

• Cloning an existing module. This lets you select which bits of the module 

you want to copy. For example, you can select which attributes you want 

to copy.. 

• Copying a baseline. 

To create an empty formal module: 
1. In the DOORS Explorer, select the folder or project in which you want to 

create the new module. This is the module’s parent. 

You must have create access to the parent. 

2. Click File > New > Formal Module. 

3. Type the name of the new module in the Name box. 
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The name is case-sensitive. For example, the names Mymodule and 

MyMODULE are different. 

The name must be unique within the parent project or folder. All the 

projects, folders and modules in the parent must have different names. 

 

The name can contain the following characters: 

• Alphanumeric characters (letters of the alphabet and numbers) 

• Space characters 

• Periods (.) 

• Underscores (_) 

• Hyphens (-) 

4. If you want to give the module a description, type it in the Description box. 

5. By default, the module’s object identifiers start at 1 and have no prefix. If 

you want to override the default, use the Start at and Prefix boxes. 

6. If you want to use a template to populate the new module, select the Use a 

template check box, then use Browse to locate it. 

DOORS provides a library of templates to help get you up and running 

quickly. For example, there are DoD-STD and MIL-STD templates. 

Templates help you keep your modules consistent by encouraging people to 

use a standard structure and headings. 

You can create your own templates and add them to the library, which is in 

the DOORS home directory, in \doors_8.3\lib\dxl\standard. For 

more information, see the DXL Reference Manual, which can be accessed 

from DOORS by selecting Help > DXL Reference Manual. 

Note You can also insert a template into an existing module. 

 

7. Click OK. 

The module is created. It inherits its access rights from its parent. 

Note   If you receive the error Cannot create this Module: Lock 

request timed out when you try to create the module, wait a 

moment, then try again. This error is generated if another 
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DOORS user is performing a paste operation when you click 

OK to create the module. 

Controlling access to a formal module 

To change the access rights for a formal module, you must have admin access to 

the module. 

To change the access rights for a formal module: 
1. You can change the access rights for a module from either the DOORS 

Explorer or the module window: 

• In the DOORS Explorer, select the module then right-click Properties. 

• In the module window, click File > Module Properties. 

2. Click the Access tab. 

The current access rights for the module are displayed. 

Note You cannot open a module unless you have read access 

to the parent project or folder. 

 

 

You need this 
access right  

To  

Read (R)  See the module. If you don’t have read access, the module is not 

displayed in your DOORS Explorer.  

Set your own default view for the module (see “Setting default views,” on 

page 90).  

Create (C)  Create top-level objects in the module. 

Create attribute types and attribute definitions for the module.  

Modify (M)  Change the module’s name, description, attribute values, default view. 

Create baselines of the module.  

Delete (D)  Delete, undelete and purge the module. 

Cut the module to the DOORS Explorer clipboard.  

Admin (A)  Partition the module out. 

Change the access rights for the module.  
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If the module is partitioned in, the access rights associated with the partition 

are displayed. These describe the maximum access that any user has. They 

override the RCMD access rights displayed for users and groups. 

 

For example, if a user’s entry says full access (RCMDA), but the module is 

partitioned in read only, in practice the user only has read (R) access. 

3. Make the changes you want. 

 

Access tab  Description  

Inherit from 

parent  

Select this check box if you want the module to inherit its access rights from 

the project or folder that it’s in. When this check box is selected, the list of 

access rights is unavailable, and shows what access rights the module is 

inheriting.  

Add  To add a new entry to the list of access rights: 

a. Click Add.  

The Add Access window is displayed.  

b. In the Name box, select the name of the user or group that you want to 

add an entry for.  

c. Select the access rights you want to give them, then click OK.  

Remove  To remove an entry from the list of access rights, select the entry, and then 

click Remove.  

Edit  To edit an entry in the list of access rights: 

a. Select the entry then click Edit.  

The Edit Access window is displayed.  

b. Select the access rights you want to give them, then click OK.  
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Access tab  Description 

Additional 

access  

Select the additional access rights that you want to propagate with create 

access. The additional rights are propagated to the objects in the module 

that inherit their access rights from the module.  

Note   Module attributes cannot inherit access rights, so 

additional access rights do not apply to module attributes and their 

values.  

For more information, see the section topic on propagating extra access 

rights in Getting Started with DOORS, which is available on the Telelogic 

Lifecycle Solutions DVD.  

 

4. Click OK. 

Paste special 

When you select Paste Special, you create a new module by copying the 

structure of an existing module. You can copy: 

• Object Heading and Object Text 

• The heading structure only, including the heading text 

• The columns in a particular view 

• Attribute types and definitions 

• Baselines are not copied 

To use Paste Special: 
1. In the DOORS Explorer, select the module you want to copy. 

2. Click Edit > Copy 

3. Select the folder or project to which you want to copy the module and select 

Edit > Paste Special. 

You must have create access to the folder or project. 
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4. In the New module name box, type the name you want to give the new 

module. 

The name is case-sensitive. For example, the names Mymodule and 

MyMODULE are different. 

 

The name must be unique within the parent project or folder. All the 

projects, folders and modules in the parent must have different names. 

The name can contain the following characters: 

• Alphanumeric characters (letters of the alphabet and numbers) 

• Space characters 

• Periods (.) 

• Underscores (_) 

• Hyphens (-) 

The name cannot be more than 460 characters in length. 
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5. If you want to give the new module a description, type it in the Description 

box. 

6. By default, the new module’s object identifiers start at 1 and have no prefix. 

If you want to override the default, use the Start at and Prefix boxes. 

7. In the list of views, select the view you want to copy. 

Note   The standard view is always copied. If you select another 

view, you get the standard view as well as the view you select. 

 

8. You can choose whether to copy Object Heading and Object Text, or just 

the Object Heading. 

• If you want to copy both Object Heading and Object Text select All 

objects. 

• If you only want to copy the Object Heading structure and text 

select Objects with object heading. 

• If you do not want to copy any objects, clear the Objects with 

object heading and All objects boxes. 

9. By default, the main column is copied. 

Select the Columns check box if you want to copy all the columns in the 

selected view. 

10. By default, no attribute types or definitions are copied. 

If you want to copy attribute types and definitions: 

a. Select the appropriate Copy check box. 

b. Click Select. 

A list of all the non-system attribute definitions or types is displayed. 

c. Select the ones you want to copy, then click Close. 

11. By default, the copied links in the new module use the same link modules as 

the links in the original module. 

If you want to use a different link module: 

a. Select the Links Copy check box. 

b. Click Select. 
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c. Clear the Through same link module check box. 

d. Select the link module you want to use, then click Close. 

12. By default, external links are not copied. If you want to copy external links 

select the External Links Copy check box. If the module does not contain 

any external links, the check box is not available. 

13. Click OK. 

Showing module properties 

To show the properties of a formal module: 

Either: 

• In the module window, click File > Module Properties. 

• In the DOORS Explorer, select the module in the right pane, then 

right-click Properties. 

The properties sheet for the module is displayed. 
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General tab  Description 

Name  The name of the module.  

Description  Additional information about the module.  

Type  The type of item whose properties are being displayed. This is Formaland 

can’t be edited.  

URL  The URL of the module.  

Copy URL  Copies the URL to the system clipboard. For more information about 

DOORS URLs see “Understanding DOORS URLs,” on page 245.  

List of 

attributes  

This is a list of all the module’s attributes. For each attribute, it shows the 

name of the attribute and its value.  

If you want to edit module attributes from the Properties window, open the 

module before you open the Module  

Properties dialog box.  

View/Edit  To change the value of an attribute: 

a. Select the attribute in the list of attributes, and then click View/Edit.  

b. Enter the new attribute value.  

c. Click OK.  

List of 

Baseline Set  

Definitions  

The baseline set definitions that include the module  

View  Select a baseline set definition and click View to view the 

definition  

Generate 

history  

for the 

creation and  

deletion of 

links  

Select this option if you want to record the creation and 

deletion of links in the module history.  
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For information 
on this tab  

See 

Access Either:

• The help for the Access tab (click the Access tab, then click 

Help).  

•  “Controlling access to a formal module,” on page 30.  

History Either:

• The help for the History tab (click the History tab, then click Help). 

• “Showing module history,” on page 249. 

Linksets Either:

• The help for the Linksets tab (click the Linkset tab, then click 

Help). 

• “Using links,” on page 209. 

Statistics “Showing module statistics, “ on page 38. 

 

Showing module statistics 

The statistics for a formal module record the number of words and characters in 

the module. If you have a filter applied to the module, the statistics function only 

calculates results for the displayed objects. 

To show the statistics for a module: 

 

1. In the module window, click File > Module Properties. 

2. Click the Statistics tab. 

3. Click Refresh. DOORS fills in the values on the tab. For large modules, this 

can take some time. 
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Statistics tab  Description 

Total Objects Number of objects in the module 

Words in Heading 

and text 

Number of words in the Object Heading, Object Text and Object Short 

Text attributes. 

Characters in 

heading and text 

Number of characters in the Object Heading, Object Text and Object 

Short Text attributes 

Words in other 

attributes 

Number of words in other attributes of type text or string. 

Characters in 

other attributes 

Number of characters in other attributes of type text and string. 

Total Words  Total number of words in attributes of type text and string, including the 

Object Heading, Object Text and Object Short Text. 

Total characters  Total number of characters in attributes of the type text and string 

including the Object Heading, Object Text and Object Short Text. 

Refresh Refreshes the display. This may take a few minutes. 

 

Deleting, un-deleting and purging a module 

Deleting a module doesn’t destroy any of the module data. It simply marks the 

module as deleted, and stops users from being able to access it. To destroy the 

module, you must purge it once you’ve deleted it. 

Purging deleted modules removes them permanently from the database. 

You can’t delete a module if any user is accessing the module. 

To delete, undelete or purge a module, you must have delete access to the 

module. 

To delete a module: 
1. If you currently have the module open, close it (click File > Close). 

2. In the DOORS Explorer, select the module you want to delete, then click File 

> Delete. 
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You can also click Delete  on the Project toolbar, right-click Delete or 

press DELETE. 

To undelete a module: 
1. In the DOORS Explorer, make sure that deleted items are being displayed. 

 

If necessary, click View > Show Deleted. 

 

2. Select the module you want to undelete, then either click File > Undelete or 

right-click Undelete. 

To purge a module: 
1. In the DOORS Explorer, make sure that deleted items are being displayed. 

If necessary, click View > Show Deleted. 

3. Select the module you want to purge then click File > Purge.... 

A message is displayed asking if you really want to purge the module. 

4. Click Yes. 

The module is permanently removed from the database. 

Managing open modules 

Sometimes DOORS or DXL programs open modules in the background 

without displaying them on your screen. This topic describes how to close these 

modules or change their edit mode to read only. 

 

To close a module you can't see or set its edit mode to read only: 
1. In the DOORS Explorer, click Tools > Manage Open Modules. 

A list of all the modules that you currently have open is displayed. 

The modules that were opened but not displayed on your screen have No in 

the Displayed column. 

2. To close a module, select the module, then click Close Modules. 

If you have made changes that have not yet been saved, a message is 

displayed asking if you want to save the changes. 

3. Click Yes to save your changes, or No to discard them. 
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4. To change the edit mode of a module to read only, select the module, then 

click Set Modules Read-Only. 

If you have made changes that have not yet been saved, a message is 

displayed asking if you want to save the changes. 

5. Click Yes to save your changes, or No to discard them. 

6. To refresh the display, click Refresh. 

7. When you have finished, click Close. 
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Chapter 4 Editing 
 

This chapter contains the following topics: 

• Understanding edit modes 

• Changing the edit mode 

• Understanding editable sections 

• Setting up a module for sharing 

• Working in shareable edit mode 

• Requesting a section lock 

• In-place editing 

• Editing using the object properties sheet 

• Undoing edits 

• Extended undo 

• Saving your changes 

• Creating objects 

• Controlling access to an object 

• Promoting and demoting objects 

• Swapping Object Heading and Object Text attributes 

• Splitting Object Heading from Object Text 

• Deleting, un-deleting and purging objects 

• Understanding the spelling checker 

• Checking spelling 

• Inserting symbols 

• Inserting URLs 

• Inserting templates 

• Using the object splitter 

• Using the object copier 

• Merging object text 
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Understanding edit modes 

When you work with formal modules, you can use one of three edit modes. 

 

 

Edit mode  Description  

Read only  You can read (look at) the module, but you can’t edit it.  

Exclusive  You can edit the module, but other users can only read it.  

Shareable  While you’re editing one section of the module, another user can edit another 

section.  

You have to lock the section of the module that you want to edit, to stop other 

users from editing it. While you have the section locked, other users can only 

read the data in it. When you’ve finished, you unlock the section to allow 

another user to edit it.  

For more information, see “Setting up a module for sharing,” on page 47 and 

“Working in shareable edit mode,” on page 48.  

Note In shareable edit mode, you can’t create top-level objects in the module. 

And you can’t create, delete or edit attribute definitions or attribute types. You 

can only do these tasks in exclusive edit mode.  

 

You must have modify access to a module to open it in either shareable or 

exclusive edit mode. 

If you open a module by double-clicking it in the DOORS Explorer, it is opened 

in your default edit mode. By default this is exclusive edit mode.  

When you open a module using the File menu in the DOORS Explorer, you can 

select the mode in which you want to open the module. For example, if you want 

to open it in exclusive edit mode, click File > Open > Exclusive Edit. 

You can change the edit mode of a module once it’s open. 

Changing the edit mode 

The edit mode you are currently using is shown on the status bar at the bottom 
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of the module window. 

You must have modify access to a module to open it in either shareable or 

exclusive edit mode. 

To change the edit mode of an open module: 
1. In the module window, click Edit > Edit Mode, then whichever edit mode 

you want (Read-only, Shareable Edit or Exclusive Edit). 

If you are changing the edit mode to read only and you have made changes 

that you haven’t saved, a message is displayed asking if you want to save your 

changes. 

2. Click Yes to save your changes, or No to discard them. 

3. If you have copied an object, and you change edit modes, a message is 

displayed stating that the clipboard will be cleared when the edit mode is 

changed. Click Confirm to change edit mode and clear the clipboard, or 

Cancel to stay in the same edit mode and keep the contents of the clipboard. 

Note   If you have opened a link module in read only mode, you 

cannot change the edit mode from within the module. To 

change from read only mode, you have to close the link 

module and reopen it in your chosen edit mode. This is only 

the case for link modules. 

Understanding editable sections 
If you want to work in shareable edit mode, you first need to set up the module 

for sharing. This involves dividing the module into editable sections. While one 

user is editing one section, another user can edit another section. 

For example, you might want different users to be able to edit different top-level 

sections within a module. 
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In this example, if each top-level section of the module is an editable section, 

one user can edit the User types section, while another user edits the Project 

Structure section. 

Note Try not to set up editable sections unless you need them. 

Performance gets poorer as the number of editable sections 

increases, because each editable section is stored in a separate 

file in the database. 

Setting up a module for sharing 
To set up a module for sharing, you create editable sections in the module  

You can either: 

• Divide a module into editable sections based on its current object section 

levels. For example, you can make an editable section for each level 1 

section. Or you can make an editable section for each level 2 section. 

• Create custom editable sections. 
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You must have modify access to the module, and admin access to the objects at 

the start of each new section. 

To divide a module into editable sections based on current section levels: 
1. Open the module in exclusive edit mode. 

For example, select the module in the DOORS Explorer, then click File > 

Open > Exclusive Edit. 

2. Click Tools > Setup for Sharing. 

3. Select the section level that you want to make editable sections for, then 

click OK. 

Note   If you subsequently add a new section at the specified level, 

you must manually create an editable section for it. Follow 

the steps below to create a custom editable section. 

For example, if you made editable sections at level 1 and you 

add a new level 1 section, you need to make a custom 

editable section for the new level 1 section. 

To create custom editable sections for a module: 
1. Open the module in exclusive edit mode. 

For example, select the module in the DOORS Explorer, then click File > 

Open > Exclusive Edit. 

2. Select the object where you want a new editable section to start, then click 

Edit > Object > Properties or right-click Properties. 

The new editable section consists of this object and all objects in the tree 

below it that inherit their access rights from it. 

3. Click the Access tab. 

4. Clear the Inherit from parent check box. 

5. Click OK. 

6. Repeat Step 2 to Step 5 for each editable section. 

7. Save the module to make the changes permanent (click File > Save). 

Working in shareable edit mode 
Once you’ve set up a module for sharing, you can work in shareable edit mode. 

You need to lock a section before you can edit the objects in it, create objects in 
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it, or delete objects from it. 

To lock a section: 
1. In the module window, select any object in the section you want to 

lock. 

2. Click Edit > Section > Lock. 

The section containing the current object is locked. If someone else 

has edited the data in the section since you opened the module, 

DOORS refreshes your screen to display the latest data before it 

locks the section.  

If another user already has the section locked, a Request Lock 

dialog box is displayed. Fore more information, see. 

 

No other users can edit the section until you unlock it. 

To unlock a section: 
1. Select any object in the section you want to unlock, then click Edit > 

Section > Unlock. 

If you’ve made any changes that you haven’t saved, a message is 

displayed asking if you want to save your changes. 

2. Click Yes to save your changes, or No to discard them. 

All sections are automatically unlocked when you close the module. 

Saving changes when editing in shareable mode 

When you are editing in shareable edit mode: 

Saving changes when editing in shareable mode 

When you are editing in shareable edit mode: 

 
To...  Select...  
Save sections without 
unlocking  

File > Save, click Save CTRL+ S  
or press  

Save changes and unlock 
all the sections you 
currently have locked  

File > Save and Unlock All Sections  
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Colors of locked and unlocked sections 
The colors used for locked and unlocked sections depend on which display 

scheme you’re using. For example: 

• In the Modern scheme, the background color is pale gray for objects that 

are read only, dark gray for objects in sections you have not locked, and 

white for objects in sections you have locked. 

• In the Classic scheme, the text is black for objects that are read only and 

blue for objects in sections you have locked. The background color is a 

pale blue for objects in sections, and doesn’t change when you lock the 

sections. 

Requesting a section lock 
If you try to lock a section that another user already has locked, the Request 

Lock dialog box is displayed. The options on the dialog box are described in the 

following table. Select the options you want, then click OK. 
 
Select...  To...  
Send a message  Open a Lock Request Message dialog box when you click OK. You can 

type a message into the Lock Request Message dialog box, which will be 
displayed to the user who currently holds the lock. The user can optionally 
reply to your message.  

Alert me when 
lock is  
available  

Receive a message alert when the lock is released. You can  
lock the section directly from the message alert.  

 
Note   Lock request messages are not delivered to DOORSnet 

users. However, if you select Alert me when lock is 

available, you will receive an alert when the DOORSnet 

user releases the lock. 

In-place editing 
There are two ways to edit the values of object attributes: 

• Editing objects in-place (described in this topic) 

Using the object properties sheet . 

If you want to change the values of an attribute for lots of objects or for all the 
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objects in a module, it’s quicker to use the object properties sheet. 

To edit in-place, double-click the attribute you want to edit, then change its 

value. 

Alternatively, just start typing and DOORS appends your text to the end of the 

text in the current object’s main column. 

To edit the value of an attribute, you must have modify access to both the object 

and the attribute value. 

Selecting and editing 
The following table describes the features you can use when you edit in-place: 

To  Do this  
Select another object  Either: 

• Single-click the other object to make it the current 
object. 

• Double-click the other object to make it the current 
object and edit it in-place.  

• Press SHIFT+ RETURN to make the next object the 
current object and edit it in-place. 

• Press the up or down arrow keys to make the previous 
or next object the current object and edit it in-place. 

Select another attribute  Click or double-click the attribute.
If you want to edit the next attribute, click Edit > In-Place > Edit 
Next Attribute, or press CTRL+ A. 

Accept the edits you made 
to the current object  

Either:
• Click Accept changes  on the Commit toolbar.  
• Press CTRL+ M (the letter M is for Make the change).  
• Click Edit > In-Place > Accept Changes.  
• Click on another object or another attribute. 

Discard the edits you 
made to the current object  

Either:
• Click Discard changes  on the Commit toolbar. 
• Press CTRL+ D.  
• Click Edit > In-Place > Discard Changes.  

Change the value of the 
current attribute to the 
default value for that 
attribute  

Click Edit > In-Place > Reset to Default. If the attribute doesn’t 
have a default value, this changes its value to no value.  

Edit the Object Heading 
for the current object • Double-click the existing heading. 

• Click Edit Object Heading  on the Object Edit toolbar. 
• Press CTRL + H

Either: 
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To  Do this  
• Click Edit > In- Place > Edit Heading 

Edit the Object Text for the 
current object 

Either:
• Double-click the existing text. 
• Click Edit Object Text  on the Object Edit toolbar. 
• Click Edit > In-Place> Edit Text. 

 
If you don’t discard the edits you make to the current object, your changes are 

stored temporarily in your local computer’s memory. They are marked with a red 

change bar , to show that they haven’t yet been saved in the database. 

To save them in the database, save the module  

Formatting text 
When you edit a text or string attribute, you can select some text then apply 

formatting to it. 

 
 
 
To make the 
currently selected 
text 

Do this 

bold  Either:
• Click Bold on the Formatting toolbar.  
• Press CTRL+ B.  
• Right-click Bold.  

italic  

Either: 
• Click Italic on the Formatting toolbar. 
• Press CTRL+ I.  
• Right-click Italic.  

underlined  

Either: 
• Click Underline on the Formatting toolbar.  
• Press CTRL+ U.  
• Right-click Underline.  

strikethrough  Either: 
• Click Strike through on the Formatting toolbar.  
• Press CTRL+ SHIFT+ S.  
• Right-click Strikethru.  

superscript  Right-click Superscript.  
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To make the 
currently selected 
text  

Do this  

subscript  Right-click Subscript.  
 

Text can contain standard bullets and can be indented. Place the cursor in the 

text you want to apply the paragraph format to and do the following: 

 
To  Do this  
Copy  Either:  

• Click Copy objects or selected text  on the Clipboard toolbar. 
• Press CTRL+C.  
• Right-click Copy.  
• Click Edit > Copy.  

Cut  Either: 
• Click Cut objects or selected text  on the Clipboard toolbar. 
• Press CTRL+X.  
• Right-click Cut.  
• Click Edit > Cut.  

Paste  Either: 
• Click Paste objects or text  on the Clipboard toolbar. 
• Press CTRL+V.  
• Right-click Paste.  
• Click Edit > Paste.  

 
 

attributes. For example, you may want to copy some text from a Word 

document and paste it into a DOOR object. 

 
 
Note    If you copy an Omega symbol from a FrameMaker 

document and paste it into DOORS, it loses its font family, 

and is pasted as W. 

Editing using the object properties sheet 
There are two ways to edit the values of object attributes: 

• Editing objects in-place  
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• Using the object properties sheet (described in this topic) 

The properties sheet for an object shows various information, including all its 

attributes and their values. 

To edit the value of an attribute, you must have modify access to the module, the 

object and the attribute value. 

To edit an object using its properties sheet: 
1. In the module window, select the object you want to edit, then right-

click Properties. 

The properties sheet for the object is displayed. 

The status of the object is displayed as part of the title of the 

properties sheet: 

 
 
Possible values are: 

• Saved 

• Unsaved 

• New 

• Baselined 

• Deleted 

If you change the current object in the module window, the object properties 

sheet is updated to display the properties of the object you have selected. 

2. Use the General tab to edit the attribute values. 

The following table lists the attribute values you can edit. 
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General tab  Description  
Heading  The Object Heading attribute. 

This is displayed in the module’s main column in Document mode. By 
default, heading text is displayed in bold.  
DOORS automatically generates and displays a heading number, which 
shows the object’s position in the hierarchy. If you move the object or add 
new objects, the heading number is automatically updated.  

Note   You cannot insert new lines in the Object Heading  
attribute. However, text with new lines can be copied into the 
attribute, and the new lines are preserved. When you view Object 
Heading text that has new lines in the Object Properties window, only 
the first line of the text is displayed. If you edit this text in the Object 
Properties window, the text that is not displayed is removed from the 
attribute. 

Short Text  The Object Short Text attribute. 
This is the default value displayed in the object box in  
Graphics mode.  

Object Text  The Object Text attribute. 
This is displayed in the module’s main column in Document  
mode.  

 
We recommend that each object is either a heading (its Object Text is blank) 

or normal text (its Object Heading is blank), but not both. This gives a 

cleaner and more manageable structure to your module. It also means that if 

you export from DOORS to other applications that don’t have the concept 

of multi-attribute objects, you get what you expect. 

 

For example, word processors don’t let you combine heading and text in the 

same paragraph. If you don’t combine heading and text in your DOORS 

objects, each object is exported as a separate paragraph, which is what you’d 

expect. If you combine heading and text in one object, when you export to a 

word processor, the object is exported as two paragraphs, one that contains 

the heading and another that contains the text. 

 
Note   The General tab of the object properties sheet also 

displays the URL of the object and a Copy URL button. 
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Clicking Copy URL copies the object’s URL to the 

system clipboard.  

3. To edit other attribute values, click the Attributes tab. 

A list of all the attributes that apply to objects is displayed, along with the 

values they have for this particular object. 

Read-only is displayed to the left of attributes you can’t edit. 

4. Select the attribute you want to view or edit, then click View/Edit. 

5. The screen that is displayed depends on the type of attribute that 

you’re viewing. 

At the top, the name and type of the attribute is displayed. 

If you only have read access to the attribute, you cannot edit the value but 

you can select and copy it. 

6. Select the Inherit check box if you want the object to inherit the 

value of this attribute: 

• The object inherits the value from the nearest ancestor 

object that is not inheriting the value of this attribute. 

• If all its ancestors are inheriting the value of this attribute, 

you get the default value of the attribute. 

If the attribute doesn’t have a default value, you get no value. 

 

7. If you clear the Inherit check box: 

a. Enter the value you want the object to have. If you are editing a 

multi valued enumerated attribute and want to maintain the 

current settings for the affected objects, but select or clear 

certain values for all objects, go to Step 8. 

b. Use the Apply to radio buttons to specify which objects you want   

the new value to apply to: 

• Click Current object to apply the new value to the current object 

only. 

• Click Selected objects to apply the new value to all currently 

selected objects. 
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• Click Objects in current view to apply the new value to every 

object in the current view. 

8. You can edit the multi-valued enumerated attribute value of multiple 

objects without affecting the individual attribute values of those 

objects. 

For example, you have a multi-valued enumerated attribute, with 

the values A, B and C. There are three objects in your current view, 

which have the following values set for this attribute: 

• Object 1: A, B 

• Object 2: A, C 

• Object 3: B, C 

You want to remove value A from all the objects, while retaining the 

other values that are set. To do this: 

a. Select B and C in the list of values, and clear A. 

b. Select Objects in current view. 

c. Select the Remove unchecked values check box, and make 

sure the Add checked values check box is cleared. 

d. Click OK. 

e. The objects now have values as follows: 

• Object 1: B 

• Object 2: C 

• Object 3: B, C 

A is removed from all the objects, but B and C are not added to the 

objects because the Add checked values check box was not selected. 

In a similar way you can add values to selected objects, or objects in the 

current view by selecting the values you want to add, clearing the values you 

want to leave unchanged, and making sure that Add checked values is 

selected and Remove unchecked values is cleared. 

 

The Add checked values and Remove unchecked values check boxes are 

unavailable if Current object is selected, or if the attribute you are editing is 
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not a multi-valued enumerated attribute. 

9. Click OK. 

10. Click Next or Previous to display the properties sheet for the next or 

previous object in the current view. 

11. When you have finished, click OK. 

12. Save the module to make the changes permanent (click File > 

Save). 

Undoing edits 
To undo an edit, click Edit > Undo. 

You can’t use this feature while you’re editing in-place. To stop editing in-place, 

click another object or attribute (don’t double-click it or you remain editing 

in-place). 

Note   If you can’t undo the last edit, the Undo option is 

unavailable. 

Extended undo 
Any change made to a DOORS object that has been captured in the current 

history listing can be reversed (with the exception of Move operations and links). 

This gives you the power to undo all changes recorded in history, in any order. 

To use the extended undo facility: 
1. Click Edit > Object > Properties. 

You can also select the object and right-click Properties or double-

click the object’s change bar. 

The Object Properties window is displayed. 

2. Select the History tab. 

The Object History window is displayed. 
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3. Select the history record you want to restore. Select the View 

changes as redlining check box to see the changes as redlined 

text. 

4. Click the Details button to display the information about the 

selected history item in a separate window. 

Select the View change as redlining check box to turn redlining on, 

or clear the check box to view the history record without redlining. 

5. Click the OK to return to the Object Properties window. 

6. Click Restore. 

 

The object will now be restored to the previous state. Links are not 

affected when you restore a history record. All links are retained, including 

those that have been created between the date of the history record you 

are restoring and the present time. 
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If the change you want to restore is not the most recent change, a warning 

message may be displayed: 

 

 
 

Click Continue to restore the change. 

You can control whether the message is displayed by selecting or clearing the 

Warn when restoring a change other than the most recent from history 

check box on the Settings tab of the Options dialog box (Tools > 

Options...).  

 

Note  You cannot cancel a Restore operation because the 

restore takes effect immediately. You can undo by 

closing the dialog, rerunning the process, and selecting 

the most recent history record. 

Saving your changes 
When you edit data in a module, your changes are stored temporarily in your 

local computer’s memory. They aren’t saved in the database until you explicitly 

save them. 

To save your changes when you're editing a module, either: 

• Click Save  on the Commit toolbar. 

• Click File > Save. 

• Press CTRL+ S. 

When you close a module or exit DOORS, if you’ve made changes that you 

haven’t saved, a message is displayed asking if you want to save the changes. 

Click Yes to save your changes, or No to discard them. 
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Creating objects 
To create an object, you need create access to its parent. 

To create a top-level object: 
• You need create and modify access to the module 
• You must be in exclusive edit mode 

 
The edit mode is shown on the status bar at the bottom of the module 
window. To change your edit mode, click Edit > Edit Mode > Exclusive 
Edit. 

 
To create an 
object  Do this  

At the same level 
as the  
current object  

Either: 
• Click Insert > Object.  
• Press CTRL+ N.  
• If you’re editing the current object in-place, press  

CTRL+ RETURN.  
• Click New object at this level on the Object  toolbar. 

One level below 
the  
current object  

Either:  
• Click Insert, then Object Below.  
• Press CTRL+ L(the letter L is for one Level below).  
• Click New object below on the Object toolbar.  

If the current object already has children, the new object becomes the first 
child. 

 
Note  Remember to save the module after you’ve created new 

objects. 

Each object you create has a unique Absolute Number. Once an absolute 

number has been assigned to an object, that number is not used again in the 

module, even if the module is closed without saving the new object. 

Controlling access to an object 
To change the access rights for an object, you must have admin access to it. 

To change the access rights for an object: 
a. In the module window, select the object, then right-click Properties. 

a. Click the Access tab. 

The current access rights for the object are displayed. 
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You need this access 
right 

To

Read ( R ) See the object 
Modify ( M )  Change the value of any attribute.

Create and delete links from the object that is the source of 
the link.

Create ( C ) Create objects one level below the object.
Move another object to one level below the object

Delete ( D )  Delete, undelete and purge the object
Move the object

Admin (A) Change the access rights for the object. 
 

If the module is partitioned in, the access rights associated with the partition 

are displayed. These describe the maximum access that any user has. They 

override the RCMD access rights displayed for users and groups. 

For example, if a user’s entry says full access (RMCDA), but the module is 

partitioned in read only, in practice the user has only read (R) access to the 

object. 

3. Make the changes you want. 

Access 
tab 

Description 

Inherit from 
parent 

Select this check box if you want the object to inherit its parent’s access 
rights. If it’s a top-level object, it inherits access rights from the module. 

Note If you clear this check box you create an editable section for 
the current object. For best performance, try to use the DOORS 
inheritance mechanism whenever possible, and avoid creating 
editable sections unless you need them. For more information, see 
“ Understanding editable sections, “ on page 45.

Add To add a new entry to the list of access rights: 
a Click Add 
The Add Access window is displayed. 
b In the Name box, select the name of the user or 

group that you want to add an entry for. 
c Select the access rights you want to give them, then 

click OK.
Remove To remove an entry from the list of access rights, select the entry, an then 

click Remove. 
Edit To edit an entry in the list of access rights:

a Select the entry then click Edit. 
The Edit Access window is displayed 
b Select the access rights you want to give them, then 

click OK.
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Access 
tab

Description 

Additional 
Access 
rights 

Select the additional access rights that you want to propagate with the 
create access. 
the additional rights are propagated to the child objects in the tree below 
this object that inherit their access rights from this object. 

 
4. Click OK. 

5. Save the module to make the changes permanent (click File > 

Save). 

Promoting and demoting objects 

You can manipulate the object hierarchy by promoting and demoting objects. 

• When you promote an object it becomes the next sibling of the object that 

was its parent. 

• When you demote an object it becomes the last child of the object that 

was its preceding sibling. 

An object can’t be demoted to be the child of a deleted object, so the object 

must have an undeleted preceding sibling. 

Children of objects that are being promoted or demoted move with their parent 

to the new location in the hierarchy. 

Promotion and demotion of objects is restricted as follows to ensure that object 

ordering (with no sort applied) is not changed: 

• You can’t promote or demote deleted objects. However if you select an 

undeleted object and it has deleted children, the object can be promoted 

or demoted and its deleted children are promoted or demoted along with 

it. 

• You cannot promote or demote objects when a sort or filter is applied to 

the module. 

To promote an object: 
1. Select the object or objects you want to promote. 

2. Select Edit > Object > Promote, or click Promote on the Object 

toolbar. 
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The object is promoted, and becomes the next sibling of its former parent. 

To demote an object: 
1. Select the object or objects you want to demote. 

The object must have an undeleted preceding sibling. 

2. Select Edit > Object > Demote, or click Demote  on the Object 

toolbar. 

The object is demoted and becomes the last child of the object that was its 

preceding sibling. 

Swapping Object Heading and Object Text attributes 
You can swap the Object Heading and Object Text attributes. When you swap 

the attributes the contents of the Heading attribute becomes Object Text and 

the contents of the Text attribute becomes Object Heading. 

This operation can be used on objects that contain both Object Heading and 

Object Text, and on objects that contain one or other. 

Caution  When you swap Object Text with Object Heading, the 

text may be truncated, as the Object Heading attribute 

cannot hold as many characters as the Object Text 

attribute. 

To swap attributes: 
1. Select the object that contains the Object Heading and/or Object 

Text you want to swap. You must have read and modify access to 

the Object Heading and Object Text attributes in the module. 

2. Select Edit > Object > Swap, or click Swap  on the Object Edit 

toolbar. 

The contents of the Object Heading attribute becomes Object Text and 

the contents of the Object Text attribute becomes Object Heading. 

Splitting Object Heading from Object Text 
When you split an object, a new object is created to replace the selected object, 

and the text in the Object Heading is moved into the new object. The selected 

object retains the Object Text, and becomes the first child of the new object. 
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If the selected object has any children, they become siblings of the selected 

object, with the new object containing the Object Heading as their parent. 

Note  If you have a module open in shareable edit mode, you can’t 

split the top object in a locked section. However, you can 

split child objects. 

To split Object Heading from Object Text: 
1. Select the object you want to split. You must have read and modify 

access to the Object Heading attribute and read access to the 

Object Text attribute. 

2. Select Edit > Object > Split. 

 

A new object is created to replace the selected object. The text in the 

Object Heading is moved into the new object. 

Deleting, un-deleting and purging objects 
Deleting an object doesn’t destroy the object. It simply marks the object and all 

the objects in the tree below it as deleted, which stops users from being able to 

easily access them. To destroy the object, you must purge it once you’ve deleted 

it. 

Purging deleted objects removes them permanently from the database. 

If the object you want to delete has an in-link, this link must be deleted before 

the object can be deleted. If the object has descendants, any in-links to those 

objects must also be deleted before the parent object can be deleted. This 

prevents dangling links being left at the source object. 

To delete the link: 
• The link module and the module containing the source object must be 

open. 

• You must have modify access to the source object and the link module. 

 

When you delete an object that has an out-link, the link is not actually deleted 

until you purge the object and then save the module after purging the object. 
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To delete, undelete or purge an object, you must have delete access to the 

object and to all objects in the tree below it. 

Note  You can’t delete or purge objects that have descendants if 

sorting is turned on. Leaf objects can be deleted when 

sorting is on. 

To delete an object: 
1. In the module window, select the object you want to delete, then 

click Edit > Object > Delete. 

You can also right-click Delete or press DELETE. 

2. Save the module to make the change permanent (click File > 

Save). 

The object is deleted. Its object identifier is never reused by any 

future objects. 

To undelete an object: 
1. In the module window, make sure that deleted objects are being 

displayed. 

If necessary, click View > Show > Deletions. 

Deleted objects have red text, and their change bars  are black  . 

2. Select the object you want to undelete, then click Edit > Object > 

Undelete. You can also right-click Undelete. 

3. Save the module (click File > Save). 

To purge an object: 
1. In the module window, make sure that deleted objects are being 

displayed. 

If necessary, click View > Show > Deletions. 

2. Select the deleted object you want to purge, then click Edit > Object 

> Purge. You can also right-click Purge.... 

Deleted objects are colored red, and their change bars are black  . 

3. A message is displayed asking if you really want to purge the 

objects. Click Yes. 
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4. Save the module to make the change permanent (click File > 

Save). 

The object and all objects in the tree below it are permanently 

removed from the database. 

To purge all deleted objects: 

1. In the module window, select Edit > Purge All. 

A confirmation message is displayed. 

2. Click Yes to purge all the deleted objects in the module. 

Deleted objects are purged even if they are not being displayed. 

Understanding the spelling checker 
The spelling checker allows you to check the spelling of text and string attributes 

in any of the language dictionaries that are supported by DOORS. For 

information on supported languages, see . 

Each attribute has a locale language, which is displayed beside the attribute 

name in the spelling checker. You can check more than one attribute at a time, 

but attributes that are checked together must have either the same locale or have 

no locale set. 

The language that will be used for the spelling check is displayed in the Selected 

Language list box. By default, the attribute is checked in its locale language, as 

displayed in the attribute list. If the selected attribute does not have an 

associated language, or if the language is not supported, the language that is 

used by default depends a setting on the Spelling tab of the Options dialog box. 

For information about this setting, see. 

If you want to check the attribute in a different language, you can select the 

language you want to use from the Selected Languages list box. 

Checking spelling 
To check the spelling of the text in your module: 

1. In the module window, click Tools > Spelling. 

The Check Spelling dialog box is displayed. 
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2. The attributes that can be checked are listed in the Check box. The 

list only contains text and string attributes that are displayed in the 

current view. The locale of each attribute is displayed in the 

Language column.  

By default, DOORS checks the spelling and grammar for the Object 

Text attribute. You can check additional attributes by selecting them 

from the list. You can only check attributes at the same time if they 

have the same locale or if they do not have a locale set. If you want 

to check the spelling in attributes that have different locales, you 

have to check them individually. 

3. The language that will be used for the spelling check is displayed in 

the Selected Language list. If you want to check in a different 

language, select it from the list. 

Note  If you want to correct an error, you must have an edit 

lock on the object or attribute and have modify access to it. 

4. By default, all the objects in the current view are checked. 

Select Current Object Only or Current Object And Children, if you 

want to limit the objects that are checked. 
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5. Click Start to start checking spelling and grammar. 

When an error is detected: 

• The sentence that contains the error is displayed in the Sentence box, 

with the error highlighted. 

• A description of the error is given in the Explanation box. 

• If there are any suggested corrections, these are listed in the 

Alternatives box. 

Click To 
Ignore Leave the highlighted error unchanged, and continue checking 
Ignore ALL 
/  
Ignore Rule

Leave the highlighted error unchanged, and ignore any further 
occurrences of the highlighted word, or type of grammar error. 

Ignore 
attribute 

Leave the highlighted error unchanged, and ignore the attribute for the 
remainder of the spelling check. 

Skip 
Sentence 

Ignore any errors in the current sentence, and continue checking in the 
next sentence. 

Add Add the selected word to the client dictionary of the database dictionary. 
You must have modify access to the database dictionary to add words to 
it.  
If you select Client, the selected word is added to the client dictionary. This 
dictionary is not available to other DOORS clients. 
If you select Database, the selected word is added to the database 
dictionary. The dictionary is available to all of the DOORS clients that 
access the database. 

Replace Replace the highlighted word with the word you have selected in the 
Alternatives box. 
You can also edit the text in the Sentence box and apply rich text 
formatting to it, then click Replace to commit the change. 
The sentence is checked again if you edit text in the Sentence box.

Replace All Replace every occurrence of the highlighted word in the object with the 
word you have selected in the Alternative box. 

Stop Stop the spelling check. 
Close Finish the spelling check. 
 

If an error is found in an object or attribute to which you have read only 

access, you can choose to continue checking values to which you have 

read only access, or only check the values to which you have modify 

access. You cannot correct errors unless you have modify access to the 

object or attribute. 
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6. Save the module to make the changes permanent (click File > 

Save). 

You can configure the spelling checker using the Options dialog box. For 

more information, see “Configuring the spelling checker,” on page 387. 

For more information about locales, see Understanding locales and 

Unicode options in the Managing DOORS manual, which is available on 

the Telelogic Lifecycle Solutions DVD. 

Inserting symbols 
When you edit an object in-place, you can insert symbols, such as square root 

symbols, and Greek characters. 

You can only insert symbols into attributes of type text or string. 

To insert a symbol: 
1. In the module window, double-click the text you want to edit. 

2. Position your cursor at the place where you want to insert the 

symbol. 

3. Click Insert > Symbol. 

4. In the Character set box, select the character set you want to use. 

5. Click the symbol you want to insert. 

The symbol is inserted at the position of your cursor. 

6. Click Close. 

7. Save the module to make the changes permanent (click File > 

Save). 

Symbols are not displayed in the left pane of the Module Explorer. In the 

left pane, a text description of the symbol is displayed. For example, the 

text diamond is displayed instead of the diamond symbol. 

Note  The symbol is not displayed when it is inserted in text. 

This symbol inserts a soft hyphen in a word, which tells the 

text reader that the word can break across a line at this point. 

Inserting URLs 
The values of attributes of type text or string can include live URLs. The URLs 
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can have the following formats: 

• http:// 

• https:// 

• ftp:// 

• file:// 

To insert a URL, simply type the URL. For example, type 

http://www.telelogic.com/doors/ 

The URL is automatically highlighted in blue. 

The URL is live. If you double-click it, your browser opens the web page 

associated with URL. 

A URL that is displayed in a traceability column is not live. To activate the 

URL, you must follow the link to the source or target object, and double-click 

on the URL there. 

You can also insert URLs as external links.  

Note  Microsoft Project bookmarks are not supported in DOORS. 

Note Your user options specify which browser is used when you 

double-click a URL in DOORS. To change the browser, in 

the DOORS Explorer, click Tools > Options, then use the 

Settings tab to specify the browser you want to use. 

Chapter  5  Editing using forms 
 
This chapter contains the following topics: 

• Overview 

• Creating a new form 

• Editing forms 

• Running forms 

• Deleting forms 
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Overview 
You can create forms for viewing and editing data in modules. You select the 

attributes you want to display in the form and optionally create a view of those 

attributes in the module. Forms can be saved and accessed from the module at 

any time. 

Creating a new form 
1. In the module window, select Tools > Forms > New Form. 

The Form Generator dialog box is displayed. The following table 

describes the options that are available: 

 
Option Description 
Form Name The name you want to give the form. 
Object 
Attributes 

The attributes in the module that are available to display in the form. 

Form 
Attributes 

The attributes that will be displayed in the form. 

Add adds the attributes selected in the Object attributes list to the Form 
Attributes list. 

Remove  Remove the attributes selected in the form attributes list. 
 

Move Up  Moves the selected attribute up the Forms attribute list. The attributes are 
displayed on the form in the order they appear in the Form Attributes list. 

Move down Moves the selected attributes down the Forms attribute list. 
The attributes are displayed on the form in the order they appear in the 
Forms attributes list. 

Use space 
to align 
elements 

Use the slider to dictate the distance between the left hand edge of the 
form and the input boxes for the attributes you have selected. 
The form is not automatically formatted, so if you don’t use the slider to 
space the elements, the input boxes will overlap their labels. 

Read-only-
form 

Makes the form read-only. This does not change the access rights to the 
attributes that are displayed, it just prevents users from editing the 
attributes using the form. 

Attributes in 
the current 
view only 

Changes the Object attributes list to only display the attributes that ae 
displayed in the current view. 
If you want to display system attributes on the form, add them as columns 
to the module view, then select this check box on the form. 

Create 
View 

Create a view in the module that displays in columns the attributes you 
have added to the form. 

Preview Previews the form. 
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2. Select the attributes you want to display on the form from the 

Object Attributes list and click Add. 

3. Select the check box in the column of the Form attributes panel for 

any attributes that you want to display on the form, but that you 

don’t want to be editable. This does not change the access rights to 

the attribute, it just makes it read only on the form. 

4. If you want to preview the form before you create it, click Preview. 

5. If you want to create a module view that displays the attributes you 

have added to the form: 

a. Click Create View. 

The Save View dialog box is displayed. 

b. Type a name for the view and click OK. 

If a view with that name already exists, you will be prompted to 

overwrite the view. 

6. Click OK to create the form. 

Editing forms 
You can edit forms that you have created previously. 

To edit a form: 

1. In the module window, select Tools > Forms > Edit Forms. 

2. Select the form you want to edit from the list and click OK. 

3. You can change the attributes that you want to display on the form, 

and the options that apply to the form, but not the name of the form. 

4. Click OK when you are finished. 

The form is updated. 

Running forms 
When you have created a form, you can use it to view and edit the attributes that 

are included in the form. You can only edit attribute values if you have modify 

access to them and if they have not been set to display as read-only on the form. 

To view and edit attributes using a form: 
1. In the module window, select Tools > Forms > Run Forms. 
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2. Select the form you want to view and click OK. 

The form opens. The attributes are those that were selected to be 

displayed on the form when it was created or last edited. The 

attribute values displayed are those of the currently selected object. 

Some or all attribute values may be read-only, depending on your 

access rights, and whether they were set to be read-only when the 

form was created or last edited. 

3. Select Automatically write changes to module if you do not want to 

be prompted to save your changes each time you move to a 

different object. 

4. Use the form to edit different objects in the module by clicking the 

Previous, Next and Go To buttons. If you have not selected to 

automatically write changes to the module, you will be prompted to 

save any changes you have made. 

5. Click OK to save changes and close the form. 

Deleting forms 
To delete a form: 

1. In the module window, select Tools > Forms > Delete Form. 

A list of the available forms is displayed. 

2. Select the form you want to delete and click OK. 

The form is deleted. 
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Chapter  6  Using views 
 

This chapter contains the following topics: 

This chapter contains the following topics: 

• Understanding views 

• Saving your current view 

• Understanding inheritance in views 

• Setting default views 

• Editing a view 

• Controlling access to a view 

• Deleting a view 
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Understanding views 
When you create a formal module, the default view of the module is the 

Standard view. This displays the module explorer, the ID column, and the main 

column. 

You can edit the Standard view and save it with a different name, but you cannot 

save a view and name it Standard view. 

 

When you work with modules, your current view is what’s currently displayed 

on your screen. It’s a combination of the columns that you can see, the sort or 

filter you are currently using, and so on. 

You can save your current view, so you can use it again later, for example in 

your next DOORS session. This saves you having to set up all the display 

options again. 
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The names of all the views that have been created for a module are shown in the 

Views drop-down list on the View toolbar. The full name of the view that is 

currently selected is displayed when you roll over the list box. 

To load a different view, select it from the drop-down list. Click away from the 

drop down list to cancel a selection. 

To reload the current view, click View > Reload. 

Note  A warning is displayed if you make changes to the display 

that will be lost when you select a different view or close the 

module. You can stop this message being displayed by 

changing your user options. 

Saving your current view 
To save your current view: 

1. In the module window, click View > Save As. 
2. In the Name box, type the name you want. If you want to overwrite 

an existing view, type the name of the view you want to overwrite. 
 
Note  View names are case sensitive, so if you want to 

overwrite an existing view, you must type the name 
exactly as it appears in the Views list. 
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3. Select the display settings you want to save with the view. 
 
Setting  Description  

Current object  Saves information about which object is the 
current  object  

Window size 
and position  

Saves information about the current window 
size and position  

Filtering  
Saves the current filtering settings (whether 
filtering is turned on and what the current 
filter is)  

Sorting  
Saves the current sorting settings (whether 
sorting is turned on and what the current sort 
is)  

Inherit 
undefined  
settings from  

Select a view from which settings are 
inherited if they are not defined in the current 
view.  

 
The saved settings are automatically applied whenever you load the view. If a 

check box is not selected, loading the view doesn’t change the associated 

display setting. 

For example: 

• If the Filtering check box is not selected, loading the saved view 

does not change the current filtering settings. 

• If the Filtering check box is selected, when you subsequently 

load the saved view, the filtering settings are changed to be the 

same as they are 

now. If filtering is off now, then filtering is off when you load the saved 

view. 

4. Use the Default check boxes if you want the saved view to be a 

default view for the module: 

• Select For module if you want it to be the module default view. You 

must have modify access to the module to be able to select or clear 

this check box. This option is not available if Private is selected in 

the Access to this view pane. 



Centers for Medicare & Medicaid Services  
  

89  

• Select For current user if you want it to be your own user default 

view. 

5. Use the Access to this view section to define the access rights for 

the view. 

 
If you select  Then  
Private  You will have full access to the view, and everyone else will have access 

None. You cannot make the view private if the For Module check box is 
selected in the Default pane of this dialog box.  

Public  You will have full access to the view, and everyone else will have read 
access.  

Custom  You will have full access to the new view. The custom access rights for all 
other users and groups that are defined in the view that is currently displayed 
in the module are inherited by the new view. If you are overwriting an existing 
view, the access rights for the existing view are overwritten with the access 
rights of the view that is currently displayed in the module. If the view that is 
displayed in the module when you save a new view is the Standard view, you 
cannot select Custom for the Access to this view. This is because the 
Standard view cannot have custom access rights, so there are no custom 
access rights for your new view to copy.  

 
You can edit the access rights for a view using the Manage views dialog 

box. For example, you might have created a private view, but want to allow 

specific DOORS users access to it. 

6. Use the Advanced tab if you don’t want to save other display 

options with the view. 

7. Click OK. 

Understanding inheritance in views 
When you create a view you can make it inherit undefined settings from a 

different view in the module. Undefined settings mean any of the options that 

are not selected in the Remember settings for frames on the General and 

Advanced tabs when you save a view. This is useful if you want to save a new 

view of a module, but use a setting that has been saved with an existing view. 

For example if you already have a filter saved with View X and you want to use 
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that filter again in View Y, you can select View X in the Inherit undefined 

settings from list when you create View Y. As long as you make sure that 

Filtering is not selected in the Remember settings for pane of View Y, it will 

inherit the filter from View X. 

When you select View Y, View X is pre-loaded: 
• Settings that are selected in View X are applied to the view. 

• When View Y is loaded, any settings that are selected in View Y 

overwrite settings in View X. 

• Any settings that are not selected in View Y are inherited from 

View X. If a setting is not selected in either View Y or View X, the 

module default is used. 

So, you could create a sort in the current view and inherit a filter from an existing 

view. As long as the Sorting check box is selected and the Filtering check box is 

cleared in the Remember settings for pane of the current view, both the sort 

and the filter will be applied when you select the view. 

Views inheritance and access controls 
 

When you set a view to inherit settings from another view, all the users that have 

read access to the current view must also have read access to the view from 

which it inherits settings. When you save a new view, only the existing views that 

allow the same users read access as the new view are displayed in the Inherit 

undefined settings from list. 

A view that inherits access controls from the module cannot inherit settings 

from a view which does not, and to which any users may not have Read access. 

If you change the access rights on an existing view that is inheriting settings, so 

that you give read access to users who do not have read access to the view from 

which it inherits settings, then the inheritance is invalid. You are prompted to 

either confirm the change in access and remove the inheritance, or cancel the 

change in access. 

If you remove read access from a view that has its settings inherited by other 

views, so that users who have read access to inheriting views do not have read 
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access to this view, then the inheritance is invalid. You are prompted to either 

confirm the change in access and remove the inheritance from views which are 

affected, or cancel the change in access. 

Setting default views 
 

A module has two different types of default view: 
• User default view 

Each user can set their own default view for the module. If you’ve defined 

a user default view for a module, that view is displayed when you open the 

module. 

• Module default view 

This is the view that a user sees when they open a module and they 

haven’t defined a user default view for the module. 

 
Note  If you make the module default view read only, other 

users cannot change the settings within the view. 

However, a user with modify access to the module can 

overwrite the module default view with a different view. 

To set the default views for a module: 
1. In the module window, click View > Manage Views. 

2. On the left of the screen, select the view that you want to be the 

default. 

3. On the General tab on the right: 

a. Select the For module check box to make the view the module 

default. 

You must have modify access to the module to be able to select or 

clear this check box. 

b. Select the For current user check box to make the view your 

personal user default. 

4. Click OK. 
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Editing a view 
To edit a view: 

1. In the module window, click View > Manage Views. 

2. On the left of the screen, select the view you want to edit. 

You must have modify access to the view. 

3. On the General tab, you can edit the view name, the settings that 

are remembered with the view, and if the view is a default view. 

4. To change the general properties of the view, use the General tab 

on the right of the screen. 

5. Select the display settings you want to save with the view. 

The following table describes the options on the General tab. 

General Tab Description 
Name The name of the view 
Current object Select this check box to save information about the current object. 
Window size 
and position 

Select this check box to save information about the current window size and 
position. 

Filtering  Select this check box to save the current filtering settings (whether filtering is 
turned on and what the current filter is) 

Sorting  Select this check box to save the current sorting settings ( whether sorting is 
turned on and what the current sort is ) 

Inherit 
undefined 
settings from  

If the view does not currently inherit settings from another view, this option is 
unavailable. 
If the view does currently inherit settings, you can clear the inheritance, but 
you cannot change the view from which it is inheriting, When you clear the 
inheritance, the option becomes unavailable. 
If you want to change the view’s inheritance, you must save the view again. 

For module Select this check box if you want this view to be the module default view. 
You must have modify access to the module to be able to select or clear this 
check box. 

For current 
user 

Select this check box id you want this view to b your user default view for the 
module. 

 

The saved settings are automatically applied whenever you load the view. If a 

check box is not selected, loading the view doesn’t change the associated 

display setting. 

For example: 

• If the Filtering check box is not selected, loading the saved view does 
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not change the current filtering settings. 

• If the Filtering check box is selected, when you subsequently load the 

saved view, the filtering settings are changed to be the same as they are 

now. If filtering is off now, then filtering is off when you load the saved 

view. If filtering is on now, then filtering is on when you load the saved 

view. 

6. To change the access rights for the view, click the Access tab. 

For more information, see “Controlling access to a view,” on page 

94. 

7. To change the advanced properties of the view, click the Advanced 

tab. 

Select the display settings you want to save with the view. The 

saved settings are automatically applied whenever you load the 

view. 

Select To 
Outlining Save the outlining setting ( shown on the View menu ) with the view.  
Compression  Save compression settings with the view. 
Graphics 
mode 

Save the display mode setting ( shown on the view menu) with the view. 

Graphics links Save the Show Graphics Links settings (shown on the View menu) with the 
view. 

Module 
Explorer 

Save the Module Explorer setting ( shown on the View menu ) with the view. 

Link arrows  Save the Show Link Arrows setting ( show on the View menu) with the view. 
Deleted 
Objects 
 

Save the Show Deletions setting ( shown on the View menu ) with the view. 

Table cells Save the Show Table Cells setting ( shown on the View menu ) with the view. 
Filter table 
contents 

Save the advanced filter option for hiding non-matching table cells with the 
view. 

Default table 
cell attribute 

Save the Table Attribute setting with the view. 

Pictures Save the Show Pictures setting ( shown on the View menu ) with the view. 
Display level  Save the display level setting ( shown on the View menu) with the view 
Columns Save the information about columns with the view. 
Graphics 
column 

Save information about which column’s values are displayed in the object 
boxes in Graphics mode. 

Graphics Save information about which column’s values are displayed in the datatip in 
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Select To 
datatip Graphics mode. 
Indentation of 
main column 

Save the auto-indentation setting for the main column. 

Current 
selection 

Save information about currently selected objects with the view. 

Filtered 
objects’ 
ancestors 

Save the advanced filter option for showing ancestors with the view. 

Filtered 
objects’ 
descendants 

Save the advanced filter option for showing the descendants with the view. 

Set All Select all the check boxes on the tab. 
Clear All Clear all the check boxes on the tab. 

 

 

 

8. Click OK. 
 

Controlling access to a view 
 

To change the access rights for a view, you must have admin access to it. 
 
To change the access rights for a view: 
 

1. Open the module that contains the view you want to change. 
 

2. Click View > Manage Views. 
 

3. Select the view, then click the Access tab.  The current access 
rights for the view are displayed. 

You need this 
access right 

To 

Read (R) See the view. 
Make it your user default view. 

Modify (M) Change the view in any way. 
Delete (D) Delete the view. 
Admin (A) Change the access rights for the view. 
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If the module is partitioned in, the access rights associated with the partition  are 

displayed. These describe the maximum access that any user has. They  

override the RCMD access rights displayed for users and groups. 

 

For example, if a user’s entry says full access (RMDA), but the view is  

partitioned in read only, in practice the user has only read (R) access. 

4. Make the changes you want. 

 
Access tab Description 
Inherit from 
parent 

Select this check box if you want the view to inherit its access rights from 
the module. 
When this check box is selected, the list of access rights is unavailable, 
and shows what access rights the view is inheriting. 

Add To add a new entry to the list of access rights: 
a. Click Add. 
The Add Access window is displayed. 
b. In the Name box, select the name of the user or group that you want 
to add an entry for. 
c. Select the access rights you want to give them, then 
click OK. 

Remove To remove an entry from the list of access rights, select 
the entry, and then click Remove. 

Edit To edit an entry in the list of access rights: 
a. Select the entry then click Edit. 
The Edit Access window is displayed. 
b. Select the access rights you want to give them, then 
click OK. 

 
 
If you change the access rights on a view that is inheriting settings, so that  you 

give read access to users who do not have read access to the view from  which it 

inherits settings, then the inheritance is invalid. You are prompted to  either 

confirm the change in access and remove the inheritance, or cancel  the change 

in access.  

 
If you remove read access from a view that has its settings inherited by other   

views, so that users who have read access to inheriting views do not have  read 

access to this view, then the inheritance is invalid. You are prompted to  either 
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confirm the change in access and remove the inheritance from views  which are 

affected, or cancel the change in access. 

Deleting a view 
 
Note  You can’t undelete a view once you’ve deleted it. 
 
To delete a view: 
 

1. In the module window, click View > Manage Views. 
 

2. On the left of the screen, select the view you want to 
delete, then click Delete. 

 
You must have delete access to both the module and the 

view.  

3. A message is displayed asking if you really want to 

delete the view. Click Yes.   

4. Click OK. 
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Chapter  7  Filtering and Searching 
 

This chapter contains the following topics:   
 

• Searching with the DOORS Explorer 

• Finding text in a module 

• Finding and replacing text 

• Going to a particular object 

• Understanding filters 

• Using a simple filter 

• Using an advanced filter 

• Turning filtering on and off 
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Searching with the DOORS Explorer 
In the DOORS Explorer, you can: 

• Search for projects, folders and modules that have a particular name 

• Search for formal modules that contain specific text in their Object 

Heading or Object Text attribute 
To search with the DOORS Explorer: 

1. In the DOORS Explorer, select the project, folder or module that 

you want to search. 

2. Click Tools > Find. 

3. If you want to search for projects, folders or modules with a 

particular name: 

a. Type the name in the Named box. 

The name can include asterisk (*) and question mark (?) 

wildcard characters. 

b. Select Search description to search the project, folder and 

module descriptions. 

c. Select the Match case check box if you want a case-sensitive 

search. 

4. The Look in box shows the project or folder to be searched. 

By default, the search includes all the projects and folders under 

this project or folder. Clear the Include Subfolders check box if 

you only want to search the modules in this project or folder. 

 

If you selected a module in Step 1, the Look in box contains the 

name of the folder or project that it’s in. 

5. If you want to search for modules that contain specific text in their 

Object Heading or Object Text attribute: 

a. Type the text you want to search for in the Containing text box. 

b. Select the Use Wildcards check box if the text you typed in the 

Containing text box includes asterisk (*) or question mark (?) 

wildcard characters. 
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c. Select the Match case check box if you want a case-sensitive 

search. 

6. Click Find Now to start the search. 

A list of all the items that matched your search is displayed. 

Double-click an item to open it. 

Finding text in a module 
This topic describes how to search a formal module for all the objects that 

contain specific text. For example, you can search for objects that contain the 

word accelerate. 

To search a module for objects that contain specific text: 
1. Open the module you want to search. 

2. In the module window, click Edit > Find. 

The Find and Replace dialog box is displayed. 

 
Any search options that have already been set are displayed. In this example, 

Highlight matches, Match case and User regular expression have 

already been set. 

 

3. In the Find what box, type the text you want to search for. 

4. If you to change the search options, select Advanced and select or 

clear the appropriate check boxes: 

• Select Highlight matches if you want matches to be highlighted in 

the module window. When a match is found: 

• If the match is in an attribute that is displayed in the current view, 

and that attribute can be edited in-place, the matching text is 
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highlighted. The object and attribute in which the match is found 

is also highlighted with a colored outline. 

• If the match is in an attribute that is displayed in the current view, 

but cannot be edited in-place, for example an enumerated 

attribute, the object and attribute in which the match occurs is 

highlighted with a colored outline, but the matching text is not 

highlighted. 

• If the match is in an attribute that is not displayed in the current 

view, you are prompted to add the attribute to the current view. If 

you add the attribute, the rules described above apply. If you do 

not add the attribute, this match and any other matches found in 

the attribute are highlighted with a colored line above and below 

the object containing the match. 

• Select Match case if you want to perform a case-sensitive 

search. 

• Select Use regular expression if you want to use a regular 

expression in the Find what box. 

5. In the Find in box, select the attributes or Layout DXL you want to 

search. 

By default, only Object Heading and Object Text are selected. 

• Click All in View to select all the attributes displayed in your 

current view. 

• Click Select All to select all the attributes in the list. 

• Click Clear All to clear all the attributes in the list. 

6. Click Find Next to find the next object that contains the specified text, 

or click Find Previous to search backwards. 

7. When you have finished, click Close. 

Finding and replacing text 
You can search for and replace text within a formal module. For example, you 

can search for the word petrol and replace it with gas. 

To find and replace text within a formal module: 
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1. In the module window, click Edit > Replace. 

The Find and Replace dialog box is displayed. 

 
Any search options that have already been set are displayed. In 

this example, 

Match case and User regular expression have already been set. 

2. In the Find what box, type the text you want to search for, and in 

the Replace with box, type the text you want to replace it with. 

3. If you to change the search options, select Advanced and select 

or clear the appropriate check boxes: 

• Select Match case if you want to perform a case-sensitive search. 

• Select Use regular expression if you want to use a regular 

expression in the Find what box. 

4. In the Replace in box, select the attributes you want to search. By 

default, only Object Heading and Object Text are selected. 

• Click All in View to select all the attributes displayed in your 

current view. 

• Click All to select all the attributes in the list. 

Note You can only use the Replace function if you have 

modify access to the attributes being searched. 

5. Click Find Next to find the next object that contains the specified 

text, or click Find Previous to search backwards. 
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• Click Replace to replace every occurrence of the specified 

text in the current object 

• Click Replace All to replace every occurrence of the specified 

text throughout the module 

6. When you have finished, click Close. 

Going to a particular object 
When you have a module open, you can go directly to a particular object in the 

module if you know its absolute number or its section number. 

Note You can only go to an object in the current view. 

To go directly to a particular object: 
1. In the module window, either: 

• Click Edit > Go To. 

• Press CTRL+G. 

2. Type in the section number or absolute number of the object you 

want to go to, or select a number that you previously entered from 

the list. 

• If you enter a number containing a decimal point, for example 

5.2 or 6., DOORS goes to the object with that section 

number. 

• If you enter a whole number, for example 5, DOORS goes to 

the object with that absolute number. 

• If you enter a valid module prefix followed by valid object 

number, DOORS goes to the object with that Object 

Identifier. 

3. Click Go To. 

If the object with the specified absolute number or section number 

is in your current view, it becomes the current object. 

The last seven numbers that you have typed are stored in the list 

until you close the module. They can be accessed by clicking the 

down arrow. 

4. Click Close. 



Centers for Medicare & Medicaid Services  
  

103  

Understanding filters 
Filters let you control what data is displayed or your screen. You can use them to 

filter out data you don’t want to see. 

For example, you can filter out all objects except those that contain the word 

steering. Or you can filter out all objects except those that have links. 

There are two types of filter, simple and advanced. 

Simple filters 
With a simple filter, you can either: 

•  Filter on the contents of every attribute of type text or string. 

• Filter on the Object Heading number. 

• Filter on the contents of any column, whether it is a traceability column 

or any other custom column created by DXL. 

• Filter on the value of a single attribute of any type. 

• Filter on the basis of whether the object has links. 

• Filter on the basis of whether the object is either the current object or a 

leaf object. 

An object is a leaf object if it doesn’t have any children. In the left pane of 

the Module Explorer, leaf objects don’t have a plus or minus sign 

because there is nothing to expand below them. 

Advanced filters 
With an advanced filter, you can: 

• Combine together simple filters to create a complex filter. 

For example, you can display objects that contain the word steering 

and that also have links. 

• Specify filter options that control what is displayed. 

For example, you can control whether only the objects that match your 

filter are displayed, or whether their ancestors or descendants are 

displayed too. 

Note  Filtering only affects the right pane of the module. The left 

pane always shows all the data. 
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Using a simple filter 
To use a simple filter: 

1. In the module window, click Tools > Filter > Define..., or click Filter 

properties  on the Display toolbar. 

2. Use the Attributes tab if you want to filter on an attribute. 

Note If you are filtering on a date, you must use the legacy 

date format, which is dd month yyyy with the month 

name in english for date only. For date and time use 

mm/dd/yy and, optionally, hh:mm:ss. 

 

Specify the attribute you want to use for your filter. For example, if you want 

to only display objects that contains the word steering: 

a. Select Any string or text attribute in the Attribute box. 

b. Select contains in the Condition box. 

c. Type steering in the Value box. 

3. If the value in the Condition box is contains: 

a. Select the Match case check box if you want to set up a case-

sensitive filter. 

b. Select the Regular Expression check box if you want to use a 

regular expression.  

4. If you want to filter objects on the basis of what links they have, 

click the Links tab, then define your link criteria. 

For example, if you only want to display objects that have in-links, 

select have and in-links in the top two boxes. To show: 

• All the objects in the module that have inlinks select going 

through any link module. 

• Only in-links contained in a specific link module, select going 

through link module, then browse to the link module. 

5. If you want to filter objects on the basis of whether they are either 

the current object or leaf objects, click the Objects tab, then click 

the appropriate radio button. 
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An object is a leaf if it doesn’t have any children. In the left pane of 

the Module Explorer, leaf objects don’t have a plus or minus sign 

because there is nothing to expand below them. 

6. Alternatively, if you want to filter the contents of columns, click the 

Columns tab. 

a. Select the column you want to filter in the Column box. 

b. Type what you want to filter for in the Contains box. 

c. Select the Match case check box if you want to set up a case-

sensitive filter. 

d. Select the Regular Expression check box if you want to use a 

regular expression. 

7. Click Apply or OK. 

The module background color changes to show that a filter is being applied to 

the data. The color depends on the display scheme you are using. For example, 

in the Modern display scheme the background changes to gray, and in the 

Classic display scheme it changes to green. 

If a simple filter is currently applied to the module, the filter settings are 

displayed in the filter dialog when it is opened. 

 
Note  Filtering only affects the right pane of the Module Explorer. 

The left pane always shows all the data.  

Statistics 
If you click Apply after defining your filter, the statistics box will display the 

following information: 

 

Total Objects  The total number of objects in the current 
module.  

Accepted  The number of objects that fulfill the filter criteria.  

Rejected  The number of objects that do not fulfill the filter 
criteria.  
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Using an advanced filter 
For information on filters, see “Understanding filters,” on page 105. 

For information on using simple filters, see “Using a simple filter,” on page 106. 

To use an advanced filter: 
1. In the module window, either: 

• Click Tools > Filter > Define.... 

• Click Filter properties  on the Display toolbar. 

2. Click Advanced. 

3. There are four tabs at the top of the screen: Attributes, Links, 

Objects, and Columns. 

4. Use these tabs to define a simple filtering criteria, then click Add 
to add it to the list of rules.  

5. Use the And, Or and Not buttons to define complex filtering 

criteria. 

The following table describes the buttons on the Advanced Filter window. 

Use  If you want to  
And  Include all the objects that match two or more filtering criteria. For 

example, you want to include all objects that have a priority greater 
than 3 and that contain the word steering. Select the rules you 
want to and together, then click And.  

Or  Include all the objects that match one or more filtering criteria. For 
example, you want to include all objects that either have a priority 
greater than 3 or contain the word steering, or both. Select the 
rules you want to or together, then click Or.  

Not  Include all the objects that don’t match a particular filtering criteria. 
For example, you want to include all objects that don’t contain the 
word steering. Select the rule, then click Not.  

And, Or, and Not add a new rule to the list. 

 

To delete one or more filter rules from the list, select the rule then 

click Delete. If you delete a filter rule that has been applied to the 
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module, the rule is displayed again the next time you open the 

Advanced Filter dialog box. 

6. Select the rule you want to apply to your current view. 

If you have created a complex and lengthy rule, it may be difficult 

to view the complete definition in the Filter Definition window. If 

you want to view the complete definition, select it in the filter 

definition pane and click the Description button. A dialog box 

containing the complete filter definition is displayed. 

Use the following filter options to control what’s displayed on your screen. 

 

 

Select  To  
Show 
ancestors  

Display all the ancestors of the objects that match the filter, as well as the 
objects themselves. For each object that matches the filter, DOORS displays 
its parent, grandparent, and so on. This lets you see where the objects that 
match the filter fit in the object hierarchy.  

Show 
descendents  

Display all the descendents of the objects that match the filter criteria, as well 
as the objects themselves. For each object that matches the criteria, DOORS 
displays the tree of objects below it.  

Display all 
table cells  

To display all table cells and their contents regardless of whether they match 
the filter definition. If you wish to retain the structure of tables in the module 
when filtering, ensure this check box is selected.  

7. When you have finished, click Apply or OK 
The module background color changes to show that a filter is 

being applied to the data. The color depends on the display 

scheme you are using. For example, in the Modern display 

scheme the background changes to gray, and in the Classic 

display scheme it changes to green. 

Turning filtering on and off 
To turn filtering on and off, either: 

• Click View > Show > Filter 
• Click Turn filtering on or off  on the Display toolbar. 

Turning the filter off and on again shows the results of the last filter. It doesn’t 

reapply the filter. 
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For example, you filter a module to show only the objects that have a high 

priority. Object 13 has a high priority, so it’s displayed on your screen. You turn 

filtering off, then edit object 13 and change its priority to medium. When you 

turn the filter back on, you still see object 13 because it matched the filter when 

you first applied the filter. To filter the data using the current values, you must 

reapply the filter. 

To reapply your filter, click Tools > Filter > Reapply or click Reapply filter  
on the Display toolbar. 
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Chapter  8  Using Attributes 
 

This chapter contains the following topics: 

• Understanding system attributes 

• Understanding attribute types 

• Showing attribute types 

• Creating an attribute type 

• Controlling access to an attribute type 

• Editing an attribute type 

• Deleting an attribute type 

• Showing attribute definitions 

• Creating an attribute definition 

• Controlling access to an attribute definition 

• Controlling access to an attribute value 

• Editing an attribute definition 

• Sharing attribute and type definitions 

• Deleting an attribute definition 

• Copying attribute values 
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Understanding system attributes 
System attributes are attributes that are automatically created by DOORS. 
For example, when you create a new module, DOORS automatically creates a 
system attribute, called Created On, that contains the date when the module was 
created. 
 
Note  DOORS allows you to edit a new drop-down checklist by 

checking and clearing the values you want to store for the 
attribute. 
 

The following table lists the system attributes for modules. You can’t edit the 

ones that are read only: 

 
System attributes for 
modules  

Description  Read only  

Created By  The username of the person who created the 
module.  

Yes  

Created On  The date when the module was created.  Yes  
Description  

Additional information about the module.  
No  

Last Modified By  The username of the person who last modified 
the module.  

Yes  

Last Modified On  The date when the module was last modified. 
This attribute value can be used together with the 
module history to provide information about 
changes to the module.  

Yes  

Mapping  
The type of link mapping, for example one-to-one 
or many-to-many (link modules only).  

Yes  

Name  The name of the module.  No  
Prefix  The prefix part of the module’s object identifiers. 

An object identifier consists of an optional prefix, 
followed by an absolute number that is 
automatically generated by DOORS.  

No  
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The following table lists the system attributes for objects. You can’t edit the ones 

that are read only: 

 
System attributes for 
objects  

Description  Read only  

Absolute Number  The unique number that was 
automatically generated by DOORS 
when you created the object.  

Yes  

Created By  The username of the person who 
created the object.  

Yes  

Created On  The date when the object was 
created.  Yes  

Created Thru  Whether the object was created by 
copying, extraction, or manual input 
(formal modules only).  

Yes  

Last Modified By  The username of the person who 
last modified the object.  

Yes  

Last Modified On  The date when the object was last 
modified.  

Yes  

Object Heading  The object heading (formal modules 
only).  

No  

Object Short Text  The text that is used by default in 
Graphics mode in object boxes 
(formal modules only).  

No  

Object Text  The object text (formal and link 
modules only).  

No  
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System attributes for 
objects Description  Read only  
OLE OLEIconic Picture 
PictureName 
PictureNum  

Advanced system attributes that 
show status information (formal 
modules only). For example, Picture 
is a Boolean attribute that has the 
value True if the object contains a 
picture. These attributes are 
normally hidden. To display them:  
a. Click Tools > Options.  
b. Click the Settings tab.  
c. Select the Show advanced 
system attributes check box.  
d. Click OK.  

Yes  

TableBottomBorder 
TableCellAlign 
TableCellWidth 
TableChangeBars 
TableLeftBorder 
TableLinkIndicators 
TableRightBorder 
TableShowAttrs 
TableShowBookform 
TableShowWide 
TableTopBorder 
TableType  

Advanced system attributes that 
show status information (formal 
modules only). To display them:  
a. Click Tools > Options.  
b. Click the Settings tab.  
c. Select the Show advanced 
system attributes check box.  
d. Click OK.  

No  

Understanding attribute types 
Each attribute has a type, which controls the type and range of values that you 

can store in it. For example, you can only store integer values in attributes of type 

Integer, and dates in attributes of type Date. 

DOORS provides the base types shown in the following table: 

This base 
type  Can store this type of value  

Text  Text, which can include 
paragraphs

(newline characters). 

String  Text, which cannot include paragraphs (newline characters).  
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This base 
type Can store this type of value  

Integer  An integer (a whole number, such as 4 or 57). It can be 
positive or negative.  

Real  A decimal value (for example, 5.619). It can be positive or 
negative.  

Date A date, for example, 15 May 2005. For more information, see 
the section on understanding how dates and times are 
recorded in Managing DOORS, which is part of the DOORS 
documentation set.  

Enumeration  One of a predefined list of values. For example, you can define 
an attribute called Priority whose:  

• Base type is Enumeration.  
• Values are High, Medium, and Low.  

Username  A DOORS username.  
 

You can construct your own types from these base types. 

For example, you create a type called Percentage that has a base type of Integer 

and that can have values in the range 0 to 100. You then create various 

attributes of type Percentage. You know that users can only assign integer 

values between 0 and 100 to those attributes. DOORS automatically rejects any 

other values as invalid. 

You can also use types as a way of letting users know what units of 

measurement 

an attribute’s values should use. For example, you create a type called Kg that 

has a base type of Integer, and then create an attribute called Weight of type 

Kg. If an experienced DOORS user is looking at your Weight values, and isn’t 

sure what units the weight is measured in, they can check the attribute type and 

see that the units are Kg. 

The following table shows examples of attribute types you might want to create: 
 

 
Example type  Description  
Kg  A type of base type Integer, used for storing weights.  

Dollar  A type of base type Integer, used for storing costs.  
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Example type  Description  
Percentage  A type of base type Integer, with a minimum value of 0 and a 

maximum value of 100.  
Deviation  A type of base type Real, with a minimum value of 0.5 and a 

maximum value of 1.5.  
Priority  A type of base type Enumeration, with the values Mandatory, 

Desirable and Luxury.  
Project Span  A type of base type Date, with a minimum value of 1 January 2005 

and maximum value of 31 December 2005.  
 

Showing attribute types 
To show attribute types: 

1. In the module window, click Edit > Types. 

2. A list of all the attribute types for the module is displayed. 

Creating an attribute type 
To create an attribute type, you must have create and modify access to 

the module. 

To create an attribute type: 
1. Make sure you are in exclusive edit mode. 

The edit mode is shown on the status bar at the bottom of the 

module window. To change your edit mode, click Edit > Edit 
Mode > Exclusive Edit. 

2. Click Edit > Types. 

3. Either click New to create a new type from scratch, or select the 

type you want to copy, then click Copy. 

4. Type the name of the new attribute type in the Type name box. 

5. Select the base type in the Base type box. 

6. If the base type allows a range of values to be defined, you can 

type minimum and maximum values in the Minimum value and 

Maximum value boxes. 

7. If the base type is Enumeration, click the Enumerations tab, 

then define the values that attributes of this type can have. 
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Enumerations 
tab  

Description  

Value  Enter a value for the attribute in the Value box, then click 
Add. 

Related 
number  

If you want, you can enter a number that you want to assign to the 
value. This number is used when you sort or filter using an operator 
that uses a numeric value. For example, you can filter on values 
greater than 5.  
By default, the values are assigned numbers 0, 1, 2 and so  
on.  

Default  Click this radio button if you want 
for the attribute value.  

to use the default color  

Specified  Click this radio button if you don’t want to use the default  
color for the value, then select the color you want from  
the drop-down list.  

Add  Adds the value in the Value box (and optionally also the  
number in the Related number box) to the list of  
attribute values in the right box.  

Replace  Replaces the selected entry in the list of attribute values in  
the right box, with the contents of the Value and Related  
number boxes on the left.  

Delete  Deletes the selected entry from the list of attribute values  
in the right box.  
  
Changes the order of the entries in the list of attribute  
values in the right box. 

8. By default, the new attribute type inherits its access rights from 

the module. If you want to change its access rights use the 

Access tab. 

9. Click OK. 

10. Click Close. 

Controlling access to an attribute type 
 

Use access rights to control who can edit an attribute type. 

For example, the delivery dates for a project must fall within fixed dates. The 
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Project Manager creates an attribute type called Delivery, that can have a range 

of date values. She gives other users read-only access to the attribute type, so 

that they can’t change the date ranges. 

To change the access rights for an attribute type, you must have admin access to 

it. 

To change the access rights for an attribute type: 
1. Open the module that contains the attribute type you want to 

change. 

2. Click Edit > Types. 

3. Select the attribute type, then click Edit. 
4. Click the Access tab. 

The current access rights for the attribute type are displayed. 

 

 

 

You need this 
access right  

To  

Read  (R)  See the attribute type.  

Modify (M)  Change the attribute type in any way.  

Delete (D)  Delete the attribute type.  

Admin  (A)  Change the access rights for the attribute type.  

If the module is partitioned in, the access rights associated with the partition 

are displayed. These describe the maximum access that any user has. They

override the RMD access rights displayed for users and groups. 

 

For example, if a user’s entry says full access (RMDA), but the module is 

partitioned in read only, in practice the user has only read (R) access to the 

attribute type. 

5. Make the changes you want. 

 

Access tab  Description  
Inherit from 
parent  

Select this check box if you want the attribute type to inherit its access 
rights from the module. When this check box is selected, the list of 
access rights is unavailable, and shows what access rights the 
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Access tab  Description  
attribute type is inheriting.  

Add 
To add a new entry to the list of access rights: a. Click Add.  

The Add Access window is displayed. b. In the Name box, select the 
name of the user or group that you want to add an entry for. c. Select 
the access rights you want to give them, then click OK.  

Remove  To remove an entry from the list of access rights, select the entry, and 
then click Remove.  

Edit  To edit an entry in the list of access rights: a. Select the entry then 
click Edit. The Edit Access window is displayed. b. Select the 
access rights you want to give them, then click OK.  

 
6. Click OK. 

7. Click Close. 

Save the module to make the changes permanent (click File > Save). 

Editing an attribute type 
To edit an attribute type, you must have modify access to both the 

attribute type and the module. 

To edit an attribute type: 
1. Make sure you are in exclusive edit mode. 

The edit mode is shown on the status bar at the bottom of the 

module window. To change your edit mode, click Edit > Edit 
Mode > Exclusive Edit. 

2. Click Edit > Types. 

3. Select the type you want to edit, then click Edit. Base types are 

read only. 

4. Make the changes you want. For information on the boxes and 

tabs on the screen, see “Creating an attribute type,” on page 118. 

5. Click OK. 
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If you made the range of values more restrictive for an attribute 

type, any values in the module that are now out of range are 

unchanged until the object containing them is edited. At that point 

the user is forced to change the value so it falls within the new 

range 

6. If you edited the values of an enumerated attribute type: 

• If you replaced a value, DOORS automatically updates the 

value of any attribute that had that enumerated value. 

• If you delete a value: 

• DOORS automatically updates the value of any attribute that 

had that value. The value is set to the attribute’s default 

value. 

• If the attribute doesn’t have a default value, the value is 

deleted and left empty. 

Note  If you delete an enumeration value that is still set as 

the attribute value of an object then the attribute 

value of the object will be lost. 

7. Click Close. 

Deleting an attribute type 
You cannot delete an attribute type that is being used in an attribute 

definition. 

To delete an attribute type, you must have delete access to the attribute 

type and modify access to the module. 

To delete an attribute type: 
1. Make sure you are in exclusive edit mode. 

The edit mode is shown on the status bar at the bottom of the 

module window. To change your edit mode, click Edit > Edit 
Mode > Exclusive Edit. 

2. Click Edit > Types. 

3. Select the type you want to delete, then click Delete. 
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A message is displayed asking if you really want to delete the 

attribute type. 

4. Click Yes. 

5. Click Close. 

Showing attribute definitions 
To show attribute definitions: 

1. In the module window, click Edit > Attributes. 

2. A list of attribute definitions is displayed: 

• The Name column shows the name of the attribute 

definition. 

• The Type column shows the attribute type. 

• The Default value column shows its default value. 

• The Inherits value column shows whether it inherits its 

value. 

• The Exists for column shows whether it’s an object attribute 

a module attribute, or both. 

• If it’s an enumerated attribute, the Multi-valued column tells 

you whether it can have multiple values. 

Creating an attribute definition 
To create an attribute definition, you must have create and modify access 

to the module. 

To create an attribute definition: 
1. Make sure you are in exclusive edit mode. 

The edit mode is shown on the status bar at the bottom of the 

module window. To change your edit mode, click Edit > Edit 
Mode > Exclusive Edit. 

2. Click Edit > Attributes. 

On the Attributes tab, a list of attributes is displayed. 

3. If you want the new attribute to have a type that doesn’t already 

exist, click the Types tab and create the type 
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4. On the Attributes tab, either click New to create an attribute from 

scratch, or select the attribute you want to copy, then click Copy. 

5. Type the name of the new attribute in the Name box, and select 

the other options on the General tab. 

 

General tab Description 
Name The name you want to give the new attribute.

The name must be unique within the module.
Type The type of the new attribute.

The options in the dialog box change depending on what 
type you select.

Locale This option is displayed when either Text or String attribute 
types are selected. 
Select a locale for the attribute. By default this is the current 
locale on the client machine. 

DXL attribute Select this check box if you want to use a DXL program to 
assign values to the attribute. Click Browse to select the DXL 
program you want to use, or Wizard to create a DXL attribute 
using the DXL Attribute Wizard.  

Browse If you selected the DXL attribute check box:
a. Click Browse to select the DXL program. 
A list of all predefined DXL programs that can be used 
to 
set attribute values is displayed. 
b. Select the program you want to use, then click 
Apply. 
Alternatively, if you want to define a new program, click   
New. 

Multi-valued Select this check box if the attribute type has a base type of
Enumeration, and you want to be able to store more than one
value in the attribute.

Default value If you want the new attribute to have a default value, select 
the Default value check box, then type the value in the box. 
If the new attribute has an attribute type of Date, you can type 
the default value, or select a date from the drop down 
calendar.

Include time
of day 

This option is available when date attribute types are 
selected. 
If you select this box, date and time values are displayed 
using the default short date format for your current locale, and 
a 24-hour clock. 
If you clear this box, date values are displayed using the 
default long date format for your current locale.
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General tab Description 
Objects Select this check box if you want the attribute to apply to the 

objects in the module. 
Module Select this check box if you want the attribute to apply to the 

module. 
Inherit value Select this check box if the attribute applies to objects, and if 

you want objects to be able to inherit the attribute value from 
their parent objects. 
Note that if the attribute applies to both the module and 
objects in it, top-level objects don’t inherit the value from the 
module. 

Affect 
change 
bars 

Select this check box if you want DOORS to update an 
object’s change bar when anyone edits the attribute values. 

Affect 
change 
dates 

Select this check box if you want DOORS to update an 
object’s last modified date when anyone edits the attribute 
values. 

Generate 
history 

Select this check box if you want DOORS to update the 
database history when anyone edits the attribute values. 

Add new 
attribute to 
current view 

Select this check box if you want to add a column for the new 
attribute to your current view. 

 

6. By default, the attribute inherits its access rights from the module. 

If you want to change its access rights use the Access 
(Definition) and Access (Value) tabs.  

7. Click OK. 

8. Click Close. 

Save the module to make the change permanent (click File > Save).  

Creating a new DXL attribute 
You can use the DXL Attribute Wizard to create a DXL attribute that contains 

the values of other attributes in the module. This is particularly useful for 

displaying the values of more than one attribute in table cells. 

1. Click Edit > Attributes, and click New. 

2. Type a name for the attribute in the Name box. 

3. Select Text in the Type box. 

4. Select DXL attribute and click Wizard. 

The DXL Attribute Wizard opens. 
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5. Click Next. 
The Attribute Selection screen is displayed. 

6. Select the attributes you want to include in the DXL attribute and 

click Next. 
The Attribute Ordering screen is displayed. 

7. Move the attributes up or down the list by selecting the attribute 

name and clicking the up or down arrow. Click Next. 
The Other Information screen is displayed. 

8. The following options are available: 

• One attribute per line 

• Show attribute names 

• Include OLE objects in text. 

Select or clear the options as required and click Next. 
The Finish screen is displayed 

9. Click Finish. 

The new attribute is created. If you do not want the attribute 

displayed in a column in the module, clear the Add new attribute 
to current view check box on the New attribute dialog box. 

10. Click OK. 

Controlling access to an attribute definition 
Use access rights to control who can edit an attribute definition. 

For example, you might want to lock Generate history on for an attribute 

definition. If users can edit the attribute definition, a dishonest user could 

conceal a change to an attribute value by temporarily turning Generate 
history off, changing the attribute value, and then turning Generate 
history on again. Although the modification of the attribute definition 

would be recorded in the module’s history, you would miss the change to 

the attribute value. By setting strict access rights, this unlikely event 

becomes impossible. To change the access rights for an attribute 

definition, you must have admin access to it. 

To change the access rights for an attribute definition: 
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1. Open the module that contains the attribute definition you want to 

change. 

2. Click Edit > Attributes. 

3. Select the attribute, then click Edit. 
4. Click the Access (Definition) tab. 

The current access rights for the attribute definition are displayed. 

 
You need this 
access right  

To  

Read  (R)  See the attribute definition  

Modify (M)  Change the attribute definition in any way  

Delete (D)  Delete the attribute definition  

Admin  (A)  Change the access rights for the attribute 
definition  

 
If the module is partitioned in, the access rights associated with the partition 

are displayed. These describe the maximum access that any user has. They 

override the RMD access rights displayed for users and groups. 

For example, if a user’s entry says full access (RMDA), but the attribute is 

partitioned in read only, in practice the user has only read (R) access. 

5. Make the changes you want. 

 
Access tab  Description  
Inherit from 
parent  

Select this check box if you want the attribute 
definition to inherit its access rights from the 
module. When this check box is selected, the 
list of access rights is unavailable, and shows 
what access rights the attribute definition is 
inheriting.  

Add  To add a new entry to the list of access 
rights: 
 a. Click Add.  
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Access tab  Description  
 The Add Access window is displayed.  

b. In the Name box, select the name of the 
user or group that you want to add an entry 
for.  
c. Select the access rights you want to give 
them, then click OK.  

Remove  To remove an entry from the list of access 
rights, select the entry, and then click 
Remove.  

Edit  To edit an entry in the list of access rights:  
a. Select the entry then click Edit. The Edit 
Access window is displayed.  
b. Select the access rights you want to give 
them, then click OK.  

 
6. Click OK. 

7. Click Close. 

8. Save the module to make the changes permanent (click File > 
Save). 

Controlling access to an attribute value 
Use access rights on an attribute’s values to control who can edit the 

values. To edit the value of an attribute for a particular object, you need 

modify access to both the object and the attribute’s values. 

For example, you give everyone read-only access to the Priority 
attribute’s values. This lets everyone see the priority of each object, but 

they can’t change the priority even if they have modify access to the 

object. To change the access rights for an attribute value, you must have 

admin access to it. 

To change the access rights for an attribute value: 
1. Open the module that contains the attribute value you want to 

change. 

2. Click Edit > Attributes. 

3. Select the attribute, then click Edit. 
4. Click the Access (Value) tab. 
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The current access rights for the attribute values are displayed. 

You need this
access right

To 

Read (R) See the attribute definition 
Modify (M) Change the attribute definition in any way 
Delete (D) Delete the attribute definition 

Admin (A) 
Change the access rights for the attribute 
definition 

 

If the module is partitioned in, the access rights associated with the 

partition are displayed. These describe the maximum access that any user 

has. They override the RM access rights displayed for users and groups. 

For example, if a user’s entry says full access (RMA), but the attribute is 

partitioned in read only, in practice the user has only read (R) access. 

5. Make the changes you want. 

Access tab Description 
Inherit from 
parent 

Select this check box if you want the attribute 
definition to inherit its access rights from the 
module. When this check box is selected, the 
list of access rights is unavailable, and shows 
what access rights the attribute definition is 
inheriting. 

Add To add a new entry to the list of access rights: 
a. Click Add. 
The Add Access window is displayed. 
b. In the Name box, select the name of 
the user or group that you want to add 
an entry for. 
c. Select the access rights you want to 
give them, then click OK. 

Remove To remove an entry from the list of access 
rights, select the entry, and then click 
Remove. 

Edit To edit an entry in the list of access rights: 
a. Select the entry then click Edit. 
The Edit Access window is displayed. 
b. Select the access rights you want to 
give them, then click OK. 
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6. Click OK. 

7. Save the module to make the changes permanent (click File > 
Save). 

Editing an attribute definition 
To edit an attribute definition, you must have modify access to both the 

attribute definition and the module it’s in. 

To edit an attribute definition: 
1. Make sure you are in exclusive edit mode. 

The edit mode is shown on the status bar at the bottom of the 

module window. To change your edit mode, click Edit > Edit Mode > 
Exclusive Edit. 
2. Click Edit > Attributes. 

3. Select the attribute you want to edit, then click Edit. 
4. On the General tab, make the changes you want. 

 

General tab Description 
Name The name of the attribute definition. 

 
Note When you change the name of an attribute definition, it 

is no longer recognized by any of the views it’s in. 
Update each view to add a column for the attribute, 
then save the view. 

Type The type of the attribute. Once an attribute has been created, 
you cannot change its type, so this field is always unavailable. 

Locale This option is displayed when either Text or String attribute 
types are selected. 
 
Select a locale for the attribute. By default this is the current 
locale on the client machine.  

DXL 
attribute 

Select this check box if you want to use a DXL program to 
assign values to a text attribute. Click Browse to select the 
DXL program you want to use, or Wizard to create a DXL 
attribute using the DXL Attribute Wizard. 
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General tab Description 
Browse If the DXL attribute check box is selected: 

a. Click Browse. 
A list of all the predefined DXL programs that can be used to set 
attribute values is displayed. 
b. Select the program you want to use, then click OK. 
Alternatively, if you want to define a new program, click New. 

Wizard If the DXL attribute check box is selected:
a. Click Wizard. 
b. Step through the DXL Attribute Wizard, selecting the 
attributes that you want to display in the DXL attribute, 
the order in which you want them displayed, and how 
you want the information to be displayed. 
c. Click Finish to create the DXL attribute. 

Multi-valued Select this check box if the attribute type has a base type of
Enumeration, and you want to be able to store more than one 
value in the attribute. 

Default 
value 

If you want the attribute to have a default value, select the 
Default value check box, then type the value in the box. 
If the attribute has an attribute type of Date, you can type the 
default value, or select a date from the drop down calendar. 
When you change the default value of an attribute definition, 
the values of any attributes that have been assigned the 
previous default value are updated. 

Include time 
of 
day 

This option is available when date attribute types are selected. 
If you select this box, date and time values are displayed using 
the default short date format for your current locale, and a 
24-hour clock. 
If you clear this box, date values are displayed using the default 
long date format for your current locale. 

Objects Select this check box if you want the attribute to apply to the 
objects in the module. 

Module Select this check box if you want the attribute to apply to the 
module. 
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General tab Description 
Inherit value Select this check box if the attribute applies to objects, and if 

you want the objects to be able to inherit the attribute value 
from their parent objects. 

Note that if the attribute applies to both the module and 
objects in it, top-level objects don’t inherit the value from the 
module.

Affect 
change 
bars

Select this check box if you want DOORS to update an object’s change 
bar when anyone edits the attribute values. 

Affect 
change 
dates 

Select this check box if you want DOORS to update an object’s last 
modified date when anyone edits the attribute values. 

Generate 
history 

Select this check box if you want DOORS to update the 
database history when anyone edits the attribute values. 

5. Use the Access (Definition) tab if you want to change who can 

see or modify the definition of the attribute. For more information, 

see “Controlling access to an attribute definition,” on page 127. 

6. Use the Access (Values) tab if you want to change who can read 

or modify the attribute’s values.  

7. Click OK. 

8. Click Close. 

9. Save the module to make the changes permanent (click File > 
Save). 

Editing a DXL attribute definition 
If the DXL attribute you are editing was created using the DXL Attribute 

Wizard, edit it using the wizard. Edit any other DXL attributes by clicking 

the Browse button. 

If the DXL attribute was created using the DXL Attribute Wizard: 
1. Select the DXL attribute you want to edit. 

2. Click Wizard. 

The DXL Attribute Wizard is displayed. 

3. Click Next. 
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The Attribute Selection screen is displayed. The attributes that are 

currently included in the DXL attribute definition are selected. 

 
Note  If no attributes are selected on this screen, the DXL 

attribute was probably not created using the wizard. If 

you continue, any DXL that is currently associated with 

the attribute will be overwritten. If you do not want to 

overwrite the existing DXL, click Cancel and use the 
Browse button to edit the DXL attribute. 
 

4. Select the attributes you want to add to the DXL attribute 

definition, and clear the attributes that you want to remove from 

the attribute definition. 

5. Click Next. 
The Attribute Ordering screen is displayed. 

6. Move the attributes up or down the list by selecting the attribute 

name and clicking the up or down arrow. 

7. Click Next. 
The Other Information screen is displayed. 

8. The following options are available: 

• One attribute per line 

• Show attribute names 

• Include OLE objects in text 

Select or clear the options as required and click Next. 
The Finish screen is displayed. 

9. Click Finish. 

The DXL attribute definition is updated. 

If the DXL attribute definition was not created using the DXL 
Attribute Wizard: 
1. Select the DXL Attribute you want to edit. 

2. Click Browse. 

The Browse DXL dialog box is displayed. 
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3. Click Current. 
The Edit Attribute DXL window opens, and the DXL associated 

with the attribute is displayed for editing and checking. 

 
Note  If the DXL was created by the DXL Attribute Wizard, 

this is indicated in the first line of the code. If you make 

manual changes to code that was generated by the 

wizard, and you subsequently edit the attribute using the 

wizard, the manual changes will not be recognized, and 

will be overwritten. 

Sharing attribute and type definitions 
DOORS allows you import attribute types or attribute definitions into your 

current module from any module in the DOORS database that you have 

read access to. 

To import attribute definitions into an open module: 
1. Click Edit > Attributes. 

The Columns and Attributes window is displayed. 

2. Select the Attributes tab. 

The attributes that are available in the module are listed. 

3. Click Import. 
The Import Attribute dialog box is displayed. 

4. Click Browse. 

A Mini-Explorer window opens. 

5. Browse to the source module containing the attribute definitions 

you want to import, and then click OK. 

The source module’s attributes are listed in the Import Attribute 
dialog box. 

6. Select the attribute definition or definitions that you want to import, 

then click OK. 
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The dialog box closes. The attribute definitions are added to your 

open module and the display returns to the Columns and 
Attributes window. 

7. Click Close. 

To import type definitions into an open module: 
1. Click Edit > Types. 

The Columns and Attributes window is displayed. 

2. Select the Types tab. 

The types that are available in the module are listed. 

3. Click Import. 
The Import Type dialog box is displayed. 

4. Click Browse 
A Mini-Explorer window opens. 

5. Browse to the source module containing the type definitions you 

want to import, and then click OK. 

The source module’s types are listed in the Import Types dialog 

box.  

6. Select the type definition(s) you want to import, then click OK. 

The window closes. The type definitions are added to your open 

module and the display returns to the Columns and Attributes 
window. 

7. Click Close. 

Deleting an attribute definition 
To delete an attribute definition, you must have delete access to the 

attribute definition, and modify access to the module. 

 
Note  You can’t undelete an attribute definition once you’ve deleted 

it. 

To delete an attribute definition: 
1. Make sure you are in exclusive edit mode. 
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The edit mode is shown on the status bar at the bottom of the 

module window. To change your edit mode, click Edit > Edit 
Mode > Exclusive Edit. 

2. Click Edit > Attributes. 

3. Select the attribute you want to delete, then click Delete. 

4. A message is displayed asking if you really want to delete the 

attribute. Click Yes. 

5. Click Close. 

6. Save the module to make the change permanent (click File > 
Save). 

Understanding DXL attributes and layout DXL columns 
Both DXL attributes and layout DXL columns use DXL programs to 

calculate values displayed on your screen. For example, DOORS provides 

DXL programs that calculate the number of days since an object was last 

modified, and the number of in-links and out-links for an object. 

The differences between DXL attributes and layout DXL columns are 

subtle. With a DXL attribute, the DXL program is associated with an 

attribute definition. You can use the attribute in multiple columns and in 

multiple views.  

With a layout DXL column, the DXL program is associated with a single 

column, but not with any attribute. A layout DXL column is a column that 

doesn’t contain an attribute. Instead, it uses the DXL program to calculate 

what to display on your screen. 

 
Note Layout DXL does not process table objects. 

 

The values of an object’s DXL attributes are automatically calculated only 

when the object is first displayed on your screen. To make DOORS 

recalculate the values, click Tools, then Refresh DXL Attributes. This 

updates the values of all of the DXL attributes in the module by re-running 

the DXL programs associated with them. 
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The values displayed in a layout DXL column are automatically 

recalculated whenever DOORS refreshes your screen. If the DXL program 

associated with the column is compute intensive, the constant 

recalculation of the values can lead to poor performance. In this case you 

should consider using a DXL attribute instead of a layout DXL column. 

 

You should also use attribute DXL, or convert your layout DXL column to 

attribute DXL, if a large amount of data is displayed in the column. This is 

because you cannot scroll layout DXL if the object contains more data 

than can be displayed on the screen, but you can scroll attribute DXL. 

Copying attribute values 
To copy values from one attribute to another, within the same module: 

1. In the module window, click Tools > Functions > Copy 
Attributes. 

2. In the Source attribute box, select the attribute that contains the 

values you want to copy. 

3. In the Destination attribute box, select the attribute whose 

values you want to overwrite. 

4. Click OK. 

5. Save the module to make the changes permanent (click File > 
Save). 
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Chapter  9  Viewing Data In A Formal Module 
 

This chapter contains the following topics: 

• Navigating using the keyboard 

• Using the module explorer 

• Understanding display modes 

• Changing the display mode 

• Controlling display levels 

• Controlling table attribute display 

• Using outlining 

• Using compression 

• Working with columns 

• Showing column information 

• Adding a column 

• Editing column information 

• Color-coding your data 
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Navigating using the keyboard 
The following table shows the keys you can use on your keyboard to navigate 

formal modules: 

Press  To  

HOME  Go to the first object in the module.  

END  Go to the last object in the module.  

PAGE UP  Scroll up one screen in Document mode. Rotate the tree 
clockwise through 90 degrees in Graphics mode.  

PAGE DOWN  Scroll down one screen in Document mode.  
Rotate the objects clockwise in Graphics mode.  

UP ARROW  Go to the next or previous object in Document mode.  
DOWN ARROW  Move up or down the tree hierarchy in Graphics mode.  
CTRL+ UP ARROW  Move from the current object to the sibling above or below it.  
CTRL+ DOWN ARROW Scroll, if the focus is on the left pane of the Module Explorer. 
CTRL+ LEFT  
ARROW  

Go to the current object’s parent (left arrow) or first child  
(right arrow).  

CTRL+ RIGHT  
ARROW  

Scroll if the focus is on the left pane of the Module Explorer.  

SHIFT+ RETURN  Edit the current object in-place in Document mode.  
Go to the next object if you’re already editing in-place.  
 

Note It does nothing if you’re in Graphics mode, or if 
the focus is on the left pane of the Module Explorer.  

 

 

Using the module explorer 
To turn on the module explorer, do one of the following: 

• Click View > Module Explorer. 
• Click Module Explorer  on the Display toolbar. 

When you turn the Module Explorer on, two panes are displayed: 

• The left pane has a Windows Explorer style display that lets you quickly 

navigate the object tree within the module. 
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• What’s displayed in the right pane depends on whether you’re in 

Document or Graphics mode and what display options, such as outlining, 

you’re using. 

When you turn the Module Explorer off, the left pane disappears and the right 

pane fills your screen. 

Understanding display modes 
You can use the following display modes: 

• Document mode 

• Graphics mode 

Document mode is the default. It displays the module data as a table, with 

rows and columns, as shown in this screenshot. 

 

 

 

 
In Graphics mode each object is displayed as a box that contains one attribute, 
as shown in the following screenshot: 
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You can choose which attribute is displayed in the box (see “Changing the 

display mode,” on page 149). By default, it’s the Object Short Text attribute. If 

the object doesn’t have an Object Short Text, one of the following is used, in 

order of priority: Object Heading, then Object Text, then Object Identifier. 

The box at the left shows the title of the main column, User requirements for 
SUV 4x2. 

In Graphics mode: 
• The current object has a pink border, and is always visible on your screen. 

 

As you navigate around the module, the display changes to keep the 

current object near the center of your screen. On a large screen, it 

magnifies the objects in the center and makes the objects at the edge 

smaller, as if you were looking through a fish-eye lens. 

 

• If you roll your mouse over an object, a datatip is displayed. 

 

By default, the datatip shows the Object Heading and Object Text 
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attributes. You can choose to display another attribute in the datatip. 

• A red square or triangle is displayed if there are child objects that are 

hidden because they don’t fit on your screen. Click the red square or 

triangle to display the hidden objects. 

Note  A red square means a single object tree is hidden. A red 

triangle means two or more object trees are hidden. 

Changing the display mode 
 
To turn Graphics mode on or off, either: 

• Click View > Graphics Mode. 

• Click Turn Graphics mode on or off on the Display toolbar. 

This switches between Graphics mode and Document mode. When Graphics 

mode is off, you get the default mode, which is Document mode. 

Selecting the attributes shown in graphics mode 

To change the attribute shown in the object boxes in Graphics mode: 
1. Turn Graphics mode off. 

2. Select the title of the column that contains the data you want to 

display in the object boxes in Graphics mode, then right-click Use 
in Graphics mode boxes. 

A white marker is displayed at the top right edge of the column’s 

title bar, as shown in the next screenshot. 

To change the attribute shown in the datatips in Graphics mode: 
1. Turn Graphics mode off. 

2. Select the title of the column that contains the data you want to 

use, then right-click Use in Graphics mode datatips. 

An orange marker is displayed at the bottom right edge of the 

column’s title bar, as shown in the following screenshot. 
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Controlling display levels 
The object hierarchy in a module is often too complex to see at once. 

You can specify how many levels of the hierarchy you want to see. For 

example, you may only want to see level 1 and level 2 objects. 

To change the display level either: 
• Click View > Level, then select the level you want. 

• Select the display level from the Display to level drop-down list on 

the View toolbar. 

Objects lower than the selected level are hidden. For example, if you 

select level 2, you only see level 1 and 2 objects. 
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Notice that an object is marked with a > symbol if it has children that 

are hidden because they’re at a lower level than the selected display 

level. 

Note The display level only affects the right pane of the Module 

Explorer. In the left pane, you can always see all the objects 

In the current view. 

 

Controlling table attribute display 
By default, table cells display the main column attributes: Object Heading and 

Object Text. If you want to display a different attribute in table cells, either: 

• Use the table properties to specify which attribute you want to display 

in that table’s cells. This allows you to display a different attribute in 

each table in the module.  

• Use the Table Attributes option under the View menu to set an 

attribute other than the main column attributes to be the default 
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displayed in tables in the module. You can choose to make this setting 

override table settings for individual tables in the module. 

To change the default attribute displayed in table cells: 
1. In the formal module, select View > Table Attributes. 

The Table Attributes dialog box is displayed. 

2. Select Enable default table attribute, and select the attribute 

that you want to display from the list. 

3. If you want this setting to override any attribute settings that 

have been made in the table properties of individual tables, 

select the Default attribute overrides table settings check 

box. 

4. Click OK. 

If you want this setting to persist through different sessions, you 

must save the view.  

Using outlining 
Outlining reduces the amount of information displayed on your screen. 

When outlining is turned on: 

• Only objects that have a heading are displayed. 

• Only the Object Heading of those objects is displayed. Their Object 
Text attribute is hidden. 
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You can use outlining in Document or Graphics mode. 

Note Outlining only affects the right pane of the Module Explorer. 

In the left pane, you can always see all the objects in the 

current view. 

To turn outlining on or off, do one of the following: 
• Click View > Outline 

• Click Turn outlining on or off  on the Display toolbar 

Note Tables are always hidden when outlining is turned on. 

Using compression 
When outlining is turned on, you can compress or hide parts of the 

hierarchy. 

 
For example, in this picture section 3 is compressed. It has a plus 

sign to show that its objects are hidden. 

To turn compression on or off for the current object, click View > 
Compress. 
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Working with columns 
When you’re in Document mode, module data is displayed in rows 

and columns. 

 

 

To  Do this  

Move a column  Drag the column’s title to the new position.  

Change the width of 
a column  

Drag the column separator at the edge of the column’s title bar.  

Select a column  Click the column’s title.  

De-select a column  Click its title again.  

Change the 
alignment of the  
contents of a column  

Select the column, then either:  
• Right-click Left, or click Left align column   on the 

Alignment toolbar.  
• Right-click Right, or click Right align column  on the 

Alignment toolbar.  
• Right-click Center, or click Center column  on the 

Alignment toolbar.  
• Right-click Justify, or click Justify column  on the 

Alignment toolbar.  

Auto-indent the main  
column  

Click Auto-indent main column  on the  
Alignment toolbar.  
The contents of the main column are indented  
according to the object’s position in the hierarchy: the  
lower down the hierarchy the object is, the further it is 
indented. This allows users to see at a glance the structure of 
the module.  

Sort the module on 
the contents of a 
column  

Right-click on the column heading and select Sort >  
Ascending or Sort > Descending. The module is  
sorted according to the contents of the module.  

Remove a column  Either:  
• Select the column’s title, then right-click Remove.  
• Select the column, then click Remove column  

button  on the Column toolbar.  

Use a column in 
Graphics  
mode  

Select the column, then either:  
• Right-click Use in Graphics mode object boxes.  
• Right-click Use in Graphics mode datatips.  
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Showing column information 
When you’re in Document mode, you can control what columns are displayed on 

your screen, what’s displayed in each column, what the column titles are, and so 

on. 

To show column information: 
1. In the module window, click Edit > Columns. 

2. On the Columns tab, a list is displayed of all the columns 

currently displayed on your screen: 

• The Title column shows the title of the column. 

• The Attribute column shows the name of the attribute. If 

the column doesn’t contain an attribute, words in angle 

brackets are displayed. For example, if it contains layout 

DXL, <Layout DXL> is displayed. 

• The Type column shows the type of the attribute. It’s 

empty if the column doesn’t contain an attribute. 

3. To remove a column, select it, then click Remove. 

Note You can also remove a column, by selecting the column’s title 

in the module window, then either right-clicking Remove, or 

clicking Remove column  on the Column toolbar. 

Adding a column 
When you’re in Document mode, you can control what columns are 

displayed on your screen. 

 
Note  The maximum number of columns you can display in a view 

Is 32. 

To add a column: 
1. In the module window, click Insert > Column. 

Alternatively, click Insert column  on the Column toolbar. 
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Note  You can also click Edit > Columns, which displays the 

Columns and Attributes window, with the Columns 
tab selected. This shows a list of all the columns 

currently displayed on your screen, in the order in which 

they are displayed. Select the column that you want to 

insert the new column before, then click New or Copy. 

If you don’t select a column, the new column is added to 

the bottom of the list and is displayed at the extreme 

right of the module window. 

2. In the New Column window, use the Contents radio buttons 

to specify what you want to display in the column: 

• To display an attribute in the column, click Attribute, 

then select the attribute from the drop-down list. 

• To display the Object Heading and Object Text 
attributes in the column (like a main column), click Object 
Heading and Object Text. 

• To display layout DXL in the column: 

i. Click Layout DXL. 

ii. Click Browse to specify the DXL. A list of all the 

predefined DXL programs you can use is displayed. 

iii. Select the program you want to use, then click Apply. 

Alternatively, if you want to define a new program, click 

New and define the program. 

3. If you want to color-code the data that is displayed in the 

column, click By attribute in the Text Color box, then select 

the attribute from the drop-down list. 

4. In the Column Title box, type the title you want the column to 

have. You can leave this box blank if you’re displaying an 

attribute in the column. By default, the title of the column is the 

same as the name of the attribute. 
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5. If you do not want to add any more columns to the view, click 

OK. If you want to add more columns to the view, click Apply. 

When you have finished adding columns, click Close. 

If you want to permanently add the new column to your view, follow 

the instructions in “Saving your current view,” on page 87. 

Editing column information 
See also “Working with columns,” on page 153. 

To edit column information: 
1. In the module window, click Edit > Columns. 

2. A list of all the columns currently displayed on your screen is 

displayed. Select the column you want to edit, then click Edit. 
The following table describes the options on the Edit Column 
dialog box.  

 
Option  Description  
Title  The title of the column.  

Attribute  Selected if the column contains an attribute. The drop-down list 
shows the name of the attribute.  

Layout DXL  Selected if the column contains layout DXL. Click Browse to see the 
name of the DXL program.  

Object 
Heading and 
Object Text  

Selected if the column contains both the Object Heading and Object 
Text attributes, like a main column.  

Default  Selected if the data displayed in the column isn’t color-coded using 
the values of another attribute.  

By attribute  Selected if the data displayed in the column is color-coded using the 
values of another attribute. The drop-down list shows the name of the 
other attribute. For more information, see the following section, 
“Color-coding your data”.  

Column title  The column title that is displayed in the view. If you leave this blank, 
the attribute name is displayed as the column title.  

 
Color-coding your data 
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For enumerated attribute types you can define the color associated with 

each value that the attribute can have. 

For example, you have an enumerated attribute type called Yes or No, 

and you define its values and their colors like this: 

Value  Color  
Yes  Green  

No  Red  
 
 

You create an attribute called Approved that has the type Yes or No. You 

can then edit the properties of any of the columns in the view so that the 

data in the column is color-coded according to the value of the Approved 
attribute. For example, right-click on the main column title bar and select 

Properties. In the Color pane, select By attribute and select Approved 
from the list.  

The main column is color-coded using the Approved attribute. Items that 

are approved are green, and items that are not approved are red. In this 

case, you don’t need to display the Approved attribute in its own column, 

because you can see at a glance which items are approved from their 

color in the main column. 
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Chapter  10  Working With Tables 
 
 

This chapter contains the following topics: 

• Understanding tables 

• Creating a table 

• Inserting a module as a table 

• Inserting rows 

• Inserting columns 

• Changing table properties 

• Deleting, un-deleting and purging tables 
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Understanding tables 

When you insert a table in a module, DOORS creates an object for each 

cell in the table. It also creates a table marker object, which contains the 

table cell objects. 

You can see the table marker object in the left pane of the Module 

Explorer, as shown in this picture. It has >> Table as its tex 

 

 
In the right pane, the table marker object is hidden by default. Instead the 

table cells is displayed are displayed. 

You can turn the display of table cells on and off in the right pane by 

clicking View > Show > Table Cells. When it’s off, >> Table is displayed 

in the right pane as well as the left. 
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Note  If you want to copy a table, turn the display of table cells off. 

When it’s turned on, the Copy option is unavailable when 

you select a table. 

 

By default, the whole table is displayed in the main column of the module. 

It’s truncated if it is too wide to fit in the main column. Use the table 

properties sheet to override the default behavior and use the full screen 

width to display the table (see “Changing table properties,” on page 181). 

 
Note You can’t create a table within an existing table cell. 

 

You can use drag-and-drop to copy tables between modules. Select all 

the cells in the table (click the first cell, then SHIFT+Click the last cell) 

then drag them to the target module. 

Creating a table 
This topic describes how to create an empty table. You can also create a 

table 

from another module (see “Inserting a module as a table,” on page 179). 

To create a table: 
1. In the module window, select the object where you want to 

create the table. 

You can create a table at either the same level as the current object 

or one level below the current object. You must have create access 

to the current object to create a table one level below it. You must 

have create access to the parent of the current object to create a 

table at the same level as the current object. 

2. Click Table > Insert then either After or Below. 

3. Optionally type the number of rows and columns you want in 

your table. 

4. Optionally type the column width, in pixels. 
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Pixels are used to measure distances on computer screens. In the 

Control Panel, select Display, then the Settings tab to find out 

how big your screen is in pixels. 

5. Click OK. 

6. Save the module to make the changes permanent (click File > 
Save). 

Inserting a module as a table 
This topic describes how to insert a whole module as a table in another 

module, as shown in the example. Both modules must be in the same 

folder, and the inserted module must not contain any tables 

 

 
 

To insert a module as a table in the current module: 
1. Select the object that you want to insert the module after. 

2. Click Table > Insert > Module as Table. 

The Insert Module as Table dialog box is displayed. 
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3. In the Source module box, click Browse and select the 

module you want to insert. 

Note  The module you want to insert must not contain any 

tables. 

4. In the Views box, select the view you want to insert. 

5. Select the Object Identifiers check box if you want the inserted table to 

include a column that contains the object identifiers for the objects in the 

source module. 

6. Select the Borders check box if you want the inserted table to have borders 

around its cells. 

7. Click OK. 

Inserting rows 
To insert a new row in a table: 

1. In the module window, select the row where you want to insert 

a new row. 

Note You must have create access to the table marker object. 

 

You can insert a row above or below the current row. 

The inserted row has the same number of cells and the same settings as 

the current row. For example, it has the same width and alignment as the 

current row. 

2. Click Table > Insert > Row, then either Above or Below. 

3. Save the module to make the changes permanent (click File > 
Save). 

Inserting columns 
To insert a new column in a table: 

1. In the module window, select the cell where you want to insert 

a new column. 

Note You must have create access to the table marker object. 
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You can insert a column to the left of the current cell, or to the right 

of the current cell. 

The inserted column has the same number of cells and the same 

settings as the current column. For example, it has the same width 

and alignment as the current column. 

2. Click Table > Insert > Column, then either To the Left or To 
the Right. 

3. Save the module to make the changes permanent (click File, 

then Save). 

Note  In a table with unequal row lengths, cells in the inserted 

column may not be horizontally aligned. Each cell in the new 

column is positioned relative to the start of the row that it’s 

in. For example, if the current cell is the third cell in the row 

and you insert a column to the left of it, then a new cell is 

added to the left of the third cell in each row. 

Changing table properties 
To change the properties of a table: 

1. Click in a table cell: 

• If you want to change the properties of the whole table, click any 

table cell. 

• If you want to change the properties of a particular row or column, 

click any cell in that row or column. 

• If you want to change the properties of a particular cell, click that 

cell. 

2. Click Table > Properties. 

3. To change the settings for every cell in the entire table, click 

the Table tab and select the settings you want. 
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Table tab  Description  

Display in 
module  
main column 
only  

Clear this check box to display the table 
across all the columns in the module, not just 
in its main column.  

Preferred 
Width  

If you want to specify a cell width, select the 
Preferred Width check box, then enter the 
cell width in pixels, or use the slider bar to 
change the width of all the cells in the  
table graphically.  

Note Pixels are used to measure 
distances on computer screens. In the 
Control Panel, select Display, then 
the Settings tab to find out how big 
your screen is in pixels.  

Alignment  Select the alignment of text within the cells.  

Change bars  Show or hide change bars for the cells.  

Link arrows  Show or hide link arrows in the cells.  

 

 

 

4. To change the settings for every cell in the current row, click 

the Row tab and select the settings you want. 

Row tab  Description  
Preferred 
Width  

If you want to specify a cell width, select the 
Preferred Width check box, then enter the 
cell width in pixels, or use the slider bar to 
change the width of the cells in the selected 
row graphically.  

Note Pixels are used to measure 
distances on computer screens. In the 
Control Panel, select Display, then 
the Settings tab to find out how big 
your screen is in pixels.  

Alignment  Select the alignment of text within the cells.  

Change bars  Show or hide change bars for the cells.  

Link arrows  Show or hide link arrows in the cells.  

5. To change the settings for every cell in the current column, 

click the Column tab and select the settings you want. 
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Column tab  Description  
Preferred 
Width  

If you want to specify a cell width, select the 
Preferred Widthcheck box, then enter the 
cell width in pixels, or use the slider bar to 
change the width of the cells in the selected 
row graphically.  

Note Pixels are used to measure 
distances on computer screens. In the 
Control Panel, select Display, then 
the Settings tab to find out how big 
your screen is in pixels.  

Alignment  Select the alignment of text within the cells.  

Change bars  Show or hide change bars for the cells.  

Link arrows  Show or hide link arrows in the cells.  

6. To change the settings for the current cell only, click the Cell 
tab and select the settings you want. 

Cell tab  Description  

Preferred 
Width  

If you want to specify a cell width, select the 
Preferred Width check box, then enter the 
cell width in pixels, or use the slider bar to 
change the width of the selected cell 
graphically.  
Pixels are used to measure distances on 
computer screens. In the Control Panel, 
select Display, then the Settings  
tab to find out how big your screen is in 
pixels.  

Alignment  Select the alignment of text within the cell.  

Change bars  Show or hide change bars for the cell.  

Link arrows  Show or hide link arrows in the cell.  

7. To change the borders of the table, click the Borders tab and 

select the settings you want. 

8.  
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Borders tab  Description  
None  Click None if you don’t want any borders.  

Box  Click Box if you want a border around the 
outside edge only.  

All  Click All if you want border around all edges, 
including internal cells.  

Custom  Click Custom to set up custom borders, then 
in the Preview box, click the buttons to 
specify where you want borders.  

Apply to  Specify whether you want your settings to 
apply to the whole table, the current row, the 
current column, or the current cell. By 
default, settings are applied to the current 
cell.  

 
9. To change the attribute that is displayed in the table cell, click 

the Attributes tab and select the attribute you want to display 

from the list, or click Object Heading and Object Text to 

display those attributes. By default, Object Heading and 

Object Text are displayed in table cells. 

 
Note  If an attribute to display in table cells has been specified 

using the View > Tables Attributes option, that setting 

may have been set to override individual table settings. 

If you want to display more than one attribute in table cells, you can 

use the DXL Attribute Wizard to create a DXL attribute that contains 

all the attributes you want to display. For more information about 

the DXL Attribute Wizard. 

If you select a DXL attribute from the drop down list, the Edit using 
Wizard... button becomes available. If the DXL attribute was 

created using the DXL Attribute Wizard, you can view and edit it by 

clicking this button to open the wizard. 

 
Note  If the module is displayed in DOORSnet, the Object 
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Heading and Object Text attributes are displayed 

regardless of what is selected on this tab. 

10. Click OK. 

11. Save the module to make the changes permanent (click File > 
Save). 

Deleting, un-deleting and purging tables 
You can delete an entire table, or just a row, column or cell within 

the table. Deleting a table cell doesn’t destroy any of it data. It 

simply marks the cell as deleted, and stops users from being able 

to access it. To destroy the table cell, you must purge it once 

you’ve deleted it.  

Purging deleted table cells removes them permanently from the 

database. When you delete a table cell that has an in-link, the 

source object is automatically modified to remove the link, so you 

must have modify access to the source object. 

 

You can’t delete the table cell if you don’t have modify access to 

the source 

object. This ensures that you don’t end up with a dangling link at 

the source object that goes nowhere. The link between the object 

and the table cell means there is some kind of dependency 

between them. You must resolve this dependency before you 

delete the table cell and lose the dependency. 

 

To delete, undelete or purge a table cell, you must have delete 

access to the table marker object. 

To delete all or part of a table: 
1. Click the appropriate table cells: 

• If you want to delete the entire table, click any cell in the 

table. 
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• If you want to delete a particular row or column, click any 

cell in that row or column. 

• If you want to delete a particular cell, click that cell. 

2. Click Table > Delete, then either Table or Row or Column or 

Cell. 
3. Save the module to make the change permanent (click File > 

Save). 

Note Cells to the right of the deleted cells are shifted left. 

To undelete all or part of a table: 
1. In the module window, make sure that deleted items are being 

displayed. If necessary, click View > Show > Deletions. 

Deleted cells have red text, and their change bars are black  

. 

2. Select the table cells you want to undelete: 

• If you want to undelete the entire table, click any cell in the 

table. 

•  If you want to undelete a particular row or column, click 

any cell in that row or column. 

• If you want to undelete a particular cell, click that cell. 

3. Click Table > Undelete, then either Table or Row or Column 
or Cell. 

4. Save the module to make the change permanent (click File > 
Save). 

To purge all or part of a table: 
1. In the module window, make sure that deleted items are being 

displayed. 

If necessary, click View > Show > Deletions. 

Deleted cells have red text, and their change bars are black  . 

2. Select the deleted table cells you want to purge: 
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• If you want to purge the entire table, click any cell in 

the table. 

• If you want to purge a particular row or column, click 

any cell in that row or column. 

• If you want to purge a particular cell, click that cell. 

3. Click Table > Purge, then either Table or Row or Column or 

Cell. 
A message is displayed asking you to confirm that you want to 

purge the cells 

4. Click Confirm. 

5. Save the module to make the change permanent (click File > 
Save). 

The cells are permanently removed from the database. 
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Chapter  11  Working With Pictures and OLE Objects 

This chapter contains the following topics: 

• Working with pictures 

• Understanding OLE objects 

• Activating and deactivating an OLE object 

• Inserting a new OLE object 

• Inserting an existing file as an OLE object 

• Resizing OLE objects 

• Cutting, copying and pasting OLE objects 

• Editing OLE object properties 

• Deleting OLE objects 

• OLE objects and history 

• Setting the OLE open limit 

• Registered and Unregistered OLE Objects 

• Actions affected by changes to the handling of OLE objects 

• Actions unaffected by changes to the handling of OLE objects 
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Working with pictures 
You can insert the following picture formats into DOORS objects: 

• bmp 

• wmf 

• jpg, jpeg, jfif, jpe 

• png 

• gif 

• tif, tiff 

• dib, rle, bmz 

• emz 

• wmz 

To insert a picture: 
1. In the module window, select the appropriate object. 

2. Click Insert > Picture. 
 

 
3. In the File name box, type the name of the file that contains the picture, 

or use Browse to locate it. 

4. If you’re creating a new object, specify where you want to create it: 

• Click Same level to create it at the same level as, and immediately 

after, the current object. You need create access to the current 

object’s parent to do this. 

• Click One level below to create it one level below the current 

object. You need create access to the current object to do this. 

If the current object already contains a picture, you will see a Replace 
current picture option on the Insert Picture dialog box. 
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5. If you want to replace your picture, select the Replace current picture 

option. 

6. Click OK. 

Understanding OLE objects 
You can insert OLE objects into any text attribute in DOORS. There is no 

limit to the number of OLE objects that can be inserted into a text attribute. 

Use OLE objects carefully, however. They can diminish the performance 

of your application. 

If an attribute is displayed in a traceability column in another module, any 

OLE objects that have been inserted in the attribute are also displayed. 

 
Note You cannot insert an OLE object into the Object Heading 
attribute. 

You have several options when inserting an OLE object: 

 
Option  Description  
Insert as an 
icon  

The icon that is associated with the program is 
inserted. For example, if you insert a Word 
document as an icon, a Word icon is inserted in 
the attribute. You double-click the icon to 
activate the OLE object.  

Insert as a 
picture  

The OLE object is displayed as it appeared 
when it was last saved. For example, if you 
insert an Excel chart as a picture, the chart is 
displayed in the attribute. You double- the 
picture to activate the OLE object.  
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Option  Description  
Create New  This inserts a blank OLE object of the type you 

select into the attribute. You can then double-
click the OLE object to activate and edit it.  

Create from 
File  

This lets you browse to and insert a file that 
already exists on your system.  

Link or Embed  If you create the OLE object from file you can 
either link it to the file on your system, or embed 
it. If you link an OLE object, the path to the file 
on your system is stored with the OLE object, so 
you have a hot-link between the file and the OLE 
object in DOORS. If someone subsequently 
updates the file, the change is reflected in 
DOORS. If you embed an OLE object, you copy 
the file to the DOORS attribute. If someone 
subsequently updates the original file, the 
change is not reflected in the copy of it in 
DOORS.  

 

Activating and deactivating an OLE object 
When you activate an OLE object, the application with which it is associated is 

opened. You can either edit the OLE object in a new window, or in-place in the 

formal module. 

To activate an OLE object: 
1. Double-click the attribute in which the OLE object has been inserted to 

enter in-place edit mode. 

2. Select the OLE object. 

The Edit menu now contains an additional option for the OLE object that 

you have selected. For example, if you select a Microsoft Visio OLE 

object, the last item on the Edit menu is VISIO object. 
3. Click the OLE object name on the Edit menu, then either: 

• Click Edit to edit the OLE object in the formal module window. The 

menus and toolbars of the application associated with the OLE 

object replace the DOORS menus and toolbars. To deactivate the 

OLE object, click on another DOORS object. 
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• Click Open to open the application associated with the OLE object 

in a new window, and edit the OLE object in that window. When you 

have finished editing, save and close the file. The OLE object in 

DOORS is updated with your changes. 

Note  Menu items may vary depending on the type of OLE 

object that is selected. For example, if you select a 

PowerPoint Presentation, the additional option Show is displayed. 

Select this option to show the presentation. 

 

You can also double-click the OLE object in-place to activate it: 

• If the OLE object is displayed as an icon, the application associated 

with the OLE object is opened in a new window. When you have 

finished editing, save and close the file. The OLE object in DOORS 

is updated with your changes. 

• If the OLE object is not displayed as an icon, it becomes editable in 

the module window. The menus and toolbars of the application 

associated with the OLE object replace the DOORS menus and 

toolbars. To deactivate the OLE object, click on another DOORS 

object. 

Note  Double-clicking on a PowerPoint presentation OLE object 

runs the presentation slide show. If you want to edit a 

PowerPoint presentation OLE object, you must use the Edit 
menu to activate it. 

Inserting a new OLE object 
If you want to insert an OLE object into an attribute, you must have modify 

access to the attribute. 

To insert a new OLE object into a DOORS attribute: 
1. In the module window, select the DOORS object into which you want to 

insert the OLE object. 

2. Double-click the attribute into which you want the OLE object inserted, 

and position the cursor where you want the OLE object to appear. 
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3. Click Insert > OLE Object. 
4. Select the type of OLE object you want to insert from the Object Type 

list. Information about the type that is currently selected is displayed in 

the Result pane. 

5. Select the Display as Icon check box if you want the OLE object to be 

displayed as an icon in DOORS. The icon that is currently associated 

with the selected object type is displayed below the check box. If you 

want DOORS to use a different icon and title, click Change Icon, and 

specify a new icon and title. 

If you want the OLE object to display as editable information, leave the 

Display as Icon check box clear. 

6. Click OK. 

DOORS creates an empty OLE object of the specified type, embeds it 

in the current object, and then runs the appropriate program to let you 

edit the OLE object. For example, if you are inserting an Adobe 

Photoshop image, it runs Adobe Photoshop. 

Inserting an existing file as an OLE object 
You can use any of the following methods to insert an existing file into a 

DOORS attribute as an OLE object. 

• Click Insert > OLE object on the formal module menu bar. 

• Copy and paste, using the Paste Special option in DOORS. 

• Drag and drop. You cannot link the OLE object if it is inserted using 

drag and drop. 

To insert an existing OLE object using the Insert > OLE object menu 
option: 

1. In the module window, select the DOORS object into which you want to 

   insert the OLE object. 

2. Double-click the attribute into which you want the OLE object inserted, 

and position the cursor where you want the OLE object to appear. 

3. Click Insert > OLE Object, and select the Create from File radio button. 

4. Enter the path to the file you want to insert, or click Browse to select it. 
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5. Select the Link check box to link the OLE object to the source file, or 

clear it to embed the OLE object in the DOORS module. 

6. If you want the OLE object to be displayed as an icon in DOORS, select 

the Display as Icon check box. The icon that is currently associated with 

the selected object type is displayed below the check box. If you want 

DOORS to use a different icon and title, click Change Icon, and specify 

a new icon and title. 

If you want the OLE object to display as editable information, leave the 

Display as Icon check box clear. 

7. Click OK. 

The file is inserted into the current object as an OLE object. 

To insert an existing OLE object using copy and paste: 
1. You can either: 

• In the Windows Explorer, select the file you want to insert and copy 

it  

• Open the file and select the contents that you want to insert and 

copy them 

2. In the module window, select the DOORS object into which you want to 

insert the OLE object. 

3. Double-click the attribute into which you want the OLE object inserted, 

and position the cursor where you want the OLE object to appear. 

4. Select Edit > Paste Special. 
5. Select Paste to embed the OLE object in the DOORS module, or Paste 

Link to link the OLE object to the source file. For information on linking 

and embedding files see “Understanding OLE objects,” on page 188. 

6. If you want the OLE object to be displayed as an icon in DOORS, select 

the Display as Icon check box. The icon that is currently associated with 

the selected object type is displayed below the check box. If you want 

DOORS to use a different icon and title, click Change Icon, and specify 

a new icon and title. 

 



Centers for Medicare & Medicaid Services  
  

167  

If you want the OLE object to display as editable information, leave the 

Display as Icon check box clear. 

7. Click OK. 

The contents of the clipboard are pasted into the attribute as an OLE object. 

Note  Some OLE objects can be pasted but not activated. For 

example, if you copy a picture from a browser window and 

paste it into DOORS, it is displayed but it cannot be 

activated. These metafiles are static OLE objects. 

To insert an existing OLE object using drag and drop: 
1. In the module window, select the DOORS object into which you want to 

insert the OLE object. 

2. Double-click the attribute into which you want the OLE object inserted, 

and position the cursor where you want the OLE object to appear. 

3. Using the Windows explorer, navigate to the file you want to embed, 

select it, then drag it onto the target object in DOORS. 

The file is embedded in the current object as an OLE object. 

Note You cannot link the OLE object if it is inserted using drag 

and drop. 

Resizing OLE objects 
If an inserted OLE object is too large to fit in the column in which it has 

been inserted, you can resize it to fit the column. You can resize all of the 

OLE objects in a module, or just the OLE objects in the current object. 

To resize OLE objects to fit the column in which they are inserted, select 

Tools > Support Tools, then either Set OLE Size For Current Object or 

Set OLE Size In All Objects in the formal module window. 

To reset OLE objects to their original size, select Tools > Support Tools, 

then either Reset OLE Size In Current Object or Reset OLE Size In All 
Objects. 
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Cutting, copying and pasting OLE objects 
You can cut and paste or copy and paste OLE objects. 

The following steps describe how to do this: 
1. In the module window, select the DOORS object containing the OLE 

object you want to cut or copy. 

2. Double-click the attribute containing the OLE object to enter edit mode, 

and select the OLE object. 

3. Select Cut or Copy. 

4. Double-click the attribute you want to paste to and right-click Paste to 

nsert the OLE object. 

You can also use cut or copy if you want to paste OLE objects from DOORS to 

external applications. 

Note  You need to be in in-place edit mode to insert an OLE 

object. Consequently, you cannot cut and paste OLE objects 

between different attributes. You can, however, cut and paste 

within the same attribute. 

Editing OLE object properties 
You can change the properties of an OLE object using the OLE Object 

Properties. The options that are available depend on whether the OLE object is 

embedded or linked. 

Editing the properties of an OLE object: 
1. In the module window, select the DOORS object containing the OLE 

object whose properties you want to edit, and double-click to enter in-

place edit mode. 

2. Select the OLE object, then click Edit > OLE Object Properties. 

3. The General tab displays the file information for the OLE object. 

The Convert button is unavailable. 

4. Use the View tab to change the appearance of the OLE object in the 

module. 



Centers for Medicare & Medicaid Services  
  

169 

Field Description  
Display as 
icon 

If the OLE object is currently displayed in the 
module as editable information select this button 
to display it as an icon. You double-click the icon 
to edit the OLE object 

Change icon If the OLE object is displayed as an icon, click 
this button to change the icon or the icon’s label. 

Scale This field is unavailable, if you want to resize an 
OLE object, select the OLE object and drag the 
sizing handles. 

Relative to 
original size This field is unavailable. 

 
5. Use the Link tab to edit the link properties of the OLE object. 

Note  This tab is not present if the selected OLE object is 

embedded in the module.  

The link tab displays: 

• The path to the linked file on your system 

• The date and time that the file was last updated 

The following options are also available: 

Use  To 

Automatically 
or Manually 

This functionality is not supported in DOORS. 
Linked OLE objects in DOORS are automatically 
updated regardless of the setting. 

Change 
Source 

Manually update the path to a file that has been 
moved. You can also use this button if you want 
to replace the existing OLE object. 
Click the button, navigate to the new file 
location, select the file and click OK. The path is 
updated.

Open Source 
Open the source file. 

Update Now
Redraw the OLE object 
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Use  To 

Break Link  This functionality is not supported in DOORS. 
Clicking Break Link does not remove the link 
between the OLE object and the source object. 
If you want to remove the link from the OLE 
object, delete it and insert it again without 
linking. 

 

Deleting OLE objects 
There are two ways to delete an OLE object. You can: 

• Delete an OLE object as well as the DOORS object that contains it. 
Select the object, then either: 

• Press DELETE. 
• Click File > Delete. 

You must have delete access to the object to do this. 
• Delete an OLE object but not the DOORS object that contains it. 

a. Select the object then double-click the attribute where the OLE 
object has been placed to enter edit mode. 

b. Select the OLE object you want to delete. It will become 
highlighted. 

c. Press DELETE. 
You must have modify access to the object to do this. 

OLE objects and history 
OLE objects can now be saved as part of a history record. This allows 
users to compare a current OLE object (or set of OLE objects) with that 
which preceded it. 
Using this setting can have a major effect on performance and disk space 
requirements, so by default it is switched off. 

To enable it: 
1. Right-click on Database  , and select Properties. 
2. In the OLE in history section, select the Save OLE objects in attribute 

history option. 
Now when you view the history of a particular object, you can determine how an 

OLE object has changed over time. 

Setting the OLE open limit 
When you open a module, the OLE objects in the module are pre-loaded 

from the database into memory. By default, up to five OLE objects can be 

pre-loaded into memory at any one time. 
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The demands of these OLE objects on memory can result in poor 

performance. To improve performance, you can reduce the number of 

OLE objects that are pre-loaded. 

To do this: 
• Edit the oleopenlimit entry in your registry. 

The default value of oleopenlimit is 5. A value of 0 means there is no 

limit. 

Registered and Unregistered OLE Objects 
There have been problems with data loss related to OLE objects in 

previous versions of DOORS. 

The following sections describe how DOORS now behaves when it 

encounters OLE objects. The terminology used is explained in the table 

below. 

 
OLE Type  Definition  

Registered OLE 
objects  

If the application associated with an OLE object in DOORS is 
installed on the DOORS client, the OLE  
object is registered. It can be opened from DOORS and 
edited.  
For example, if a DOORS module you are working on contains 
a Word document, and you have  
Microsoft Word installed on your machine, that Word document 
is a registered OLE object.  

Unregistered OLE 
objects  

If the application associated with an OLE object in DOORS is 
not installed on the DOORS client, the OLE object is 
unregistered. It cannot be opened  
from DOORS and edited. For example, if a DOORS  
module you are working on contains a Word  
document and you do not have Microsoft Word  
installed on your machine, the Word document is an  
unregistered OLE object.  
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OLE Type  Definition  

Static OLE objects  A staticOLE object is a picture which cannot be  
edited regardless of what applications you have  
installed on your machine. For example, if you take a  
screenshot and paste it into a DOORS object, it is a  
static OLE object.  

 
 

Actions affected by changes to the handling of OLE objects 

DOORS now displays warnings if objects containing unregistered OLE objects 

are accessed. The warnings and behavior for each action that is affected are 

listed below. 

Edit in-place or using the Object Properties sheet. 
 
Action  Result  

Double-click on an  
unregistered OLE 
object  

The following message is displayed:  
 

 
Attempting to activate an unregistered OLE object does not 
cause any data loss.  

Edit text surrounding 
an unregistered OLE 
object  

If you edit text contained in the same attribute as an  
unregistered OLE object, the OLE object is unaffected. It 
remains unregistered on your machine, but can be accessed 
on machines that have the  
associated application installed.  

 
Caution If you edit an object that contains an unregistered OLE 

object using the change proposal system, and that change 

is approved and applied, the unregistered OLE object is 
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converted to a static OLE object and data contained in 

that OLE object is lost.  

Copy and paste in-place or using the object properties sheet 
 

Action  Result  

Cut an unregistered 
OLE object and some 
surrounding text 

The following warning is displayed. 

 
 
If you click YES, the unregistered OLE object is converted to a 
static object when it is pasted, and information held in the OLE 
object is lost. 
If you click No, the cut operation is reversed and the data is not 
affected. 

Cut a selection of OLE 
objects. Where one or 
more of them are 
unregistered. 

The following warning is displayed: 
 

 
 
If you click Yes any unregistered OLE objects are converted to 
static OLE objects when they are pasted, and information held 
in the OLE objects is lost. 
If you click NO, the cut operation is reversed and the data is 
not affected. 
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Cut and paste in-place or using the Object properties sheet 
 
Action  Result  

Cut an unregistered 
OLE object on it own 

When you paste the OLE object, it remains unregistered and 
can be accessed on the machines that have the associated 
application installed. 

Cut a selection of OLE 
objects. And some 
surrounding text. 

The following warning is displayed: 
 

 
 
If you click Yes any unregistered OLE objects are converted to 
static OLE objects when they are pasted, and information held 
in the OLE objects is lost. 
If you click NO, the cut operation is reversed and the data is 
not affected. 

Cut s selection of OLE 
objects, when one or 
more of them are 
unregistered. 

The following warning is displayed: 
 

 
 
If you click Yes, any unregistered OLE objects are converted to 
static OLE objects when they are pasted and information held 
in the OLE objects is lost. 
If you click No, the cut operation is reversed and the data is not 
affected, 

 

Copy or cut a DOORS object containing an unregistered OLE object in an 
attributes 
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Note  This is the case for all methods of copying and cutting 

objects within a module, i.e using keyboard shortcuts, drag 

and drop or the menu items. 

 
Action  Result  
Copy or cut and paste an object 
containing an unregistered OLE 
object  

The OLE in the original object, 
and in the copied or moved 
object remains unregistered 
and can be accessed on 
machines that have the 
associated application installed  

 
Copy objects using the Object Copier 

If you copy an object that contains one or more unregistered OLE objects 

to another module using the Object Copier (Tools > Functions > Copy 
Objects), the object and OLE objects are copied successfully and no data 

is lost. 

Export data from DOORS 
If you export a module from DOORS to any other application, unregistered 

OLE objects are exported as pictures. The unregistered OLE objects in 

the DOORS module are unaffected by the export and no data is lost in 

DOORS. If DOORS encounters unregistered OLE objects during an 

export to another application, a message is displayed to inform the user 

that the exported OLE objects will be converted to pictures: 

 
 

If the application to which you want to export the module supports OLE, a new 

check box is displayed on the Export dialog box. For example, the Export to 
Word dialog box now looks like this: 
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The Issue a warning when an unregistered OLE Object is exported as a 
picture check box is selected by default. Clear the check box if you do not want 

to receive warnings during export. 

Paste unregistered OLE objects into other applications 
If you cut or copy an unregistered OLE object to the clipboard, then paste it into 

another application, the OLE Object is pasted as a picture, and data contained in 

the OLE object is lost. If the OLE object is copied, the original remains 

unregistered and no data is lost in DOORS. 

Actions unaffected by changes to the handling of OLE objects 
The following areas of functionality were unaffected in previous versions of 

DOORS by the data loss problem related to OLE objects. They remain 

unchanged. 

Merge Objects 
When you merge objects in DOORS, OLE objects are not included in the 

resulting object. This is the case whether the OLE objects are registered, 
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unregistered or static. The following message is displayed when you 

merge objects containing OLE Objects: 

 
When you merge objects, the OLE objects in the original objects are 

unaffected, and no data is lost. 

Create a Baseline 
Baselining a module that contains unregistered OLE objects does not 

affect the OLE objects. They remain unregistered in both the baseline and 

the current version of the module. No data is lost. 

Copy a baseline 
When you copy a baseline of a module that contains unregistered OLE 

objects, the new module contains the unregistered OLE objects, and no 

data is lost. The data can be accessed on machines that have the 

associated application installed. 

Clone a module 
The clone module functionality is not designed to clone OLE objects, so 

any unregistered OLE objects in the original module are unaffected and no 

data is lost. This is the case in all previous versions of DOORS and there 

is no change in functionality in this patch. 

Cut or Copy modules in the database explorer 
When you copy and paste a module that contains unregistered OLE 

objects in the DOORS database explorer, the OLE objects are copied 

successfully and no data is lost. 
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Import data to DOORS 
You cannot import an unregistered OLE object to DOORS. This is the 

case in all previous versions of DOORS and there is no change in 

functionality in this patch. 

Archive and restore 
Unregistered OLE objects are unaffected by archive and restore 

operations, and no data is lost 

Partition/Rejoin 
Unregistered OLE objects are unaffected by partition/rejoin operations, 

and no data is lost 

Find and Replace 
Edits made to text contained in the same attribute as unregistered OLE 

objects during Find and Replace operations have no affect on 

unregistered OLE objects and no data is lost. 

Linking 
Creating, editing and navigating links does not affect unregistered OLE 

objects. 
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Chapter  12  Using Links 
 

This chapter contains the following topics: 

• Understanding links 

• Understanding external links 

• Using link arrows 

• Creating links 

• Creating external links 

• Clearing the link start 

• Understanding link modules and linksets 

• Controlling access to a link module 

• Understanding how copy and move affect links 

• Editing links 

• Creating link attributes 

• Deleting links 

• Using the create links tool 

• Linking by attribute 

• Understanding link module defaults 

• Creating default linkset pairings 

• Control on links for process management 

• Showing link module information 

• Creating a link module 

• Creating a linkset 

• Deleting a linkset 
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Understanding links 
DOORS lets you link together related information. You can follow links by 

simply clicking them. For example, you can link a user requirement to the 

design features that fulfill that requirement. And you can link the design 

features to the tests that are carried out to verify the design features. 

Links give you traceability. You can check that what you’re building 

satisfies your user requirements. 

You can follow links in both directions. For example, if a test fails, you can 

find out which requirements are affected by tracing the links from the test 

back to the design features, and from the design features back to the 

requirements. 

 

Links allow you to effectively manage change. You can quickly trace the 

impact of a change to a single piece of data on the rest of your system. 

 

For example, the engineering department tells you they can’t deliver the 

solar-powered battery you were expecting. You can trace the links from 

the battery object back to the requirements that depend on it, and forward 

to the other features of the car that depend on having a solar-powered 

battery. You can quickly see the full impact of not having a solar-powered 

battery. You can make an informed decision about whether to just use a 

conventional battery or whether to invest more money and resources to 

help deliver a solar-powered battery. 

Understanding external links 
You use external links to create a link from a DOORS object to an entity or 

resource that is outside the current DOORS database. For example, you 

might create an external link to a website, or to a different DOORS 

database. External links can be marked as URLs. Where an external link 

is a URL, it is treated like a hyperlink and is opened by the default 
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browser. If an external link is not marked as a URL, nothing happens 

when the external link is selected. 

 
Note  If you are running DOORS through Citrix, the application 

Referenced by the external link must also be running through 

Citrix or the external link will not work. 

An external link is a one way link to the resource it references. No 

corresponding link is created in the linked resource, although you can 

create a link in the resource back to the DOORS object by inserting the 

DOORS URL in the resource.  

External links do not use link modules. All of the information about the link 

is stored with the external link. External links are not a property of the 

object to which they are attached. They behave as separate objects, and 

can have different attribute values than the objects to which they are 

attached. 

Using link arrows 
Linked objects have link arrows in the main column: 

• Out-links have red link arrows 

 

 

• In-links have yellow link arrows  

Some module baselines may display link arrows that look like this: . These 

arrows signify links to and from modules that are not in the same baseline set 

definition, called echoed links.  
Note  You can turn off link arrows. If you can’t see any link arrows, 

select the module’s view settings. Click View > Show > Link Arrows. 

Roll over the link arrow to see how many in-links, out-links and external links 

the object has. Only information about modules you have read access to is 

displayed. 

 
Right-click the link arrow to see a pop-up menu that shows the names of the 
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modules that contain the objects at the other end of the links. If the object has 

external links, they are listed in alphabetical order in the External Links 
submenu 

 
For example, in this picture, the current object has out-links to 2 objects in the 

Functional Requirements module. This module isn’t open, so n: <unloaded> is 

displayed, where n is the object number. It also has one or more external links. If 

you roll over the External Links menu item, the description of each external 

link is displayed. External links are displayed in alphabetical order. 

To follow a link, select it from the pop-up menu: 

• If the link is to a DOORS object, the module that it’s in is 

automatically opened if it’s not already open and the linked object is 

selected. 

• If the link is an external link and the external link is a URL, the 

linked resource is opened by your default browser. If the external 

link is not a URL it cannot be opened, and a message is displayed. 

Note There is a limitation in the Microsoft rich edit control which 

results in double-byte characters not being automatically 

highlighted when they are part of a URL. This affects 

external links in DOORS, so that if an external link URL 

contains double-byte characters it cannot be followed from 

DOORS by clicking the external link. You can copy and 

paste the URL into a browser window and the item referred 

to by the link will open as expected. 

Creating links 
This topic describes two ways to create a link: 

• Using drag-and-drop 

• By explicitly defining the link start 

Using drag-and-drop 
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You can use drag-and-drop to create links from multiple objects to a single 

object. You can’t use it to create links to multiple objects. 

To create a link using drag-and-drop: 
1. If the objects you’re creating links between are in different modules, open 

both modules and re-size their windows so that you can see both 

modules on your screen at the same time. 

2. Select the objects that you want to link to or from and then, without 

releasing the mouse button, drag your cursor to the object you want to 

link. If you want to link from multiple objects, don’t release the mouse 

button after making the multiple object selection. You lose your selection 

if you  release the mouse button between selecting the objects and 

dragging the mouse. 

3. Release the mouse button. 

A pop-up menu is displayed. 

• Click Make Link from Start to create links from the objects you 

selected 

• Click Link > Make Link to Start to create links to the objects you 

Selected 

While you are dragging the mouse, the objects you selected in step 2 are 

highlighted with a pink background, showing that they are the link start. 

If you select Cancel on the pop-up menu, the source objects stay pink. 

Note  The quickest way to create a link between single objects, 

is to hold down both the SHIFT and CTRL keys when 

you release the mouse button over the target object in 

Step 3. This bypasses the pop-up menu and creates a link 

from the source object to the target object. 

4. You may see a message saying that a default link module doesn’t exist. 

Click Yes to create it. 

5. You may see a message saying that a linkset doesn’t exist. Click Yes to 

create it. 

Explicitly defining the link start 
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To create a link by explicitly defining the link start: 
1. Select the object or objects that you want to link to or from. 

2. Click Link > Start Link. 

If you selected multiple objects in Step 1, a message is displayed asking 

if you want to link to or from all of the selected objects or the current 

object only. Select the appropriate option. The link start objects turn pink. 

3. Select the object or objects that you want to link to or from. 

• Click Link > Make Link from Start to create links from the objects 

you selected in step 1. You can also use the keyboard shortcut 

CTRL+SHIFT+F to create the links. 

• Click Link > Make Link to Start to create links to the objects you 

selected in step 1. You can also use the keyboard shortcut 

CTRL+SHIFT+M to create the links. 

If you selected multiple objects in Step 3, a message is displayed asking if 

you want to create links to all of the selected objects or to the current 

object only. Select the appropriate option. 

4. You may see a message saying that a default link module doesn’t exist. 

Click Yes to create it. 

5. You may see a message saying that a linkset doesn’t exist. Click Yes to 

create it. 

Creating external links 
This section describes how to create external links that are URLs, for example 

links to web pages, or other DOORS databases. To create external links you 

must have create or modify access to the object. 

There are two options for creating external links. You can use: 

• The New External Link menu option to create external links to any 

URL. 

• Drag-and-drop to create external links to formal module objects in 

other databases or to URLs that are displayed in Internet Explorer or 

Firefox browser windows. You cannot use drag-and -drop to create 

external links if you are in-place editing an object. 
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When you drag-and-drop a browser URL, you must drag the icon in the 

address bar, not the address itself, as shown in the following example: 

 
Note  External links can also be used to facilitate integration 

between DOORS and other applications. This use of 

external links is not discussed here, but information and 

examples are available in a white paper, which can be 

downloaded from our website at 

https://support.telelogic.com/en/doors/info/docs/. 

To create an external link using the menu option: 
1. Select the object that you want to contain the external link, and click Link 

> New External Link. 

2. In the New External Link dialog box, type a Name and Description for 

the link. The Description will be displayed in the External Link sub-menu 

when you right-click on the link arrow. 

3. Enter the URL for the link in the Link Path box. 

If you want to create an external link to an item in DOORS, right-click on 

the item you want to link to and click Copy URL. This copies the item’s 

URL to the system clipboard. You can then paste the URL into the Link 
Path box on the New External Link dialog box. 

4. Select Open URL with default browser. 
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5. Select whether you want the link to be displayed as an in-link or out-link 

in the module. 

This does not affect the link behavior. In either case, when you select the 

link the resource referenced by it is opened by the default browser. No 

corresponding link is created in the resource. 

6. Click OK. 

You can create a corresponding link in the resource back to the DOORS 

object by copying the DOORS URL from the object properties sheet and 

pasting it into the resource. If the resource is a DOORS object, you can 

create a two-way link by creating an external link in that object. 

To create an external link using drag-and-drop: 
1. Drag-and-drop the DOORS formal module object, or the icon in the 

browser address bar to the object in which you want to create the 

external link. 

2. Click Confirm. 

The Edit External Link dialog box is displayed. The Name, Description 
and Link Path text boxes are populated with information about the object 

or URL. The external link is created as an out-link by default. 

3. Edit the Name, Description, Link Path and Direction if necessary, then 

click OK. 

The external link is created, and the external link description is displayed 

in the External Link sub-menu when you right-click on the link arrow in 

the object. 

Clearing the link start 
The object or objects that are currently defined as your link start are highlighted 

with a pink background. 

To clear the link start, either: 
• Click Link > Clear Start. 
• Define a new link start by selecting another object or objects. 

You can do this in any formal module. You don’t have to do it in the one 

that contains the current link start. 
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Understanding link modules and linksets 
Link modules store information about normal DOORS links. 

Within each link module, the information is subdivided into linksets. Each 

linkset contains information about the links from one particular module to 

another. 

For example, a link module has four linksets, which contain information about 

links for two modules, A and B: 

 
This 
linkset  Contains information about links from  

A => B  Module A to module B  

B => A  Module B to module A  

A => A  Module A to module A (links between objects within 
module A)  

B => B  Module B to module B (links between objects within 
module B)  

 
Notice that the direction of the links matters. Links from module A to B are not 

stored in the same linkset as links from module B to A. 

Note External links are not stored in link modules. 

DOORS Links, the default link modules 
By default, DOORS uses link modules called DOORS Links: 

• The first time you create a link from a particular module, DOORS 

offers to create a link module called DOORS Links in the same folder 

as the module (if it doesn’t already exist), and a linkset in DOORS 

Links. 

• Next time you create a link from the module, DOORS uses the 

DOORS Links module in the local folder. It offers to create a linkset in 

DOORS Links if the linkset doesn’t already exist. 

 

Why use other link modules? 
The DOORS defaults are designed to meet the needs of most users. Most 

users won’t even know what link modules and linksets they are using. 
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You should use other link modules if you want to use links to express 

different types of relationship, and you need to analyze your data 

according to the type of the link. 

To do this, you create your own link modules, and use different link 

modules for different types of links. For example, you create a link module 

called Traceability Links for your traceability links, and a link module called 

Accounting Links for your accounting links. 

 
 

You can then run traceability and other analyses on a particular type of 

link. You specify the link module you want to use for the analysis, so you 

only analyze links of the type that are stored in that link module. 

Note  If you want to create links in this way, you must use the 

Links > Create Links option from your module, and the 

module must not be set up to use mandatory linkset pairings. 

Controlling access to a link module 
To change the access rights for a link module, you must have admin access to 

the module. 

To change the access rights for a link module: 
1. You can change the access rights for a module from either the DOORS 

Explorer or the module window: 

• In the DOORS Explorer, select the module then right-click 

Properties 
• In the module window, click File > Module Properties 
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2. Click the Access tab. 

The current access rights for the module are displayed. 
 

You need this 
access right  To 

Read ( R)  See the module. If you  don’t have read access, the module is not 
displayed in your DOORS Explorer. 

Create ( C ) Create linksets in the module. 
Create attribute types and attribute definitions for he module 

Modify ( M ) Change the module’s name, description, or attribute values. 
Create a link in the link module 

Delete ( D ) 
Delete, undelete and purge the module. 
Delete a linkset from the module. 
Cut the module to the DOORS Explorer clipboard. 

Admin ( A ) Change the access rights for the module. 
If the module is partitioned in, the access rights associated with the partition 

are displayed. These describe the maximum access that any user has. They 

override the RCMD access rights displayed for users and groups. 

For example, if a user’s entry says full access (RCMDA), but the module is 

partitioned in read only, in practice the user has only read (R) access. 

3. Make the changes you want. 

Access Tab Description 

Inherit form 
parent 

Select this check box if you want the module to inherit its access rights 
from the project or folder that it’s in. 
When this check box is selected, the list of access rights is grayed out, 
and shows what access rights the module is inheriting. 

Add 

To add a new entry to the list of access rights; 
a. Click Add. 
The Add Access dialog box is displayed. 
b. In the Name box, select the name of the user or 
group that you want to add an entry for. 
c. Select the access rights you want to give them, then 
click OK. 
 

Remove 
 

To remove an entry from the list of access rights, select 
the entry, and then click Remove. 
 

Edit 
 

To edit an entry in the list of access rights: 
a. Select the entry then click Edit. 
The Edit Access dialog box is displayed. 
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Access Tab Description 

b. Select the access rights you want to give them, then 
click OK. 
 

 

4. Click OK. 

Understanding how copy and move affect links 
This topic looks at what happens when you copy or move objects that 

have links. 

When you use cut and paste: 

• The first time you paste, you simply move the thing you’re pasting. 

• if you paste it again, you copy it. 

The following table describes the rules that apply when you copy or 

move objects by using either drag-and-drop or copy, cut and paste in the 

DOORS Explorer or module windows. External links are always copied 

because all of the information about them is contained in the object, and they 

do not use link modules. 
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If you  Then  

Move an object, module, folder 
or project that contains links  

All of the links are preserved.  

Copy an object that has links  Out-links are copied if you copy the object within the 
same module. Each copied out-link uses the same link 
module as the original out-link. The following rules 
apply to in-links:  

• If you’re copying the object to another 
module, links are not copied.  

• If you’re copying the object within the same 
module, an in-link is only copied if you have 
modify access to the (source) object at the 
other end of the link. If you have modify 
access, a message is displayed asking if you 
want to copy the in-link. 

 If you don’t have modify access, a message is 
displayed telling you that the in-link will not be copied 
and asking if you want to continue with the copy 
operation.  
If an object you copy has a link that uses a mandatory 
linkset pairing, which goes through a link module that 
has one-to-one mapping, the following message is 
displayed when you paste the object:  
 
 

 
• Click Yes to copy the object without the link  
• Click No to cancel the copy operation  
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If you  Then  

Copy a formal or descriptive 
module that contains links  

Out-links are always copied. An in-link is only copied if 
you also copy the module that contains the (source) 
object at the other end of the link. The link module 
used by the out-link in the copied module depends on 
two things:  

• Whether the out-link in the source module 
uses a link module that is also being copied.   

• If the link module is not being copied, 
whether the link module is local (a local link 
module has the same parent folder or project 
as the module itself).  

If the out-link uses a link module that is also being 
copied, then the out-link in the copied module uses the 
copied link module. If the out-link uses a local link 
module, L, that is not being copied, then the out-link in 
the copied module also uses a local link module. This 
link module is also called L, and is created if it doesn’t 
already exist. If the out-link uses a non-local link 
module that is not being copied, then the out-link in the 
copied module uses the same link module as the out-
link in the source module.  
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If you  Then  
Copy a folder or project that 
contains links  

Out-links are always copied. An in-link is only copied if 
you also copy the module that contains the (source) 
object at the other end of the link. The link module used 
by the out-link in the copied module depends on two 
things: 

• Whether the out-link in the source module 
uses a link module that is also being copied.  

• If the link module is not being copied, 
whether the link module is local (in this case, 
a local link module is one that has the same 
parent as the folder or project you’re copying).  

If the out-link uses a link module that is also being 
copied, then the out-link in the copied module uses the 
copied link module. If the out-link uses a local link 
module, L, that is not being copied, then the out-link in 
the copied module also uses a local link module. This 
link module is also called L, and is created if it doesn’t 
already exist. If the out-link uses a non-local link 
module that is not being copied, then the out-link in the 
copied module uses the same link module as the out-
link in the source module.  

 

Editing links 
This topic describes how to use the object properties sheet to: 

• Show information about links. 

• Delete links. 

• Edit link attributes values (out-links and external links only). 

Note You can use link attributes to record information about your 

links. For example, you might create an attribute called 

Purpose which you use to record why the link was created. 

To edit links: 
1. In the module window, select the object whose links you want to edit. 

2. Click Link > Edit Links. 

The object properties sheet is displayed, with the Links tab selected. 
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A list of all the links in and out of the object is displayed. 

For each link: 

• The In/Out column tells you the direction of the link, and whether it is 

a normal DOORS link or an external link. 

• The Module/Description column tells you: 

• For normal DOORS links, the module that contains the object at 

the other end of the link. The path from the module’s nearest 

ancestor project is displayed. 

• For external links, the external link description 

• The Baseline column tells you what version of the source or target 

module the object is linked to. For external links this column is blank. 

• The Object Heading/Text column displays: 
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• For normal DOORS links, the first part of the Object Heading, if the 

object at the other end of the link has Object Heading. If it does not 

have Object Heading, the first part of the Object Text is displayed. 

• For external links, the external link name. 

• The ID column shows the object identifier of the object at the other 

end of the link. For external links, this column is blank. 

• The Link Module column tells you the link module that contains the 

link. The path from the link module’s nearest ancestor project is 

displayed. For external links, this column displays N/A. 

• The Link Module Baseline column tells you what version of the link 

module contains the link. For external links, this column displays N/A. 

3. To follow a link, select it, then click Follow Link. 

4. To delete a link, select it, then click Delete. 

Note You can’t undelete a link once you’ve deleted it. 

5. To see information about a link’s attribute or edit that information: 

a. Select the link, then click Details. 
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If it’s an out-link or an external link, you can edit any attribute values 

that you have modify access to. 

Note  Links have default system attributes that you can’t 

edit. Read-only is displayed at the left. 

b. Select the attribute, then click Edit. Edit the attribute value, then click 

OK. 

 
c. Click OK. 

6. Click OK. 

7. Click OK. 

Deleting links 
This topic describes how to delete links in bulk: 

• You can delete normal DOORS links from the current module to a 
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particular module. 

• You can delete all the normal DOORS links in the current module. 

• You can delete all the external links in the current module. 

You can also delete links using the object properties sheet . 

Note You can’t undelete a link once you’ve deleted it. 

To delete a normal DOORS link you must have: 

• Modify access to the source object and the link module. 

• Read access to the target object. 

To delete an external link you must have create or modify access to the 

object containing the link. 

To delete normal DOORS links from the current module to a particular 
module: 

1. In the current module, select the objects you want to delete links from. 

Note  You can ignore this step if you want to delete links from 

every object in the current view. 

2. Click Link > Delete Links. 

 
 

3. Specify which objects you want to delete links to: 

• In the Target module box, type the name of the target module, or 

use Browse to locate it. You must specify the path to the module 

from its nearest ancestor project. 
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• Click Raise to open the target module if it’s not already open, or to 

raise it to the front of your screen if it is already open. 

• If you want to delete links to a subset of the objects in the current 

view, select the objects in the target module window. 

4. In the Link module box, type the name of the link module, or use 

Browse to locate it. You must specify the path to the module from its 

nearest ancestor project. 

To delete links the link module must be open. Click Raise to open it. If the 

link module is already open, clicking Raise will bring it to the front of your 

screen. 

5. Use the Link drop-down list to specify what links you want to delete: 

• Select Selection to selection to delete links from all objects 

currently selected in the source module to all objects currently 

selected in the target module. 

• Select Selection to display set to delete links from all objects 

currently selected in the source module to all objects in the target 

module’s current view. 

• Select Display set to selection to delete links from all objects in 

the source module’s current view to all objects currently selected in 

the target module. 

• Select Display set to display set to delete links from all objects in 

the source module’s current view to all objects in the target 

module’s current view. 

6. Select the Confirm check box if you want to get a confirmation message 

that tells you how many links are about to be deleted. 

7. Click OK. 

To delete all the normal DOORS links in a module: 
1. In the module window, click Link > Delete All Links. 

2. A message is displayed asking if you really want to delete all the in- and 

out-links. Click Confirm to delete all links. 

To delete all external links in a module: 
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1. In the module window, click Link > Delete All External Links. 

2. A message is displayed asking if you really want to delete all the external 

in-and out-links. Click Confirm to delete all external links. 

Using the create links tool 
This topic describes how to create links in bulk, from the current module to 

another module. You cannot use this tool to create external links in bulk. 

Note  You can also create links using drag-and-drop and the Link 

menu options (see “Creating links,” on page 212). 

To create links from the current module to a particular module: 
1. In the current module, select the objects you want to create links from. 

Note  You can ignore this step if you want to create links from 

every object in the current view. 

2. Click Link > Create Links. 

 

 
3. Specify which objects you want to create links to: 

• In the Target module box, enter the target module, or use Browse to 

locate it. You must specify the path to the module from its nearest 

ancestor project. 

• Click Raise to open the target module if it’s not already open, or to 

bring it to the front of your screen if it is already open. 

• If you want to create links to a subset of the objects in the current 

view, select the objects in the target module window. 
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4. In the Link module box, enter the link module you want to use, or use 

Browse to locate it. You must specify the path to the module from its 

nearest ancestor project. 

If you want to look at the link module, click Raise to open it. If the link 

module is already open, clicking Raise will bring it to the front of your 

screen. 

5. Use the Link drop-down list to specify what links you want to create: 

• Select Selection to selection to create links from all objects currently 

selected in the source module to all objects currently selected in the 

target module. 

• Select Selection to display set to create links from all objects 

currently selected in the source module to all objects in the target 

module’s current view. 

• Select Display set to selection to create links from all objects in the 

source module’s current view to all objects currently selected in the 

target module. 

• Select Display set to display set to create links from all objects in the 

source module’s current view to all objects in the target module’s 

current view. 

6. Select the Confirm check box if you want to get a confirmation message 

that tells you how many links are about to be created. 

7. Click OK. 

Linking by attribute 
If you have a module that contains an attribute whose values are the 

absolute numbers of objects in another module, you can automatically 

create links between the two modules. 
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For example, in this diagram module A has an attribute Relates to that 

stores the absolute number of the related object in module B. You can 

automatically create links between the related objects, as shown in the 

diagram above. 

Note  In the source module, the attribute that you use for linking 

must be of type text. If it contains more than one absolute 

number, each number must be on a separate line. 

To link by attribute: 
1. In the source module window, click Link, then Link by Attribute. 

2. In the Target module box, type the name of the target module, or use 

Browse to locate it. You must specify the path to the module from its 

nearest ancestor project. 

3. In the Link module box, type the name of the link module you want to 

use for the links, or use Browse to locate it. You must specify the path to 

the module from its nearest ancestor project 

4. In Existing attributes, select the attribute in the source module that you 

want to use. This is the attribute whose values are the absolute numbers 

of objects in the target module. 

5. In the Link direction box, select the direction of the links. 

You can create links from the source module to the target module, from 

the target module to the source module, or in both directions. 

6. Click OK. 
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Understanding link module defaults 
For each pair of modules, you can define the default link modules that are 

used whenever anyone creates a link between the two modules. 

If you have two modules, A and B, you can define two default link 

modules: 

• The default link module that is used for links from A to B 

• The default link module that is used for links from B to A 

We call these default linkset pairings. 

For example, links from requirements to use cases might be stored in the 

design link module, and links from requirements to test in the verification 

link module. 

Using default link modules 
Your user default link module is used whenever you create a link and 

there isn’t a default linkset pairing for the source-to-target module pair. 

 

By default, your default link module is DOORS Links. 

 

If you change your user default link module to say, Mylinks, then 

whenever you create links between modules that don’t have a default 

linkset pairing, DOORS uses Mylinks in the source module’s folder. If the 

folder doesn’t already contain a link module called Mylinks, DOORS 

automatically creates it. 

Alternatively, you can set your default link module to a particular link 

module in your DOORS database, by specifying the full path of the link 

module, starting with its nearest ancestor project. Whenever you create 

links between modules that don’t have a default linkset pairing, DOORS 

uses this particular link module, regardless of which folder or project the 

source module is in. 

To change your default link module: 
1. In the DOORS Explorer, click Tools > Options. 

2. Click the Settings tab. 
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3. In the Default link module box, type the default link module you want to 

use. 

4. Click OK. 

Creating default linkset pairings 
A module’s properties sheet shows the default linkset pairings for links 

from that module to other modules. To change the pairings you must have 

admin access to the folder or project that the module is in. 

To create or change the default linkset pairings: 
1. In the module window, click File > Module Properties. 

2. Click the Linksets tab. 

A list of all the default linkset pairings for links from the current module is 

displayed. 

3. To remove a pairing, select it then click Remove. 

4. To add a new pairing: 

a. Click Add. 

b. In the Target module box, type the name of the target for the pairing, 

or use Browse to locate it. You can enter a target module that does 

not exist in the database. The module is not created, but the pairing is 

valid when the module is created. 

c. In the Link module box, type the name of the link module that you 

want to be the default for links from the current module to the specified 

target module, or use Browse to locate it. You can enter a module that 

does not exist in the database. The module is not created, but the 

linkset is valid when the module is created. 

d. Click OK. 

If the linkset pairing already exists in the module, an error message is 

displayed. Click OK to return to the Add Linkset Pairing dialog and 

amend your settings. 

5. To edit a pairing: 

a. Select the entry you want to edit, then click Edit. 
b. Edit the entry in the Target module or Link module box. 
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c. Click OK. 
6. Click OK. 

Control on links for process management 
An important aspect of requirements management is the organization of 

relationships between the data. DOORS lets you control the type and direction 

of all links, created by all users. This feature helps to enforce and support your 

project process. 

With Linkset Control, you define which links between documents are allowed 

and prohibit any other combinations. Consequently, users and project managers 

can be assured that they create the correct types of link. 

You can also control where link information is stored for each source and target 

combination by specifying a default link module for that particular module 

pairing. 

For the greatest control, you can specify that use of this link module is 

mandatory, forcing all users to store link information there, regardless of 

whether they have defined their own default link module. If that degree of 

control is not needed, you can make the link module overridable, so users can 

store information about their links in their own default link modules. 

You must have administrative access to the parent folder of the source module 

to configure linkset definitions and enable linkset control. 

To create linkset definitions: 
1. Open your source module. 

2. Click File > Module Properties. 

The Module Properties dialog box is displayed. 

3. Click the Linksets tab. 

4. Click Add. 

The Linkset Pairing dialog box is displayed. 

5. In the Target module box, type the name of the target for the pairing, or 

use Browse to locate it. 

6. In the Link module box, type the name of the link module that you want 

to use, or click Browse to locate it. 



Centers for Medicare & Medicaid Services  
  

205  

7. (Optional) Select the Link Module options you wish to use for this linkset: 

• If you select Mandatory, link information for this linkset can only be 

stored in the specified link module. 

• If you select Overridable, a user’s personal default link module will be 

used to store information about their links. 

8. Click OK. 

To enable linkset control on a module: 
1. Open your source module. 

2. Click File > Properties. 

The Module Properties dialog box is displayed. 

3. Click the Linksets tab. 

4. Select the option Only allow outgoing links as specified in the above 
list. 

5. Click Apply, then OK. 

By default, linkset control is turned off. 

Outgoing links use only those linkset pairings in the list—no others are 

allowed. 

Showing link module information 
To show the properties of a link module: 

1. In the DOORS Explorer, make sure that link modules are being 

displayed.  

If necessary, click View > Show Link Modules. 

2. Select the link module whose properties you want to show, then right-

click Properties. 

3. The properties sheet for the module is displayed. 

The following table describes the options on the General tab. 

 
General tab  Description  

Name  The name of the module.  

Description  Additional information about the module.  
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General tab  Description  

Type  The type of item whose properties are being displayed. This is Link 
Module, and can’t be edited.  

URL  The URL of the module.  

List of 
attributes  

This is a list of all the module’s attributes. For each attribute, it  
shows the name of the attribute and its value.  

View/Edit  To change the value of an attribute:  
a. Select the attribute in the list of attributes, and then click Edit.  
b. Enter the new attribute value.  
c. Click OK.  

 

Creating a link module 
To create a link module: 

1. In the DOORS Explorer, select the folder or project you want to create 

the module in. This is the module’s parent. 

You must have create access to the parent. 

2. Click File > New > Link Module. 

3. In the Name box, type the name of the new module. 

The name can contain the following characters: 

• Alphanumeric characters (letters of the alphabet and numbers) 

• Space characters 

• Periods (.) 

• Underscores (_) 

• Hyphens (-) 

4. If you want to give the module a description, type it in the Description 
box. 

5. In the Mapping box, specify what kind of links you want to store in the 

link module. You cannot change the link mapping after the module has 

been created. 

The following table describes each mapping. 
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Mapping  Description  
Many-to-many  Each object can have any number of in-links 

and out-links.  
Many-to-one  Each object can have any number of out-

links, but only one in-link.  
One-to-many  Each object can have only one out-link, but 

any number of in-links.  
One-to-one  Each object can have only one out-link, and 

one in-link. So each object can be linked to 
only one other object.  

 
6. Click OK. 

Note If you receive the error Cannot create this Module: Lock 
request timed out when you try to create the module, wait a 

moment, then try again. This error is generated if another 

DOORS user is performing a paste operation when you click 

OK to create the module. 

Working with link modules 
By default, link modules are hidden in the DOORS Explorer. To show link 

modules, click View > Show Link Modules. 

To open a link module, double-click it in the DOORS Explorer. A screen 

similar to the following example is displayed: 

 
 

Use the Linkset drop-down list on the link module’s Linkset toolbar to 

select which linkset you want to display. The full name of the linkset that is 

currently selected is displayed when you roll over the list box. 
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By default, the linkset in Matrix mode is displayed. A matrix of all the 

objects in the source and target modules is displayed. The source objects 

are shown vertically on the left, and the target objects are shown 

horizontally along the top. 

A highlighted square on the matrix means there’s a link between the two 

objects that intersect at that position. 

If you select a highlighted square, you can use Go to link source   and 

Go to link target   on the Link toolbar to open the source or target 

module and go to the source or target object. 

Note  When you select a linkset in the link module, the source 

   module of the linkset is opened in exclusive edit mode, but is 

not displayed. If you then try to open that module in 

read-only mode from the DOORS explorer, it is displayed in 

exclusive edit mode. You can change to read-only mode by 

selecting Edit > Edit Mode > Read-Only in the formal 

module window. 
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To view linksets in Graphics mode, click View > Graphics Mode. 

 
Just as with Graphics mode in formal modules, objects are shown 

as boxes. Links are shown as red arrows connecting the source 

and target objects, with the current link highlighted as a black 

arrow. 

Use Turn Graphics mode on or off on the Graphics toolbar to 

switch between Graphics mode and Matrix mode. 

Creating a linkset 
When you create a link, DOORS automatically creates a linkset between 

the source and target modules, if it does not already exist. You can, 

however, create a new linkset yourself. 

To create a linkset: 
1. In the DOORS Explorer, make sure that link modules are being 

displayed. 

If necessary, click View > Show Link Modules. 

2. Select the link module you want to create the linkset in, then click 

File >Open > Exclusive Edit. 
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You must have create access to the link module. 

3. In the link module window, click File > New > Linkset 
4. In the Source module box, type the name of the source module, or 

use Browse to locate it. 

5. In the Target module box, type the name of the target module, or 

use Browse to locate it. 

6. Click OK. 

A linkset is created, which you can use for storing links from the 

specified source module to the specified target module. 

The linkset is opened in Matrix mode. 

Deleting a linkset 
Deleting a linkset deletes all the links and link attributes it contains. 

To delete a linkset you must have delete access to the link module, and for each 

link in the linkset, you need: 

• Modify access to the source object 

• Read access to the target object 
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To delete a linkset: 
1. In the link module window, open the linkset you want to delete, using the 

Show linkset drop-down list on the Linkset toolbar. 

2. Click File > Delete > Linkset. 
A message is displayed asking if you really want to delete the linkset. 

3. Click Yes. 
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Chapter  13  Traceability 
 

This chapter contains the following topics:  

• Understanding DOORS URLs 

• Understanding link analysis 

• Running a link analysis 

• Understanding traceability columns 

• Adding a traceability column 

• Using the traceability explorer 
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Understanding DOORS URLs 
The DOORS database, and each project, folder, module, module baseline and 

object in the database has a unique identifier, which is expressed as a URL, 

beginning doors:. The URL of each item is stored in its properties sheet, and can 

be copied from there. You can also right-click on any item and select Copy 
URL. 

For formal module objects only, you can use drag-and-drop to create external 

links to objects in other DOORS modules, or to copy the object URL to 

Microsoft Word. The object URL may also be copied to other applications using 

drag-and-drop, but the behavior is governed by the application to which you 

drag-and-drop, not by DOORS. 

For example, you can use drag-and-drop to insert a hyperlink to a DOORS 

object into a Microsoft Word document, or any application that supports 

HTML, and the hyperlink would look like this: 
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When you select the hyperlink the full URL is displayed. 

 

 
 

When you select the hyperlink the full URL is displayed. 

If you use drag-and-drop to copy a hyperlink into an application that doesn’t 

support HTML, for example Notepad or WordPad, the full URL is displayed. 

When you copy the URL of a module, baseline or object and the current view is 

not the Standard view, view information is copied with the URL. When the URL 

is followed, the module, baseline or object is displayed with the view that was 

selected when the URL was copied. 

 
Note  View information is not copied with the module URL if the 

URL is copied from the DOORS explorer. 

 

DOORS URLs can be inserted into a web page, stored as favorites or 

bookmarks in your browser, or simply pasted into other applications. You can 

also use DOORS URLs for linking objects in different DOORS databases, by 

inserting the DOORS URL as an external link. 

When DOORS is installed, the DOORS protocol scheme is registered with the 
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operating system. This means that any URLs beginning doors: are recognized 

by the operating system and opened by the default browser. The browser looks 

for the DOORS database that is referenced by the URL, and either starts a new 

client session for that database, or if a suitable session is already running, it will 

use that. 

Following a DOORS URL 
When you follow a DOORS URL, the URL handler identifies which 

DOORS database is referenced by the URL, and checks if a suitable 

session is running on the computer. A session running as one of the 

following is not a suitable session, and will not be used: 

• A DOORSnet session. 

• A DOORS interoperation server for DOORS XT 

• DOORS running in batch mode. 

• A pre-8.1 version of DOORS. 

• A session that has not been authenticated. If a DOORS session 

has been initiated, but you have not logged on, the browser 

ignores that session and starts a new one. 

• A session that is running against a database other than the one 

referenced by the URL. 

If the URL handler finds a suitable session, the item referenced by the 

URL is opened and displayed. If you don’t have access to the item that is 

referenced, an error message is displayed. 

If the URL handler does not find a suitable session, it initiates a DOORS 

client. The DOORS splash screen is displayed, followed by the DOORS 

Login dialog box. Once you have entered your DOORS username and 

password, the item 

referenced by the URL is opened. The following table describes what 

happens for the different types of items 
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Item 
Referenced by 
URL  

Description  

Database  The database is opened and the database icon is selected  

Project  The project is selected in the left pane of the DOORS Explorer 
window, and its contents are displayed in the right pane.  

Folder  The folder is selected in the left pane of the DOORS Explorer window, 
and its contents are displayed in the right pane.  

Module  The module is opened in the default edit mode. If view information has 
been copied with the module URL, and the user has read access to 
the view, that view is displayed. If view information has not been 
copied with the module URL, or the user does not have read access to 
the view specified by the URL, or the view specified by the URL has 
been deleted, the default view is displayed. If the module is already 
open and the URL specifies a view other than the current view, the 
behavior is dictated by the options that are set for the current user.  

Module 
Baseline  

The module baseline is opened. If view information has been copied 
with the baseline URL, and the user has read access to the view, that 
view is displayed. If view information has not been copied with the 
baseline URL, or the user does not have read access to the view 
specified by the URL, or the view specified by the URL has been 
deleted, the default view is displayed. If the baseline is already open 
and the URL specifies a view other than the current view, the behavior 
is dictated by the options that are set for the current user.  

Object  The module containing the object is opened in the default edit mode 
with the object selected.  
If view information has been copied with the object URL, and the user 
has read access to the view, that view is displayed.  
If view information has not been copied with the object URL, or the 
user does not have read access to the view specified by the URL, or 
the view specified by the URL has been deleted, the default view is 
displayed.  
If the module is already open and the URL specifies a view other than 
the current view, the behavior is dictated by the options that are set for 
the current user. For more information, see “Showing your user 
options,” on page 375.  
If the object is not visible in either the default view or the view specified 
by the URL, a message is displayed prompting the user to change to 
the Standard view.  

 



Centers for Medicare & Medicaid Services  
  

217  

 
Note  The DOORS splash screen, Login dialog box, database 

explorer and module windows display in the normal way. 

They are not displayed in the browser window. 

By default, you have 60 seconds from the time the DOORS Login dialog box is 

displayed to enter your username and password. If you do not log on within this 

ime limit, the URL expires. You can still log on after the time limit expires, but 

an error is displayed and the item referenced by the URL is not displayed. 
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Understanding Link Analysis  
Link analysis tells you about links to or from the current module. It is an 

analysis of normal DOORS links. External links are ignored during link 

analysis. You can choose whether to analyze in-links or out-links. 

• If you analyze in-links, information about the objects in the 

chain of links coming into the current module is displayed. 

Changes to these objects affect the current module. 

• If you analyze out-links, information about the objects in the 

chain of links going out from the current module is displayed. 

These are the objects that are affected if you make any 

changes to the current module. 

 
 

You can specify how far you want to travel down the chain of linked objects. 

This is the depth of the analysis. 

For example, if you run an analysis with a depth of 2, information about the 

objects that are linked to the objects in the current module is displayed, along 

with the objects that are linked to those objects. 

Running a link analysis 
This topic describes how to run a link analysis for the current object that: 

• Opens every module that contains a linked object 

• Applies a filter so that only the linked objects are displayed 
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For more information, see “Understanding link analysis,” on page 254. 

To run the link analysis: 
1. Select the object whose links you want to analyze. 

2. Click Analysis > Links. 

3. Use the Link direction radio buttons to specify whether you want to 

analyze in- or out-links. 

4. Use the Select link module radio buttons to specify whether you want to 

restrict the analysis to links that use a specific link module: 

• Click All modules if you don’t want to restrict the analysis. 

• If you want to restrict the analysis to links that use a particular link 

module, click Specific, then either type the name of the module 

(specify the path from its nearest ancestor project), or use Browse to 

locate it. 

5. In the Depth box, type the depth of analysis you want to use. 

The default of 1 limits the analysis to objects that are directly linked to 

the current object in either the current module or other modules. 

Greater levels of depth look at links that are 2 or more link jumps on from 

the current object. Again, these can be links in either the current module 

or other modules. 

If the depth is 0, the analysis only looks for links in the current module. 

6. Click OK to run the analysis. 

If a source or target object is in another module, and the module is not 

already open, it is opened in read only mode. The data in both modules is 

filtered to show only the linked objects. 

Note  If the source or target module is opened in read only mode, 

and you change to exclusive edit mode, the filter applied by 

the link analysis is removed, and the current module view is 

loaded. 

Understanding traceability columns 
A traceability column contains information about objects that are linked to or 

from objects in the current module. 
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This picture shows two traceability columns. They contain information 

about linked objects in the System Requirements and Tests modules. 

 
Traceability columns are layout DXL columns. The values displayed in 

them are calculated by a DXL program that runs an impact or traceability 

analysis and then displays information about the linked objects. 

By default traceability columns display the following information about 

each linked object: 

• The name of the module that the linked object is in 

• The value of its Object Heading attribute 

• Its object identifier 

You can display other information if you want. You can display other 

attribute values for the linked object, and you can display information 

about the attributes of the link itself, such as when the link was created. 

Note  If you archive a project that contains modules with 

traceability columns, and restore it to another database, the 
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traceability columns will not display any information. To 

display the traceability information in the restored project, 

you must add the traceability column again. The same is also 

true for partitions, when they are imported to another 

database. 

Adding a traceability column 
To add a traceability column to your current view: 
1. Click Analysis > Wizard. 

The wizard’s Welcome screen is displayed. 

2. Define the type of links you want to analyze. 

• Click In-links or Out-links in the Link direction frame. 

• Select the link types you want to analyze. These can be either 

DOORS links, External links or both. 

3. Click Next. 
If you have selected to include DOORS Links in the analysis, the 

Scope of analysis screen is displayed. If you are only analyzing external 

links, go to Step 7. 

4. Use the Select formal module radio buttons to select which formal 

modules you want to analyze: 

• Click All open modules to analyze linked objects in all formal 

modules that are currently open. 

• Click All modules to analyze linked objects in all formal modules, 

regardless of whether they are open or not. 

• To analyze linked objects in a specific formal module, click 

Specific, then either type the name of the module (specify the path 

from its nearest ancestor project), or use Browse to locate it. 

5. Use the Select link module radio buttons to specify whether you want 

to restrict the analysis to links that use a specific link module: 

• Click All modules if you don’t want to restrict the analysis. 
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• To restrict the analysis, click Specific, then either type the name of 

the link module (specify the path from its nearest ancestor project), 

or use Browse to locate it. 

6. Click Next. 
7. The information that is displayed on this screen depends on whether 

you are analyzing DOORS links, external links or both. If you have 

included DOORS links in your analysis, the Module and object 
attributes list and the DOORS link attributes list are available. If you 

have included external links, the External link attributes list is 

available. If you are only analyzing external links, got to Step 9. 

By default, the traceability columns display the following information for 

each object that is the source or target of a DOORS link: 

• The object heading. 

• The object identifier. 

• Module Name (including path for other folders). 

This option only displays the path to the module if it is in a different 

folder to the current module. 

If you want to display the path regardless of the module’s location, 

clear Module Name (including path for other folders) and 

Module Name (no path) and select Module Name (including 
path). 
If you do not want to display the path to the module, clear Module 
Name (including path for other folders) and Module Name 
(including path) and select Module Name (no path). 
If you want to display other items, select them in the list of Module 
and object attributes. Click an item to select it. Click it again to de-

select it.  

If you selected all formal modules or all open formal modules in 

Step, , the list only shows system attributes. 

8. By default, the traceability columns don’t display any attribute values 

for the links themselves. 
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If you want to display link attribute values, select the attributes in the 

list of Link attributes. Click an item to select it. Click it again to de-

select it. 

9. By default the traceability column displays the description of any 

external links. If you want to include information from other attributes in 

the traceability column, select the attributes from the External link 
attributes list. Click an item to select it. Click it again to de-select it. 

10. Click Next. 
11. In the Column width box, specify how wide you want each traceability 

column to be, in pixels. 

Note  Pixels are used to measure distances on computer 

screens. In the Control Panel, select Display, then the 

Settings tab to find out how big your screen is in pixels. 

12. Specify how the results of the analysis are to be displayed in the 

traceability columns: 

• By default, every attribute is displayed on a new line. 

Clear the One attribute per line check box if you want the 

attributes displayed in a continuous paragraph without line breaks 

between them. 

• By default, only attribute values are displayed in the columns, but 

not the names of the attributes. 

Select the Show attribute names check box if you want to see the 

names of the attributes as well as their values. 

• By default, OLE objects are not displayed in the columns. 

Select Include OLE objects in text if you want to see OLE objects. 

• If you want to truncate the value of each attribute that is displayed 

to a specified number of characters, select the Trim each datum to 
check box and type the number. 

• If you want to truncate the entire string that is displayed to a 

specified number of characters, select the Trim entire string to 
check box and type the number. 
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13. Specify whether you want recursive analysis. 

If you want analysis of more than one level, select the Recursive 
analysis check box. 

14. In the Depth of analysis box, specify the depth of the analysis. If you 

are only analyzing external links, only analyzing to one level, or want to 

display traceability information only from specified modules this check 

box is unavailable. 

15. Determine whether you only want to display information about links to 

and from specific modules. 

Select or clear the Display information only from selected modules 
check box. If you are only analyzing external links, only analyzing to 

one level, or have specified a number of levels in the Depth of 
analysis box, this check box is unavailable. 

If you select this check box, click Next to go to the next screen to 

specify the modules. For information on the next screen of the wizard, 

go to the next step. 

If you do not select this check box, click Finish to add the traceability 

column to your current view. By default, the first column displays 

information about objects that are one link hop from the current object, 

the second column displays information about objects that are two link 

hops from the current object, and so on. 

16. Specify the modules that you want to display link information about. 

Select a module in Module Name. The link information from or to this 

module will be displayed in the first traceability column. Select another 

module. The link information from or to this module will be displayed in 

the second traceability column, and so on until you have selected all 

the modules you want. For example, you assign the first column to 

Module A, the second column to module B, and so on. Column 1 

shows objects in Module A that are linked to the current module (the 

one you’re analyzing). Column 2 shows objects in Module B that are 

linked to objects in Module A. Column 3 shows objects in Module C 
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that are linked to objects in Module B, and so on. For each object in 

the module you’re analyzing, you can follow the chain of links through 

the various modules. You can see what objects in Module A it’s 

linked to, and what objects in Module B those objects are linked to, and 

so on. 

To specify a chain of modules: 
a. Select the module you want to display in column 1, then click 

Next. 
b. Select the module you want to display in column 2, then click 

Next. 
c. Repeat until you’ve finished building up the chain of modules. 

17. Click Finish to add the traceability column to your current view. 

Using the traceability explorer 
Use the traceability explorer to see which objects in your current module 

have 

links and to navigate to the linked objects. 

To use the traceability explorer: 
1. In the module window, click Analysis > Traceability Explorer. 
A flat list of all the objects in your current view is displayed. 

If an object has a link, it has a plus sign (+) to the left. In this example, 

three objects have links. 

2. By default, the Traceability Explorer shows objects that have in-links 

from modules that are open. 

To change the default, use the options on the View menu. 

 

View menu 
option  

Description  

In-links  Only shows in-links.  

Out-links  Only shows out-links.  
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View menu 
option  

Description  

Open Modules  Only shows links from or to modules that are 

currently open.  

All Modules  Shows links from or to modules that are 

closed as well as modules that are open.  

Refresh  Refreshes your screen.  

 

3. Click the plus sign (+) to show the linked objects. 

 
 

In this example, the selected object has links to 2 objects. 

• The arrow shows the direction of the links. 

• The status bar at the bottom on the screen shows the name of the 
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module that the currently selected object is in. 

4. To show the selected object, right-click Show Object. 
If it’s in a module that is not currently open, the module is opened read 

only 

with its current object set to the selected object. 

Navigating 
To navigate within the traceability explorer: 

• Use the Page Up, Page Down and arrow keys 

• Use the scroll bars 

• Use the HOME and END keys to move to the first or last object in 

the current view 
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Chapter  14  Suspect Links 
 
 

This chapter contains the following topics: 

• Understanding suspect links 

• Showing suspect links 

• Clearing suspect links 
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Understanding suspect links 
In a large database with multiple links, a change to one object may affect 

many other objects in the database. DOORS prevents such changes 

being overlooked by marking objects that are linked to objects that have 

changed as having a suspect link. Users can check modules for suspect 

links, identify the change that has caused the link to become suspect, and 

update the objects accordingly. 

 
Note The object that is changed is not marked as having a suspect 

link, but any objects that are linked to that object are marked 

as having a suspect link. 

 

For example, if a user requirement is linked to a system requirement a 

change to the user requirement may require a change to the linked system 

requirement. The system requirement is marked as having a suspect link. 

but the user requirement does not have a suspect link. When the system 

requirement has been checked and updated as required, the suspect link 

can be cleared from the system requirement. 

If changes are made to both the source object and target object of a link, 

then the link will be marked as suspect at both ends. If you clear the 

suspect link at the source it also clears the suspect link at the target. 

 
Caution  Only those attributes that have been set to affect change 

dates cause a link to be marked as suspect when they are 

edited. The Affect change dates setting can be selected 

by editing the attribute definition. 

 
Note  In version 8 of DOORS, date values are stored on the server 

in UTC (Universal Coordinated Time), and are displayed on 

the client according to the client time zone. In pre-8.0 

versions of DOORS, date attribute values did not include the 
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information to make time zone adjustments, so date attribute 

values in migrated data may not display as expected. For 

example, if clients in multiple time zones were working on 

data, suspect links may not operate as you would expect. For 

more information, see the section on understanding how 

dates and times are recorded in Managing DOORS, which is 

part of the DOORS documentation set. 

Showing suspect links 
Objects with suspect links can be identified by: 

• Filtering on suspect links 

• Displaying suspect link indicators 

• Displaying the last change 

• Displaying all suspect link information 

Filtering on suspect links 
You can apply a filter to your module so that only objects with suspect 

links are displayed. You can choose to filter on suspect in-links or suspect 

out-links, to all modules or to modules that are currently open. 

To filter on suspect links, select Analysis > Suspect Links > Filter, then 

the type of links that you want to filter on. You can choose from: 

• In-links (open modules only) 

• In-links (all modules) 

• Out-links (open modules only) 

• Out-links (all modules) 

If you select one of the open modules only options, ensure that the 

target modules you want the suspect link filter to apply to are open. 

Note This filter cannot be saved in a view. 

Displaying suspect link indicators 
You can insert a column to display link indicators, which flag objects that 

have suspect links. 
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A link arrow with a question mark is displayed beside objects with suspect 

links.  

This    indicates an incoming suspect link and this  indicates an 

outgoing suspect link. The link indicators column does not indicate the 

number of suspect links that an object has. 

 
 

To insert a column to display link indicators: 
1. Select Analysis > Suspect Links > Display Indicators, then the type 

of links you want to flag. You can choose from: 
• In-links (open modules only) 
• In-links (all modules) 
• Out-links (open modules only) 
• Out-links (all modules) 
Note  If you select one of the open modules only options, 

ensure that the target modules you want to see suspect 
link indicators for are open. 

Displaying the last change 
You can insert a column that displays a summary of the last change that made a 
link suspect, for each object with in-links or out-links, to open modules or to all 
modules. 
The following information is displayed in the column: 

• The absolute path to the module containing the source or target 
of the suspect link 
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• The object ID of the object that is linked to 
• The date and time that the object was last modified 
• If suspicion has never been cleared, that is stated 

 

 
 

To insert a column displaying the last change that made the link suspect: 
1. Select Analysis > Suspect Links > Display last change, then the 

type of links for which you want to see suspect link information. You 
can choose from: 

• In-links (open modules only) 
• In-links (all modules) 
• Out-links (open modules only) 
• Out-links (all modules) 
Note  If you select one of the open modules only options, 

ensure that the target modules you want to see suspect 
link information for are open. 

Displaying all suspect link information 
You can insert a column that displays all the suspect link information for each 
object with in-links or out-links, to open modules or to all modules. 
The following information is displayed in the column: 

• The absolute path to the module containing the source or target of 
the suspect link 
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• The Object ID of the source or target object 
• The number of changes that have been made to the object since 

suspicion was last cleared 
• The name of the attribute that has been modified, and the time that 

the modification was made 
There can be multiple suspect link entries for one object, as the following 
example shows: 

 
 

If the source or target module has been baselined since the last time suspect 
links 
were cleared, there may have been changes to the source or target object that 
make the link suspect, but that cannot be displayed. This is because suspect link 
information is based on the object history of the source or target object. If the 
module has been baselined, the history is cleared from the current module 
version and stored in the baseline. 
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To insert a column that will display all the suspect link information: 
1. Select Analysis > Suspect Links > Display all changes, then the 

type of links for which you want to see suspect link information. You 
can choose from: 
• In-links (open modules only) 
• In-links (all modules) 
• Out-links (open modules only) 
• Out-links (all modules) 

Note  If you select one of the open modules only options, 
ensure that the target modules you want to see suspect 
link information for are open. 

Clearing suspect links 
There are two ways to clear suspect links: Clear and Clear All. 

• Use Clear to clear individual suspect in-links or out-links from a 
single object in a module 

• Use Clear All to clear all suspect in-links or all suspect out-links or 
both from a module 

Caution  We recommend that you save all open modules before 
clearing suspect links. 

When you clear suspect links, it is the suspicion on the link that is cleared. This 
means that if there have been changes to both the source and target objects of a 
link, and you clear the suspect link at the source object, the suspicion is also 
cleared at the target. 

Access rights required for clearing suspect links 
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If you want to clear suspect links, you must have the following access rights: 
• The first time a suspect link is cleared, you must have Create 

access to the link module. This is because attributes are created in 
the link module to store suspect link information. 

• Anyone who subsequently clears suspect links that go through that 
link module must have Modify access to the link module. 

• You must have Modify access to both the source and target 
modules of the suspect link. 

Using the Clear function 
1. Select Analysis > Suspect Links > Clear in the module window. 

The Clear Suspect Links dialog box for the current object is displayed: 
Important: DOORS opens all modules in the database that contain 
objects 
that are linked to the current object. These modules will be opened without 
being displayed. If you do not have read access to either the module 
containing the linked object or the linked object itself, then DOORS will not 
calculate suspect links. 
The information is displayed over two tabs: one for incoming links and one 
for outgoing links. 
The information displayed includes the following: 

• The absolute path of the module containing the linked object 
• The source or target object’s identifier 
• The date and time of the last modification to the source or target 

object 
2. Click Next or Previous to display the suspect links of the next or previous 

object in the current view. 
3. To see more information about a suspect link, select it and click Details. 

 
The first change that caused the link to become suspect is displayed. Use 
the Next and Previous buttons to look through the changes that have 
been made to the linked object since suspicion was last cleared. 
 
Select View change as redlining to see the changes that have caused 
the link to be flagged as suspect with redline markup. 
 
If the source or target module has been baselined since the last time 
suspect links were cleared, there may have been changes to the source or 
target object that make the link suspect, but that cannot be displayed. This 
is because suspect link information is based on the object history of the 
source or target object. If the module has been baselined, the history is 
cleared from the current module version and stored in the baseline. 
 
In this instance, DOORS states that the source or target module has been 
baselined, and that the baseline may contain details of changes that make 
the link suspect. 

4. Click OK to return to the Suspect Links dialog box for the current object. 
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5. Selecting a single entry or multiple entries activates the Clear option. 
6. Click Clear to clear the suspect links. 

DOORS performs an access control check to ensure that you have the 
necessary access to all formal and link modules required for update. 
If you do not have the necessary access, an error message is displayed, 
or the Clear button is unavailable.  

7. Click Close. 
When you click Close, modules open for edit, which were opened for edit 
previously, are left unsaved. 
An information message is displayed. 

 
8. You must save any open modules. 

Using the clear all function 
The Clear All suspect links option lets you clear all suspect incoming 
links, all suspect outgoing links, or both. If you have the module open in 
shareable edit mode, you can only clear suspect links in locked sections. 

To clear all suspect links: 
1. In the module window, click Analysis > Suspect Links > Clear All. 

The Clear All Suspect Links dialog box is displayed. 
2. Select Clear Suspect In-links, Clear Suspect Out-links, or both. 
3. Click OK. 

All suspect links will be cleared. 
An information message is displayed. 
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Chapter  15  History 

This chapter contains the following topics: 

 

• Understanding change bars 

• Showing module history 

• Understanding redlining 
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Understanding change bars 
Change bars let you track the changes to objects. 
The color of an object’s change bar, a symbol and a tool-tip tell you the status of 
an object. 
 

 
Change bar Example tool-tip Description  

 New Object 
You’ve created the object during the current 
session and have not yet saved the changes. 

 Unsaved changes 
You’ve edited the object during the current 
session and have not yet saved the changes.  

 
Last modified by Bill 
Young on 05/13/08 

16:16:48 

The object has been changed since the 
module was last baselined, and the changes 
have been saved.  

 Baselined 
The object has not been changed since the 
module was last baselined.  

 Deleted 
Either the object was deleted before the 
module was last baselined or history has not 
been loaded.  

 Deleted by Bill Young 
on 05/13/08 16:16:48 

The object was deleted after the module was 
last baselined and history has been loaded.  

 

You can control whether the symbol is displayed in the change bar by selecting 
or clearing the Show symbols in change bars check box on the Settings tab of 
the Options dialog box (Tools > Options...). 
 
Note The New Object symbol is always displayed, even if the 

Show symbols in change bars check box is cleared. 
 
In the following example, the Power car heading has the red Unsaved Changes 
change bar at the left, showing that it has been edited during the current session, 
but the changes have not yet been saved. 
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All the other objects have yellow change bars, which means they have been 
edited since the module was last baselined. 
 
Double-click an object’s change bar to show the history of changes for the 
object. 
Note You can control what edits are associated with change bars. 

If you don’t want to know when users edit a particular 
attribute, you can change the attribute’s definition to turn 
change bars off for that attribute. 

Showing module history 
You can control what changes to objects are recorded in the history. If you don’t 
want to know when users edit a particular attribute, you can change the 
attribute’s definition to turn history off for that object. You can choose whether 
to record the creation and deletion of links in the module history. By default, link 
history is generated. If you don’t want to generate link history, clear Create link 
history on the General tab of module properties. 
 
You can filter the history by username or date, and you can export the history to 
a text file, so you can print it or insert it in other files. 
For more information, see the section on understanding how dates and times are 
recorded in Managing DOORS, which is part of the DOORS documentation 
set. 
To show the history of a module: 

1. In the module window, click File > Module Properties. 
2. Click the History tab 
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The following table describes the options on the History tab. 
 

History tab Description  

View 
change as 
redlining 

Select this check box to show the details of the change as redlined text. 
The example above shows the details of the history record with redlining 
turned on. Deletions are 
shown as red text with strikethrough, and insertions as blue text with 
underlining. 

All This shows module and object history. 
The object history tells you about all the objects that have been created, 
deleted or edited since the module’s most recent baseline. 
If Create link history is selected, information about links that have been 
created or deleted since the module’s most 
recent baseline is displayed. 

Note You can also see an object’s history by 
double-clicking its change bar. 

Module This is the default. It shows the module history. 
Information about all the changes to module attributes is displayed, 
along with the attribute definitions and types that have been created, 
deleted or edited since the module’s most recent baseline. 
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History tab Description  

Sessions Select this box to show the module session history, then click Refresh. 
The following information about everyone who has opened the module 
since the module was created is displayed: 
• The person’s DOORS username. 
• A unique session identifier. 
• When they opened the module. 
• If they created a baseline, the name of the baseline. 

Dates If you only want to see history information after a particular date or 
within a range of dates: 
a. Select the Dates check box. 
b. Type the appropriate dates in the From and To boxes, or select them 
from the drop down calendars. 
c. Click Refresh. 

User If you only want to see history information for 
a. Select the User check box. 
b. Type the username. 
c. Click Refresh. 

a particular user: 

Details Shows full information about the selected history item. 
The information is displayed in a separate window. Select the View 
change as redlining check box to display changes as redlined text. 
If the selected history item is a link creation or deletion, you must have 
read access to the associated link module and target module to view the 
history details. 

Refresh Updates the screen to show the history associated with 
whichever Show history boxes are selected. 

Export To save the history information in a file: 
a. Click Export. 
b. Enter or select the file you want to save the 
information in. 
c. Clear the Include details check box if you don’t 
want full details of each history record. 
d. Click OK. 
The complete module and object history are exported, 
regardless of the display settings. 
 

Understanding redlining 
Some changes in DOORS can be viewed with redline markup. This makes it 
easy to see at a glance the changes that have been made to an attribute. 
Redline markup is available in: 

• Module and object history 
• The spelling checker 
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• The change proposal system 
• The Module Comparison Wizard 
• Details of suspect links 
The comparison that generates the redline markup in DOORS is made on 
a word by word basis between two static pieces of text using a longest 
common subsequence algorithm. DOORS does not save information 
about individual keystrokes, so the redline markup may not reflect the 
sequence of changes performed by the user. 
As the comparison is word by word, the redline markup may differ from 
what you might expect. For example, if DOORS is comparing ship wreck 
to shipwreck, the redline markup will show ship as deleted, wreck as 
deleted and shipwreck as inserted. 
DOORS uses word level analysis rather than character level analysis for 
performance reasons. 
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Chapter  16  Baselines 
 
 

This chapter contains the following topics: 

• Understanding baselines 
• Viewing a baseline 
• Creating a baseline 
• Copying a baseline 
• Baseline compare 
• Deleting a baseline 
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Understanding baselines 
A baseline is a read-only version of a module. It captures a moment in time and 
preserves it until you delete the module. 
 
When you create a baseline of a module, you create a copy of the module, which 
no-one can edit. 
 
The baseline includes the history of the module: 

• Information about all the attribute definitions and types that have been 
created, deleted or edited since the module’s most recent baseline. 

• Information about all the objects that have been created, deleted or 
edited since the module’s most recent baseline. 

• Information about every module session (every time the module has 
been opened) since it was first created. 

You can view baselines. You can also create a new module by copying a 
baseline. The new module contains all the same data as the baseline, but 
doesn’t have any of the history information.  

Using baselines to improve performance 
DOORS stores the history information for each module in a separate file in the 
database. The history files can get very big, because they can contain a lot of 
information about the changes made to the modules. 
 
When you edit a module, DOORS opens its history file. The bigger the history 
file, the longer it takes to open it. 
To improve performance, regularly create baselines of your modules. Creating a 
baseline creates a new file that contains the baseline, together with all the history 
information, and erases the contents of the module’s history file. You can still 
access the history information; it’s just stored in a different file which is not 
opened when you edit the module. 

Viewing a baseline 
To view a baseline: 

1. In the module window, click File > Baseline > View. 
2. Select the baseline you want to view, then click Open. 

 
If the baseline is part of a baseline set, the baseline set to which it belongs is 
displayed in the Baseline Set box. To see more information about the 
baseline set, click View. 
 
If the baseline has been deleted, the Open and Signatures buttons are 
unavailable. The username of the user who deleted the baseline, and the date 
the baseline was deleted are displayed alongside the baseline. 
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Creating a baseline 
To create a baseline, you must have modify access to the module. You can only 
create a baseline of a formal module. 
To create a baseline: 

1. Make sure you are in exclusive edit mode. 
 

The edit mode is shown on the status bar at the bottom of the module 
window. To change your edit mode, click Edit > Edit Mode > Exclusive 
Edit. 

2. Click File > Baseline > New. 
3. Check that None is selected in the Baseline Set list. 
4. Use the Version radio buttons to select the version number of the new 

baseline. 
5. If you want the new baseline to have a suffix as well as a version number, 

type it in the Suffix box. 
6. If you want to give the baseline a description, type it in the Description 

box. 
7. Click OK. 

The module is automatically closed and then opened again. 

Copying a baseline 
When you copy a baseline, you create a new module. You can either: 

• Copy all the information in the baseline. 
The new module contains exactly the same data as the baseline, 
except that it has no history information and no links. 

• Copy only the objects that have headings. 
 

This lets you create a new module that has the same structure as the 
original module. The baseline is used as a template for the new module. 

The new module is created in the same folder or project as the original module. 
You must have create access to this folder or project. 
 
To copy a baseline: 

1. In the module window, click File > Baseline > Copy. 
2. Select the baseline you want to copy. 

Note You cannot copy baselines that have been deleted. 
3. In the Copy to new formal module box, type the name you want to give 

the new module. 
 

The name is case-sensitive. For example, the names Mymodule and 
MyMODULE are different. 

 
The name must be unique within the parent project or folder. All the 
projects, folders and modules in the parent must have different names. 
The name can contain the following characters: 
• Alphanumeric characters (letters of the alphabet and numbers) 
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• Space characters 
• Periods (.) 
• Underscores (_) 
• Hyphens (-) 

4. If you want to give the new module a description, type it in the 
Description box. 

5. By default, the new module’s object identifiers start at 1 and have no 
prefix. 
If you want to override the default, use the Start at and Prefix boxes. 

6. Use the Include radio buttons to specify what you want to copy: 
• Click All information to copy everything. 
• Click Headings only to copy only objects that have headings and only 

the Object Heading text for those object. 
7. Click OK. 

 
The new module is created. It inherits its access rights from its parent folder or 
project. 

Baseline compare 
DOORS records changes to data and stores complete baselines without using 
third-party tools. DOORS offers an additional feature: baseline compare. This 
provides a list of the differences between any two baselines of the same module, 
recording: 

• Any objects that have been modified 
• Any objects that have been added or deleted 

To use Baseline compare: 
1. Select File > Baseline > Compare. 

The Baseline Compare window is displayed: 

2. Select the baselines for comparison. The screenshot above shows that 
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baseline 2.2 is being compared with current. 
 

Note  DOORS treats the version in the left pane as the older of 
the two that are being compared. so when you perform a 
baseline compare, make sure you select the older baseline 
in the left pane. If you select a more recent version in the 
left pane, DOORS will report additions to the module as 
deletions and vice versa. For example, if you baseline a 
module, then add some text to an object, then do a 
baseline compare, selecting the current version in the left 
pane, DOORS reports the text you added as being 
deleted. This is because the version selected in the left 
pane (as far as DOORS is concerned, the earlier 
version), contains text that does not exist in the version 
selected in the right pane. DOORS therefore reports this 
text as being deleted. 
 

3. Select the Show Baselines option if you want the baseline you selected 
to be opened. A filter is applied to both versions of the module so that only 
objects that have changed since the last baseline are displayed. 

4. Click Compare. 
DOORS tells you to how many differences there are between the 
baselines. 

5. Click OK. 

The Baseline Comparison Results dialog box is displayed with the Plain 
View tab selected. 

 
Select the Redlining View tab if you want to see the changes as redlined 
text. deletions are shown as red text with strikethrough, and insertions as blue 
text with underline. 

 
If you selected the Show Baseline option in Step 2, the baseline is opened 
and objects that have changed are displayed. 
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Chapter  17  Printing & Reports 
 

This chapter contains the following topics: 
• Using print preview 
• Printing 
• Applying saved page setups 
• Creating page setups 
• Creating a report 
• Printing and Managing reports 
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Using print preview 
Use print preview to see what you’re about to print, before you actually print it. 
If you like what is displayed, you can print directly from the Print Preview 
window. 
To use print preview: 

1. Open the module and set up the view you want to print. 
The main column is always printed, even if it is not displayed in the view. If 
the main column is not displayed in the view, no table of contents is 
created or printed. 

2. Click File > Print Preview. 
3. In the Printer box, select the printer you want to use. 
4. Use the Preview range radio buttons to select the pages you want to 

preview: 
• Click Selected objects to preview the objects that are currently 

selected in the module. If an object in a table is selected, the whole 
table is previewed. 

• Click All if you want to preview all the data in the current view. 
• Click Current if you want to preview the page that contains the 

current object. 
If your current page setup includes a title and/or contents page, the 
title and/or contents pages are included with the current page. 

• Click Range if you want to preview a range of pages, and then 
type the start and end page numbers in the from and to boxes. 

If your current page setup includes a title and/or contents page, the 
title and/or contents pages are included with the page range you 
select here. 

5. Click Preview. 
 

The Print preview window is displayed. 
It shows what the selected pages would look like if you printed them. It 
assumes that you’ll use your current page setup. 
You can scroll through the printed pages using PAGE UP, PAGE DOWN, 
and the ARROW keys. 
 
If your current view is too wide to fit on the printed page: 

• The data for each object spans two or more printed pages. 
• The page number of each printed page has a letter of the alphabet 

added to the end of it. For example, if page five spans three pages, 
they are numbered 5A, 5B, and 5C. 

6. After the Starting printed page number, “of n” is displayed, where n is 
the total number of module pages you selected in Step 4. A module page 
means what you would get on a single printed page if the printed page 
was infinitely wide. 

7. To zoom in or out, use the Scale drop-down list. This only affects what is 
displayed in the Print Preview window. It doesn’t affect the printed pages. 
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8. To display each module page on a separate row, select the Use vertical 
page breaks check box. 

 
This makes each new module page start on a new row in the Print 
Preview window. Page 1A is displayed above page 2A, and so on. You 
can see at a glance how many printed pages you’ll get for each module 
page. 

9. To print the pages, click Print. 
The standard Print window is displayed, allowing you to specify which 
printer you want to use, what pages you want to print, and so on. Use the 
Print window’s context sensitive help for more information. 

Printing 
To print a module: 

• In the module window, click File > Print. 
 

A standard Print window is displayed that lets you specify which 
printer you want to use, what pages you want to print, and so on. 
 
Note You can also print from the Print Preview window and 

the Report Manager. 

Applying saved page setups 
You can control the appearance of modules when they are printed by using page 
setups. DOORS provides one predefined page setup, the Standard layout, 
which is used by default when you print a module. If you or any other user has 
created and saved a page setup, it is available to all DOORS users from the 
Page setup dialog in any formal module. 
 
To apply a saved page setup to your module: 

1. In the module window, click File > Page Setup. 
A list of page setups is displayed in the left pane of the Page setup dialog 
box. 

2. Select the page setup you want to use. 
 

You can view the settings associated with that setup by looking at the tabs 
on the right of the dialog box. If you want to print the module using these 
settings, click OK. 
 
If none of the available page setups is suitable, you can base a new page 
setup on an existing one. Select the page setup that is most like the one 
you want to create, and edit it.  

Creating page setups 
To create or edit a page setup: 
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1. In a module window, click File > Page Setup. 
2. On the left, a list is displayed of all the saved page setups for the 

database, and on the right, a series of tabs that can be used to define the 
layout of the module when it is printed. To see the settings associated with 
a saved page setup, select it in the left pane, and use the tabs to view the 
settings. 

Note  If you have not edited the settings on the page setup 
dialog, the module is printed using the Standard layout, 
which is provided with DOORS. If no one has created 
and saved a page setup, the only setup listed in the left 
pane is Standard layout. 

3. Select the page setup that is most like the one you want to create. You 
can change it to suit your needs. 

4. Use the Format tab to specify whether you want to print the module in 
Table format or Book format. The options that are available on this tab 
depends on which format you select. 

 

Format Selected  Appearance When Printed Options Available for This format 

Table 
 

Includes all the columns that 
are displayed in the current 
view, and looks the same as 
the module does on screen. 
The main column is always 
printed, even if it is not 
displayed in the view. 
 

Cells 
You can select whether the 
table cells have borders, 
shading or are not marked. 
Column titles 
You can select whether 
column titles display on every 
page or only on the first page. 
 

Book 
 

Each object’s Object 
Heading and/or Object 
Text is printed on a new line, 
followed by the attribute 
values held in any other 
displayed columns. For each 
displayed column, the column 
title is printed along with the 
value for that object. 
 

You can choose whether to 
include or omit attributes with 
null values from your print 
out. If you include attributes 
with null values, each object 
that is printed will have a list 
of the displayed columns 
under it, even if the object has 
no values in any of those 
columns. If you omit 
attributes with null values, 
only columns that contain an 
attribute value for the object 
will be printed. 
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5. Use the Layout tab to specify the layout you want. 
 
 

Select this Check 
Box 

To 

Include title page 
 

Print a title (front) page. By default, the following 
information is printed on the title page: 
• The path to the module from the parent project 
• The module name 
• The module version 
• The name of the user who prints it 
• The date the module is printed 
 

Include filter 
criteria on title page 
 

Include on the title page details of the filter criteria that 
are applied to the module. If the module is not filtered 
then No filter applied is printed on the title page. 
 

Include sort criteria 
on title page. 
 

Include on the title page details of the sort criteria that are 
applied to the module. If the module is not sorted, then 
No sort applied is printed on the title page. 
 

Include signature 
information 
 

Insert after the title page a page containing all the 
signature information for the module. This check box 
only applies if the module is configured to use electronic 
signatures on baselines. 
 

Include contents up 
to level 
 

Include a contents page when the module is printed. The 
heading levels that are displayed in the contents page are 
defined using the drop-down list to the right of the box. 
For example, select 2 to print level 1 and 2 headings in the 
contents page. 
If the main column is not displayed in the view that you 
are printing, no table of contents is created or printed. 
 

Insert page breaks 
up to level 
 

Insert page breaks when the module is printed. Use the 
dropdown list to define what heading level will trigger a 
page break. For example, select 2 to start a new page for 
every level 1 heading and every level 2 heading. 
 

Show change bars 
 

Print change bars. 
 

 
 

6. Use the Paper Size tab to define the paper size and page orientation. The 
dimensions are measured in either inches or millimeters, depending on 
your current user options settings. To change the settings, click Tools > 
Options in the DOORS Explorer, then edit the Settings tab. 
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Field Description 

Paper Size Select the paper size you want to use. 
If you select Custom, type the page width and height in the Width and 
Height boxes. 

Width The width of the printed page. This field is greyed unless the paper 
size is Custom. 

Height The height of the printed page. This field is greyed unless the paper 
size is Custom. 

Portrait Select if you want the page orientation to be portrait. 

Landscape  Select if you want the page orientation to be landscape. 

 
7. Use the Margins tab to define the page margins. The values are 

measured in either inches or millimeters, depending on your current user 
options settings. To change the settings, in the DOORS Explorer, click 
Tools > Options, then edit the Settings tab. 

Field Description 

Top Enter the distance you want between the top of the page and the top of 
the first line on the page. 

Bottom Enter the distance you want between the bottom of the page and the 
bottom of the last line on the page. 

Left Enter the distance you want between the left edge of the page and the 
left margin 

Right Enter the distance you want between the right edge of the page and 
the right margin . 

 
8. Use the Headers tab to define headers for the title page, the contents 

pages, and the body pages. The body pages are the pages that contain 
the module content. 

You can either type the text that you want to be displayed in page headers 
directly into the appropriate box (Left, Middle or Right), or use rich text 
codes. Rich text codes automatically generate their associated value at print 
time. For example, use &N to include the page number: 

 

 
Code Generates  

&N Page Number. Title pages are not numbered. Contents pages use 
roman numerals. 

&C Total number of pages (for body pages only) 

&M Module Name 
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Code Generates  

&P Project Name. 
 

&I Database Name 

&L Module location from the parent project. 

&V Module Version 
If it is a baseline, then Baseline is printed along with the version 
number. If it is the current version, then Version is printed along with 
the version number. 

&U Session username  

&D Session date 

&T  Time of printing 

&A DOORS product name 

&B DOORS product version 
 

You can combine text and codes. Enter Page &N of &C to print Page 1 of 
15, for example.  

You can apply rich text formatting to header text. Select the text or rich 
text codes, then right-click and select the rich text format you want to 
apply. 

9. Use the Footers tab to define footers for the title page, the contents 
pages, and the body pages. The body pages are the pages that contain 
the module content. 

You can either type the text that you want to be displayed in page footers 
directly into the appropriate box (Left, Middle or Right), or use rich text 
codes. Rich text codes automatically generate their associated value at 
print time. For example, use &N to include the page number: 
 

 

 

 

Code Generates  

&N Page Number. Title pages are not numbered. Contents pages use 
roman numerals. 

&C Total number of pages (for body pages only) 

&M Module Name 

&P Project Name. 
 

&I Database Name 

&L Module location from the parent project. 
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Code Generates  

&V Module Version 
If it is a baseline, then Baseline is printed along with the version 
number. If it is the current version, then Version is printed along with 
the version number. 

&U Session username  

&D Session date 

&T  Time of printing 

&A DOORS product name 

&B DOORS product version 

 

 

You can combine text and codes. Enter Page &N of &C to print Page 1 of 
1, for example. 

 
Rich text formatting can be applied to footer text. Select the text or rich 
text codes, then right-click and select the rich text format you want to 
apply. 
 

10. If you want to use this page setup again, or if you want to make it available 
to other users, you can save it. 
To save your page setup: 
a. Click the Save as button on the left side of the dialog box. 
b. Give your new page setup a name. 
c. Click OK. 

 
The page setup is saved, and can be used by you or any other DOORS 
user on any module in the database. 
 

11. If you do not want to save the page setup, click OK. Your settings are 
applied to the module, and persist in the current DOORS session. They 
are not available to other modules, and are lost if you select a previously 
saved page setup. 

Creating a report 
Reports are useful if you regularly print a module using the same view and 
page setup. When you create a report what you are actually doing is 
associating a selected view and page setup with the module for printing 
purposes. You can then print the module at any time from the DOORS 
explorer using these settings, without having to navigate to and open the 
module. 
 
You use a wizard to create the report. You can select the view and page 
setup, give the report a name, and save it. 
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To create a report: 
1. Open the module you want to create the report for. 
2. Click Tools > Wizards > Report. 
 
The wizard Welcome screen is displayed. 
 
3. Click Next. 
4. Select the view you want to show in the report, then click Next. 
5. Select the page setup you want to use in the report, then click Next. 
6. In the Name box, type the name you want to give the report. This name is 

only used by the Report Manager to identify the report. It isn’t shown in the 
report itself. 
 
The report name mustn’t exceed 80 characters. 

 
7. If you want to give the report a description, type it in the Description box. 

Again, this description is only used by the Report Manager. It isn’t shown 
in the report itself. 

8. Click Next. 
9. Click Finish 
10. Click OK 
 

 

Printing and Managing reports 
Once you have saved a report, it is accessed using the DOORS explorer, not the 
module. A report is not a copy of a module at a particular point in time which 
can be printed later. It is an association between a module, a page setup and a 
view. When you print or view a report the module is opened read only, with the 
view that you selected when creating the report displayed, and the page setup 
you selected applied. 
 
To print, view or delete a report: 
 

1. In the DOORS Explorer, select the project that contains the module whose 
report you want to print, view or delete. 

2. Click Tools > Manage Reports. 
 

A list of all the modules that have reports associated with them is 
displayed. Indented below each module is a list of its reports. 
 

3. Select the report, then either: 
1. Click Print to print it. This opens the module and loads the view 

associated with the report, then displays the standard Print 
window. Use the Print window to specify which printer you want to 
use, what pages you want to print, and so on. 
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2. Click View to open the module and load the view associated with it. 
3. Click Delete to delete the report. 

4. When you are finished, click Close. 
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Chapter  18  Importing 
 

This chapter contains the following topics: 
 
• How to Create a Word document for easy export to DOORS 
• Exporting from Microsoft Word 
• Importing RTF files 
• Importing spreadsheet files 
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How to Create a Word document for easy export to DOORS 

Introduction 
In many cases, users have significant legacy information held in word 
processors or other formats. Many such formats can be exported from Word or 
imported into modules with great success. However, as in all such cases, a little 
thought and preparation can make the job significantly easier. This section  
presents some ideas on what you can do. 
 
This section provides recommendations for writing requirements and tips to 
ease the export of them into DOORS. Proper structuring of requirements 
is the first step to writing useful requirements documents. DOORS is only 
a tool and therefore if you have not structured your requirements correctly 
then the data within DOORS will not be of much use. Once you have your 
requirements structured correctly, the next step is to get them into 
DOORS. Several tips are outlined that will make the exporting of 
your Word documents time efficient.  
 
Many of the issues arise from the fact that Word uses an essentially 
unstructured format, with some structuring hints allowed. DOORS, on the 
other hand, is a strictly structured tool. Therefore, once you have 
information in DOORS, it is easy to manage and safe. 
 
Taking note of the pointers in this document will considerably enhance 
your ability to use Word documents as source material. 

Writing Good Requirements 
When writing requirements the author should follow the guidelines in 
Requirements Writer’s Guide Version 3.1 
Amongst the most important rules to follow 
are: 
• A requirement shall contain one requirement. 
• A requirement shall not contain ambiguous phrases like "and/or, 

etc.". 
• A requirement shall be verifiable. 
 

Basic Use of Word 
You can, as many people do, write requirements outside of the DOORS 
environment using Word. DOORS can import RTF files or the files can be 
exported from Word but you should follow a few rules to ensure the import or 
export of material is smooth and efficient. 
 
While DOORS can handle most information exported from Word with 
ease, if you follow these simple tips your task will be much easier. In fact, 
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most of these are basic good sense for writing documents, regardless of 
the tool used. The first recommendations are: 
 

1. LEARN Word. 
2. UNDERSTAND the document structure, whether it is a document 

that you have received or one that you are producing 
3. STRUCTURE the document appropriately 
 

Detailed knowledge of Word is not necessary, but it is worth 
understanding its basic controls, particularly relating to styles and 
structure. For you or anybody else to be able to work with information in 
DOORS, it needs to be structured. This means that you must first 
understand the structure (explicit and implicit) of the document you are 
creating and second use appropriate tools and formatting in Word to 
manage that structure. Most of what follows is an expansion of these two 
tips. 
 

Word to DOORS Mapping 
The Word to DOORS exporter takes each paragraph from the Word 
document in turn and exports it to DOORS. Empty paragraphs are 
ignored. The exporter decides whether to export the paragraph as Object 
Text or Object Heading based on whether the paragraph has an “Outline 
Level” associated with it. 
 

Styles and Structure 
Many issues found on exporting documents from Word to DOORS arise 
because of poor use of Word’s style mechanisms. This section describes 
what you can do to avoid the most common problems. 
 

Reviewing the Structure 
Section headings shall be formatted using Word’s heading feature to 
identify at what level the section is. DOORS actually uses Word’s “level” 
property to decide at which level to place a paragraph. Generally (and by 
default), this is associated only with Headings, with the level number 
matching the heading level. 
 
The default template (“normal.dot”) in Word has Outline Levels on the 
styles “Heading 1”, “Heading 2”, etc., and no Outline Level on “Normal” 
or other “body” styles. Word allows you to set the “Outline level” 
explicitly on other styles or on individual paragraphs, but we strongly 
recommend that you should only use this for headings. Note that this 
setting is distinct from the “Outline Numbering” option on paragraphs and 
styles. 
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For example, Figure 1 shows an extract from a document exported to 
DOORS where the original used Heading 1 for "Introduction", "Writing 
Good Requirements” and “Using Word to Write Requirements Outside of 
DOORS" headings. This document also used Heading 2 for “Using Word 
to Write Requirements Outside of DOORS. 

 

 

 

 

1.0 Introduction  

2.0 Writing Good Requirements  

3.0 Using Word to Write Requirements Outside of DOORS  

3.1 Create with Style  

3.1.1 Using Headings Style  

Figure 1: Sample DOORS Heading Structures 

 
DOORS automatically and dynamically assigns section numbers as you 
add more items or move items around. Do not be too concerned with what 
number the section is. 
Before finally exporting from Word to DOORS, we recommend that you 
review the document’s structure. 

4. USE Word’s Outline mode to check if you have gaps in levels, 
character formatting used instead of styles, etc. 

5. USE Word’s “Style area” (Tools ı Options ı View ı Style area 
width), available in Normal and Outline modes to see what style is 
applied to each paragraph. 

 

 

Paragraph Styles 
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Figure 3: Style Selector Tool in Word 

 
6. ALWAYS use Word paragraph styles rather than text formatting to change 

the appearance of a paragraph. There are two reasons for this. First, 
paragraph styles are (optionally) preserved in DOORS; 
character styles are not (though the formatting is to some extent). 
Second, as described above, the Word-to-DOORS exporter uses the 
“Outline Level” feature of Word paragraph styles to determine the 
hierarchical structure of the document in DOORS. 

 
Note: that versions of Word before Word 97 only allowed one style 

per heading level. Old documents may still have this restriction, as 
may documents based on old templates. One implication of this is 
that you will often find styles that are similar to, for example, Level 
1 but are actually Level 7. A typical case is where Appendix 
headings look like Level 1 Section headings. If you export this to 
DOORS, you will find a set of low-level headings at the very end 
of the document. This is simple to correct, but still confusing when 
you first encounter it. 

7. NEVER skip heading levels in Word. The Word-to-DOORS 
exporter will create empty headings to fill in the gaps. 

8. DO NOT proliferate styles in Word. They should be chosen for 
their logical meaning — the appearance should support the 
meaning. 

9. DO NOT use heading styles to number text paragraphs (see below 
for more on numbering). The Word to DOORS exporter places 
Word headings in DOORS Object Heading attributes, whereas text 
paragraphs should be in Object Text attributes. If a paragraph with 
an Outline Level is very long (around 460 characters or more, 
depending on formatting), it will be exported truncated to the 
Object Heading and in full to the Object Text of the same object. 
This is because of the limitation on the length of String attributes. It 
is the only case where the Word to DOORS exporter places entries 
in both attributes. 

No Double Line Breaks 
Line breaks are acceptable between lines and sections but avoid double 
line breaks. Addition line breaks can cause DOORS to insert blank objects 
and throw off the structure if they are styled as headings but are not. 
Figure 4 shows how DOORS will import a double line break with a 
heading style. 
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Figure 4: Double Line Break Import Error 

One Requirement per Line 
Break out each requirement into a single line with a line break after it, like 
all the "shall" lines in this document. You can group "window dressing" 
text, such as this paragraph together. If a line has a "shall" in it then it is 
probably a requirement. It looks awkward in the Word document but it 
helps to make sure each requirement has its own object ID and can be 
tracked individually. 

10. Each requirement shall be on an individual line with a line break 
after the sentence. 

Numbering and Bullets 
Bullets generated as part of a style, when exported to DOORS, will be 
recreated in DOORS. Numbered lists, as part of a style, will be lost when 
exported to DOORS. They can be re-created on export from DOORS to 
Word using the paragraph style. Note that DOORS can only pick up a 
paragraph style if there is text in the paragraph. You probably know that 
blank paragraphs are not exported from Word, but did you realise that this 
also applies to empty paragraphs that display a number (or other 
information) as part of their style definition. 

11. DO NOT use the approach of numbering in Word using a table 
with empty cells in the first column with a numbered style; this 
cannot be exported to DOORS. 
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Figure 5: Example of Bulleted and Numbered Lists 

Front and Back Matter 
Title Pages, Tables of Contents and Indexes, etc., are not usually captured 
in DOORS, being material that can be re-generated on export in to Word 
using tools like DocExpress. They can be removed before or after import 
into DOORS. 

12. TO KEEP them in DOORS, place them under a Text object – that 
way they do not interfere with the numbering in the document. This 
does violate our normal guideline not to place objects as children of 
text objects, but with justification. 

Indented Paragraphs 
Word allows you to indent paragraphs in several ways. You can use the 
ruler, Tab key or paragraph style. 

13. DO NOT use the ruler to indent. Ruler indents are not transferred 
to DOORS. For preference, define a Word style. If it is important 
that the appearance of the indent is preserved in DOORS, use a 
Tab. But be aware that indenting using Tab only affects the first 
line of a paragraph. 

Requirements Attributes 
Sometimes Word documents contain attributes in addition to just the 
paragraph text. For instance, paragraphs may each be marked as 
“Mandatory” or “Optional”. 

14. ALWAYS label particular attributes in a consistent way. This will 
allow for easier processing in DOORS after import. 
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Non-Text Content 
Although most of the content in the Word documents people generally 
place in DOORS is text, we also have to deal with non-textual 
information. 

Captions 
Typographic convention is to place the caption for a table above the table 
and that for a graphic below the graphic. There are rarely good reasons for 
violating this convention. If you follow this rule, then the caption and the 
table or graphic will be imported into separate DOORS objects. 

Tables 
Manipulating tables in DOORS is extremely time intensive. When using 
tables make them as simple as possible. Do not use merged cells or leave 
extra columns or rows. You can simulate merged cells in DOORS but it is 
easier to create the affect once the table is in DOORS. In addition, do not 
orient a page in landscape because DOOORS will import it as portrait and 
it will take a lot of work to get it back in useful form. 

15. NEVER use white space to line up text in adjacent columns. Use 
table rows to line up associated information. 

16. Tables shall be formatted in portrait orientation. 
17. Tables shall not contain extra blank rows. 
18. Tables shall not contain extra blank columns 
Because of the different ways in which Word and DOORS manage tables, 
DOORS cannot reproduce exactly tables that have merged cells. 
19. AVOID merged cells in Word tables; it is generally better to hide 

borders between cells than to merge. The effect in DOORS is that 
all the cells in the Word table will be created. 

20. USE rectangular tables, that is, the same number of columns in 
each row. These are easiest for the Word to DOORS exporter to 
handle. 

21. DETERMINE the nature of the tables in the Word document. 
There are 3 types, determined by the granularity of traceability 
required: 

Whole Table 
You only ever need to trace to the whole table (because it either is or 
qualifies a single requirement.) 

22. CONVERT these tables into embedded OLE objects BEFORE 
import to DOORS. 

Note: that embedded OLE objects do not wrap across pages, so this is not 
appropriate for long tables. 
Row-by-row 
You need to trace to rows in the table (because each row is a requirement 
with attributes.) 

23. CONVERT these tables into one-object-per-row AFTER import 
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into DOORS. 
Cell-by-cell 
You need to trace to every cell of the table (because every cell is a separate 
requirement), or you don’t need to trace at all and the table is just used for 
layout 

24. JUST import these as DOORS tables. 
Nested Tables 

25. DO NOT use nested tables in Word. DOORS tables cannot be 
nested. 

Generally, nested tables are used to fit in items that either need to have a 
particular layout or are effectively additional attributes. In the first case, 
you can generally embed the nested table as an OLE item. In the second, 
they are better represented as additional columns. 

Layout of Pictures and OLE Objects 
In general, Pictures and OLE Objects export to DOORS better if they are 
set to be “In-line with text”. This works whether they are in a separate 
paragraph (generally recommended) or part of a paragraph. 

 

 
 
Figure 6: Layout option for Pictures 

Pictures 
When inserting images do not use multiple images or added drawings on 
top of them. For example, figure 4 of this white paper is made up of a 
screen shot with a red circle, drawn on top of the image, around the area to 
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which we wanted to draw attention. Figure 7 shows how DOORS 
imported the layered images. The circle represents object 299 and the 
screen shot represents object 300, two separate objects. 

 

 
 
Figure 7: Importing layered graphics 

26. Graphics shall be created from a single image. 
27. Graphics shall not be layered. 
28. ALWAYS anchor embedded pictures to the text. This is because 

the importer only imports things that are anchored. See also the 
note on OLE Objects. 

29. ALWAYS embed pictures as complete objects, rather than draw 
shapes directly into the page. Group objects if necessary. 

OLE Objects 
OLE Objects present special problems in Word. Not least because of 
Word’s insistence on managing them as anchored to text. This means that 
(contrary to what you might expect) they tend to move around 
unpredictably, as there seems to be no way to set the position of the text 
anchor after the object has been inserted. 

30. ALWAYS Insert OLE objects (linked or embedded) into a 
paragraph, preferably with a specific style. That way you can move 
the object around so that it goes where you put it, Word will only 
move it if it can’t fit it onto the page, exactly like a paragraph 
containing a single (large!) character. This is, in any case, what you 
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must do for objects that you want to embed into text. If you embed 
pictures as OLE objects, you will get all these advantages and 
avoid most of the misery Word seems determined to inflict on us. 

31. NEVER use Paste Special, as this will give you an object anchored 
to some point in the text that you cannot change. This means that, if 
you decide to make a table into an OLE object, you must first Cut 
it, then Insert Object Microsoft Word Document, Paste the 
table into the document, Close the (embedded) document. 
Actually, you can use Paste Special, but if you do you need to do 
Format Object Layout In-line with Text. 

 

Exporting from Microsoft Word 
 Note:  exporting a large document 

can take a significant time. Part of this time is re-drawing the 
Module Explorer. TURN OFF the Module Explorer for export and 
the process will run faster. You can do this during the export itself 
or open the module before the export (creating it first if necessary!) 
then turn off the Module Explorer. 
 

This topic describes how to export data from Microsoft Word into a 
module’s main column. You export headings and text into the module’s 
Object Heading and Object Text attributes. 
You migrate documents from Microsoft Word into DOORS by exporting 
them from Microsoft Word. 
You must open the target folder or project in the DOORS Explorer before 
Word can export data to it. You must also specify the module you want to 
import to, as described in the following sections. If the module does not 
exist, it is created during import. If the module exists, you are asked if you 
want to append the imported data to the module. If you do not want to 
append data, the import stops. 
• Paragraphs in the Word document that have Outline levels 1 to 9 are 

imported as heading objects. 
• You can choose to ignore section numbers in the Word headings. 
• Auto-numbered section numbers are always ignored. 
• Paragraphs formatted as Body text in Microsoft Word are stored in the 

Object Text attribute of objects. These are created one level below the 
appropriate heading object. 

• OLE objects are imported and stored as OLE objects. 
• Tables are imported as DOORS tables. 
• Bulleted lists are imported as DOORS bulleted lists 
• Indented paragraphs in Word have identical indenting applied in 

DOORS 
• All other styles are imported as object text. 

Unicode and other international data is included in the import. 
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• If you import a document containing hidden text to DOORS, then export 
the module back to Word, the hidden text will be displayed in the 
resulting Word document. 

• You cannot import a document that contains objects created using 
Microsoft Equation 3.0. 
You can capture the style formatting of paragraphs in your Word 
document for use in a later export to a new Word document. 

 

To export a document from Word into DOORS: 
1. In the left pane of the DOORS Explorer, click the project or folder that you 

want to import the document into. 
You must have create access to this folder or project. 

2. Start Word and open the document you want to send to DOORS. 
3. Click the Export to DOORS button on the Word toolbar, or click 

Tools > Export to DOORS. 
Note: If you are running DOORS through Citrix, Word must 

also be running through Citrix or the import will not 
work. 

4. In the Module Name box, enter the name of the module you want to 
export to. 

5. In the Module Description box, enter a module description. 
6. Optionally, in the Module Prefix box, enter the object identifier prefix. 
7. In the Absolute Numbers Start At box, enter the object identifier starting 

number. 
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8. If you want to ignore section numbers in Word headings, select the 
Remove header numbers check box. 
The auto-numbering produced by DOORS may be different from the 
auto-numbering in the original document. If you have references to any of 
them, you should store the original numbers. 

9. If you want to capture Word paragraph styles, select the Capture 
Paragraph Styles check box. 

10. Click Export. 
The module is created and opened, and the document is imported to it. 
The Progress panel on the Export to DOORS dialog gives information on 
the export progress. 

Importing RTF files 
The Import RTF tool reads an RTF (Rich Text Format) file and populates the 
current module with objects created from its contents. Unicode and other 
international data is included in the import. 
The imported objects are placed after the current object. 
Before you can import an RTF file, you need to map the styles used in the RTF 
file to appropriate DOORS features. The tool attempts to map the RTF heading 
styles to DOORS features for you. 
You can save a style mapping for future use. 
If the tool finds any text before the first heading in the RTF file, the first object 
created has an Object Heading of Front Matter, and the text is stored in the 
Object Text attribute of the child of the heading object. 
If the tool finds a picture embedded in a paragraph, it creates three objects. The 
first stores the text that precedes the picture; the second stores the picture; the 
third stores the text that follows the picture. The system attribute PictureNum, 
held in the object, stores a number that uniquely identifies the picture. 
RTF tables are imported as DOORS tables. Pictures contained in table cells are 
not imported. 
Importing a document in RTF format may use more resources than importing 
the same document as a Microsoft Word document. 
When you import an RTF document, a number of module attributes are created. 
These are used if the module is exported back to RTF, so that the resulting file 
has the same properties as the original. 
To import an RTF file: 

1. Open the module that is to contain the imported file. 
2. Select the object immediately before the required location for the imported 

file. 
3. Click File > Import > RTF. 
4. Type the name of the RTF file you want to import including the path, or 

click Browse to locate it. 
5. Click Import. 
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You use the Map RTF Styles dialog box to tell DOORS how to handle 
each RTF style in the file. The importer maps the heading styles that it can, 
and maps all other styles to object text. 

6. Click one or more RTF styles that you want to map to a specific DOORS 
feature. 
Double-clicking a selected style deselects all other selected styles, and 
selects the style you clicked. 

7. Click the DOORS feature you want to map the styles to. 
The mappings are defined. 

8. Repeat Step 4 and Step 5 until all the styles are correctly mapped. 
9. If you want to save the style mapping, enter the name of a settings file in 

the Settings file box, or use Browse to locate it, and click Save. 
10. Select the styles that are in the document to be imported. 

This is necessary for DOORS to treat the headings correctly. If you do not 
select the styles in the document, the first heading is made a Heading 
Level 1 during the import, regardless of its actual level. 

11. Click Import. 
The file is imported after the current object. 
A progress bar shows how much has been done. 

 

Importing spreadsheet files 
The import spreadsheet tool imports comma separated value (CSV) and tab 
separated value (TSV) files that have been created with packages such as 
Microsoft Excel or Microsoft Access. 
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In CSV and TSV files, the rows and columns of the spreadsheet (or database 
table) are stored as lines of text. 
 
Normally, each line represents a spreadsheet or database row, and contains 
data from each spreadsheet or database column. Each data item in a line is 
separated by a comma, or a tab, depending on the type of the file. However, if 
the file contains new line characters as part of the data, the strings that contain 
the new line characters are enclosed in quotes. 
 
The import spreadsheet tool creates one object for each line in the file, and 
derives object attribute values from the TSV or the CSV data. 
 
You can assign attribute values in two ways: 

• Using an attribute list 
If you use an attribute list, you create a list of existing attributes that 
correspond with the columns in the file you want to import. The attribute 
types must be appropriate for the data in each column, or importing 
fails. Where the importer encounters empty fields, it assigns default 
values. 

• Using column labels 
If you use column labels, the contents of the fields in the first line (the 
column labels) determine which attribute is used for each column. 

Note: The importer expects a label for the first column. If the 
spreadsheet does not have a label for the first column, you 
should add one; otherwise, the allocation of attributes does 
not work correctly. 

If the attributes do not exist, the tool creates them. The attribute types are 
normally derived from the type of data found in the columns, but you can 
choose the type you want from a list of defined types. 
 
If a spreadsheet has been imported, and you subsequently change it, you can 
update the imported data by re-importing the file using the Update existing 
objects option. This option also creates new objects if any have been added to 
the spreadsheet. 
 
If you decide to modify a subset of your data after you have imported it, you 
should filter the data you want to change, export the filtered data using the 
export spreadsheet tool, modify the exported data and then re-import it with the 
same filter applied. By using the Update Display set only option you guarantee 
that the correct objects are updated. 
 
Data items in a CSV or TSV file can have integer, real, date, or string values. 
Strings are typically contained within double quotes, and can contain commas, 
tabs, and line breaks. Double quotes can be imported if they are duplicated. For 
example, looking at the CSV file with a text editor, the following string: 
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"This string has a comma, which is not imported and a double quote "" 
too" 
is imported as: 
This string has a comma which is not imported and a double quote " too 
 

Importing a spreadsheet or database file 
To import a spreadsheet or database file: 

1. Open the module that you want to import the spreadsheet into. 
2. Select the object immediately before the required location for the imported 

text. 
The imported file is placed after the current object. 

3. Click File > Import > Spreadsheet. 
4. If you are importing a CSV file, select the Comma radio button. If you are 

importing a TSV file, select the Tab radio button. 
5. In the Input file box, type the name of the file you want to import or click 

Browse to locate it. 
6. The following table describes the other options on the Import 

Spreadsheet dialog box. 

If you want to: Then 

Import the file using attributes 
from list 

Select From List. 
The Attributes to import  and  Existing attributes 
sections become available. Define or load an attribute list.  

Import the file using column 
labels 

Select By column labels. 

Import the file to an empty 
module or to append objects to a 
populated module 

Select  Create new objects 

Update the attribute values of 
objects 
already in the module, and add 
objects 
that have been added to the 
CSV file 
 

Select Update existing objects. 
 

Update every object in the 
module 
 

Select the All objects radio button. 
This option is only available if Update 
existing objects is selected. 
 

Update objects in the current 
filter 
 

Select the Display set only radio 
button. This option is only available if 
Update existing objects is selected. 
 

Specify the encoding that you 
want to 
use to interpret the file. 

Click the Advanced button. The 
dialog box expands to display an 
encoding list, which contains a list of 
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If you want to: Then 

 the code pages that are available on 
your machine, and a preview pane. 
Select the encoding that was used 
when the CSV file was created. You 
can check if this is the correct 
encoding by looking at the output in 
the preview pane. If the encoding is 
not correct, the preview pane may 
display symbols instead of text. 
 

 
7. Click Import. 
 

If you are importing by column labels, and one or more attributes need to 
be created, you must confirm the creation of each attribute. 
• If you want to change the type of an attribute before the attribute is 

created, click Choose different type.  
 

• If you want to create an attribute without changing its type, click 
Confirm. 

8. If you selected to create new objects, the file is imported. If you selected to 
update existing objects, the Select Key dialog box is displayed. 
You use this dialog box to specify which column contains data that can 
uniquely identify every object that is created (or updated). 

9. Select the column that uniquely identifies the objects, and click Select. 
Importing runs to completion. When it is complete, a message box tells 
you how many objects were created or updated. 

10. If you imported by column labels, and created new attributes, you must 
create new columns in the module to display those attributes. After 
creating the columns, save a new view. 

Defining attribute lists for import 
 

To define an attribute list: 
 

1. On the Import Spreadsheet dialog box, select the From list radio button. 
 

The Attributes to import and Existing attributes boxes become 
available. 
 

2. From the Existing attributes list, select an attribute. 
3. Click Add. 

The selected attribute is listed in the Attributes to import list. 
4. Add, insert or delete attributes from the list until the attribute list matches 

the order of the columns in the file you want to import. If there are columns 
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in the file that you do not want to import to DOORS, add ignore to the 
attribute list for that column. For example if you have three columns in a 
spreadsheet, and you only want to import information from column one 
and column three you would add attribute 1, ignore and attribute 2 . 

5. Click Save. 
6. Type the name and path of a file to store the attribute list, or click Browse 

to locate it. 
7. Click Save. 

The attribute list is saved. It can be loaded and used later.  

Using attribute list elements for import 
 

To insert an attribute into an attribute list: 
 

1. In the Import Spreadsheet dialog box, select the attribute you want to 
add to the list from the Existing attributes list. 

2. From the Attributes to import list, select the attribute before which you 
want to insert the new attribute. 

3. Click Insert. 
 

To delete an attribute from an attribute list: 
 

1. From the Attributes to import list, select the attribute you want to delete. 
2. Click Delete. 
 

Loading saved attribute lists for import 
 
To load an attribute list: 
 

1. In the Import Spreadsheet dialog box, click Load. 
2. Type the name of the attribute list file you want to load including the path, 

or use Browse to locate it. 
3. Click Load. 

The attribute list is loaded, and the window is updated. 

Choosing attribute types 
When you import a spreadsheet by column labels, attributes are created in which 
the spreadsheet data is stored. The attribute types are derived from the types of 
data found in each column. 
You are asked to confirm the type or choose a different one. 
 
To choose a different attribute type: 

1. Click Choose different type. 
2. Select a new type for the attribute from the Attribute types available box. 

Click . 3. OK
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Imposing a Hierarchical  Structure on Imported Spreadsheets 

Existing information 
Suppose you want to bring existing information into DOORS.  Among the several 
formats that you may import information into DOORS, the spreadsheet is quite a 
useful feature to maintain your data structure. 

Import spreadsheet 
File > Import > Spreadsheet… will take you to the Import Spreadsheet dialog 
box.  Select Help for more details.  This tech tip will expand on that information. 
Using import “By column labels” DOORS reads the column labels in the 
spreadsheet and if they do not already exist, create the attributes on import.  So 
if you want a certain column to import into the “Object text” in DOORS, simply 
change the spreadsheet’s column label to “Object text” (or “Object heading” or 
any other existing attribute, regardless whether it is a DOORS system or user-
defined attribute). 

Outline Level dxl script 
Import spreadsheet is a great way to maintain data structure, but the information 
is brought in “flat” (everything is at level 1).  Add a column to your spreadsheet 
with “Outline Level” as the column label.  Make sure you assign a number (i.e., 1, 
2, 3, 4, etc.) for each line that corresponds to the desired level in the hierarchy.  
Note: when you import/create attribute “Outline Level” ensure it is of type 
“Integer.” Here’s an example:  
 
Unique key Outline Level Paragraph number Object heading Object text

1 1 1.0 Introduction
2 2 The system shall do this.
3 2 The system shall do this, too.
4 1 2.0 Requirements
5 2 More requirements
6 2 2.1 Sub heading
7 3 A requirement shall be here.

 
 
Save the file below, “Outline Level.dxl” to “<DOORS HOME>\lib\dxl\addins\user” 
(for example, “C:\Program Files\Telelogic\DOORS 7\lib\dxl\addins\user”) and you 
will find “Outline Level” under the “User” menu of an open DOORS module.  After 
importing the spreadsheet, select “Outline Level” and it creates the hierarchy 
according to the values you assigned. 

Summary 
DOORS import spreadsheet is a great way to maintain data structure.  Using this 
dxl script, you can now also automatically structure the document. 
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Chapter  19  Exporting 
 

This chapter contains the following topics: 
• Exporting to Microsoft Word 
• Exporting to Microsoft Excel 
• Exporting to spreadsheet 
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Exporting to Microsoft Word 
This topic describes how to export your current view to Microsoft Word. 

• If your module contains Unicode or international data, this is included 
in the export and is encoded in rich text format. 

• If your module contains hidden text that was previously imported from 
Word, the hidden text is displayed in the Word document when the 
module is exported. 

 
To export to Microsoft Word: 
 

1. In the module window, click File > Save. 
This saves the module. It makes sure that the data you export includes 
any changes you made recently. 

 
Note:  When you export modules to Microsoft Word, DOORS 

uses the Windows clipboard. Make sure there is nothing 
on the clipboard that you do not want to lose before you 
export. 
 

2. Click the Export to Word button  , or click File > Export > Microsoft 
Office > Word. 
Note: If you are running DOORS through Citrix, Word must 

also be running through Citrix or the export will not 
work. 

 
This option is not available if you do not have Word 
installed on your machine. 

3. Use the General tab to specify what data you want to export. 
 
 
General tab  Description  

Layout  Select either:  
• Book to use the book layout, which lists the data on separate lines. 

All the columns in the current view are exported.  
• Table to use the table layout, which lays the data out as a table, just 

like in DOORS. All the columns in the current view are exported.  

Include DOORS  
Heading Numbers  

By default, the DOORS heading numbers are exported  
with the Object Heading text.  
 
Clear this check box if you don’t want to export DOORS heading 
numbers.  
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General tab  Description  

Issue a warning  
when an  
unregistered OLE  
object is exported  
as a picture  

Clear this check box if you do not want to be warned that  
the module you are exporting contains unregistered OLE  
objects. Unregistered OLE objects are exported as  
pictures and cannot be activated in Word.  

Include empty  
attributes  

Select this check box if you want to export attributes that  
do not contain any value to Word. By default DOORS  
does not export empty attributes to Word.  

 
4. Optionally, use the Advanced tab to specify advanced options 

 
Advanced tab  Description  

Use Paragraph 
Style attribute 
 

If you previously imported the data from 
check box if you want to use the Word 
information that was captured during 
This information is stored in the module’s 
attribute. 
The styles named in the Paragraph Style 
to format the exported document. 
 

Allow style 
mapping 
 

Select this check box if you want to manually map 
DOORS heading and text levels to the Word paragraph 
styles in the exported document. 
For example, you can say that you want level 1 headings in 
DOORS to use the Heading 2 Word style. 
 

Ignore DOORS 
table borders, put 
all borders on all 
cells 
 

By default, the exported Word document uses the same 
table border settings as the DOORS module. 
Select this check box if you want to ignore the table 
border settings in the DOORS module, and put borders 
around all the table cells in the Word document. 
 

Ignore DOORS 
column widths in 
table layout export, 
AutoFormat 
instead 
 

By default, in Table layout the widths of the columns in 
the exported Word document match the widths in the 
DOORS module. 
Select this check box if you want to ignore the column 
width settings in the DOORS module, and let Word chose 
the column widths. 
 

Use normal 
template 
 

By default, the normal.dot Word template is attached to 
the exported document. 
If you want to use another template, clear this check box, 
then type the name of the template file in the Template 
name box, or use Browse to locate the file. 
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Advanced tab  Description  

Use horizontal line 
separators in book 
layout exports 
 

When using book format, this will insert line separators 
between objects in the Word document. 
 

Save Word 
document after 
every 
 

The export of large modules to Word occasionally fails 
with the Word error: "the formatting in this document is 
too complex. Please full save the document now". If you 
get this error, select this check box, and specify the 
intervals at which you want to save the Word document in 
the objects box. 
When you export the module, after the first group of 
objects has been exported you are prompted for a name 
and location to which you want to save the document. 
Subsequent saves during the export automatically update 
that document. 
 

 
5. Click Export.... 
6. If you selected the Allow style mapping check box on the Advanced tab, 

the Export to Word Style Mapping screen is displayed. 
The list on the left shows what mappings you’ll get. For example, by 
default, level 1 headings in DOORS are mapped to the Heading 1 style in 
Word, and DOORS bullets are mapped to standard Word bullets. 

 
Advanced tab  Description  

Change a style 
mapping 

Select the appropriate item on the left. 
Then in the list on the right, select the Word style you 
want to use. 

Save the style 
mapping 
information 

In the Settings file box, type the name of the file that you 
want to save the information in, or click Browse to locate 
it, then click Save. 

Load style mapping 
information from a 
file 

In the Settings file box, type the name of the file that 
contains the style mapping information, or click Browse 
to locate it, then click Load. 

 
7. When you have finished defining the mapping styles, click Close. 

Exporting to Microsoft Excel 
You can export your current view to Microsoft Excel. 

• Columns other than the main column are always exported. 
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• You can control whether you export the main column too, and if so, 
which of its attributes you export. 

• The maximum number of columns you can export to Microsoft Excel is 
25. 

Note:  When you export to Microsoft Excel, rich text formatting 
and special characters are not preserved. If you want to 
preserve rich text formatting, export to a Microsoft Word 
table, then copy and paste the Word table into Excel. 

 

To export to Excel: 
1. In the module window, click File > Save. 

This saves the module. It makes sure that the data you export includes 
any changes you made recently. 

2. Click File > Export > Microsoft Office > Excel. 
Note: If you are running DOORS through Citrix, Excel must 

also be running through Citrix or the export will not 
work. 

3. Use the Main column drop-down list to specify whether you want to 
export the main column: 
• Select Ignore if you don’t want to export the main column. 
• Select Object Heading to export the Object Heading attribute in the 

main column. 
• Select Object Short Text to export the Object Short Text attribute in 

the main column. 
• Select Object Text to export the Object Text attribute in the main 

column. 
• Select Object Heading and Text to export both the Object Heading 

and Object Text attributes in the main column. 
4. Select the Include column titles check box if you want to export column 

titles. 
5. Click Export. 

The data is exported to Excel. Excel opens and displays the exported 
data. 

Exporting to spreadsheet 
You can export your current view, or selected attributes, to a CSV (comma 
separated value) or a TSV (tab separated value) file. The exported file can be 
imported by packages such as Microsoft Excel or Microsoft Access. 
 
In CSV and TSV files, the rows and columns of the spreadsheet (or database 
table) are stored as lines of text. 
 
The export spreadsheet tool creates one line in the file for each object being 
exported. 
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Normally, each line represents one spreadsheet or database row. Each data item 
in a line is separated by a comma, or a tab, depending on the type of the file. 
However, if the data being exported contains new lines, the strings that contain 
the new line characters are enclosed in quotes. 
 
You can create a list of attributes to export or you can export the columns in the 
current view. 
 
You can include the names of the attributes in the file or, if you export the 
display set, you can include the column titles. 
Note: When you export to a spreadsheet, rich text formatting and 

special characters are not preserved. If you want to preserve 
rich text formatting, export to a Microsoft Word table, then 
copy and paste the Word table into the spreadsheet. 

 

To export to a CSV or TSV file: 
 

1. In the module window, click File > Save. 
This saves the module. It makes sure that the data you export includes 
any changes you made recently. 

2. Click File > Export > Spreadsheet. 
3. If you want to export all the columns in your current view, go to Step 8. 
4. If you want to specify which attributes are exported, click the Attributes 

from list radio button. 
5. Select the attributes you want to export: 

• Select an attribute in the Existing attributes box 
• Click either Add or Insert to add the attribute to the Attributes to 

export box: 
• Use Add to add it before the selected entry in the Attributes to 

export box. 
• Use Insert to add it after. 

6. Click Delete to delete an attribute from the Attributes to export box. 
Click Save to save the list of attributes to a file. Click Load to load a list of 
previously saved attributes from a file. 

7. When the attribute list matches the order of the columns you want to 
export, go to Step 8. 

8. Use the Include radio buttons to specify what objects you want to export: 
• Click All objects to export all the objects in the module 
• Click Display set only to export only the objects in the current view 

9. If you want to include the column titles in the first line of the exported file, 
select the Include attribute names/column titles in first row check box. 

10. Use the Data separator radio buttons to specify what type of file you want 
to export to: 

• Click Comma for a CSV file 
• Click Tab for a TSV file 
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11. Type the name of the file you want to export to, or use Browse to locate it. 
12. If you want to specify an encoding for the exported file, click Advanced. 

An Encoding list box containing a list of the code pages that are available 
on your computer is displayed. Select the encoding you want to use. 
Note: Microsoft Excel 2000 does not support UTF-8 CSV 

files. If you are going to view the CSV file using Excel 
2000, you need to export it with UTF-16 encoding. 

13. Click Export. 
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Chapter  20  Using Support Tools 
 

This chapter contains the following topic: 
• Editing imported Word style information 
• Resizing OLE objects 
• Converting layout DXL to attribute DXL 
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Editing imported Word style information 
If you capture paragraph style information when you import data from 
Microsoft Word, the style information is stored in the Paragraph Style attribute. 
The Paragraph Style attribute contains one or more <attribute: style> pairs. 
Each <attribute:style> pair defines the style that is applied to an attribute’s 
value when you export the data back to Word. 
 
You can change the style information if, for example, you want to export the 
module to a Word file that uses a template with special styles. 
 
You can edit the Paragraph Style attribute value in-place, but it is more efficient 
to use the Edit Paragraph Style Attribute tool. 
 
The Paragraph Style attribute can store as many <attribute: style> pairs as 
you want. 
 
The value of the Paragraph Style attribute is object specific, but it can contain 
style information for more than one attribute. This means that you could, for 
example, specify one style for the Object Heading attribute, and a different 
style for the Object Text attribute. If you then exported the object, Word would 
apply different styles to the data in each attribute. 
 
The tool can manipulate the styles either for the current object or for every 
object in the current view. 
 
Two settings have special significance: 

• The Attributes setting 
• The Properties setting 

 
The Attributes setting lets you specify a default style which applies to every 
attribute which is not listed in the Paragraph Style attribute. 
 
The Properties setting lets you specify styles for data in your view which are not 
attribute values, such as layout DXL and object identifiers. 
 
You use the Attributes setting and the Properties setting in the same way as any 
other attributes. They have <attribute:style> pairs like any other values in the 
Paragraph Style attribute. 
 
To run the Edit Paragraph Style Attribute tool: 
 

1. Open the module whose Paragraph Style attribute you want to edit. 
2. Click Tools > Support Tools > Edit Paragraph Style Attribute. 
3. In the Attribute box, select the attribute that you want to specify a style 

for. 
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4. In the Paragraph style box, type the name of the Word style that you 
want to use for the selected attribute. 

 
Note  To delete the paragraph style information for the 

selected attribute, clear (delete all the text in) the 
Paragraph Style box. 

5. If you want to change the Paragraph Style attribute of the current object 
only, click Apply to Current. 
If you want to change the Paragraph Style attribute of all objects in the 
current view, click Apply to All. 

6. Click Close. 

Resizing OLE objects 
If an inserted OLE object is too large to fit in the column in which it has been 
inserted, you can resize it to fit the column. You can resize all of the OLE 
objects in a module, or just the OLE objects in the current object. 
 
To resize OLE objects to fit the column in which they are inserted, select Tools 
> Support Tools, then either Set OLE Size For Current Object or Set OLE 
Size In All Objects in the formal module window. 
 
To reset OLE objects to their original size, select Tools > Support Tools, then 
either Reset OLE Size In Current Object or Reset OLE Size In All Objects. 

Converting layout DXL to attribute DXL 
Values that are stored in layout DXL columns are recalculated every time 
DOORS refreshes the display. The constant recalculation of the values is 
memory intensive and can lead to poor performance. If you do not need your 
DXL program to update dynamically, you can convert the contents of your 
layout DXL column to attribute DXL. 
 
To convert a layout DXL column: 

1. Open the module that contains the layout DXL you want to convert in 
exclusive edit mode. You must have create access to the module. 

2. Select the view that includes the layout DXL column you want to convert. 
3. Select Tools > Support Tools > Convert Layout DXL to Attribute 

DXL. 
The Convert Layout DXL dialog box is displayed. It contains a list of the 
Layout DXL columns in the current view. 

4. Select the column that you want to convert and click Convert. 
A message is displayed stating that the DXL has been successfully 
converted, and the new Attribute DXL column is added to the view. 
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Chapter  21   Keyboard Shortcuts 
 

This chapter describes the keyboard shortcuts you can use instead of clicking 
menu options with your mouse: 

• CTRL keys 
• Rich text 
• Function keys 
• Keypad keys 
• Navigation Keys 
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CTRL keys 
The following table lists the control key shortcuts: 

Keys Context Description 

CTRL+A  Formal module  Edits the attribute in the next column.  

CTRL+C  DOORS 
Explorer  

Copies the currently selected items to the DOORS 
Explorer clipboard.  

 Formal module  Copies the currently selected objects to the module’s 
object clipboard. If you’re editing an object, it copies 
the currently selected text to the system clipboard.  

CTRL+D  DOORS 
Explorer  

Creates a new descriptive module.  

 Formal module  Discards a data change during an edit (deletes the 
edits you made to the current object).  

 Link module  Deletes a link.  

CTRL+E  DOORS 
Explorer  

Opens the selected module in Exclusive edit mode  

 Formal module  Displays the object properties sheet, so you can edit 
objects.  

 Link module  Displays the Edit Link Object sheet if a link is selected.  

CTRL+F  DOORS 
Explorer  

Creates a new formal module.  

 Formal module  Finds text in the module.  

CTRL+G  Formal module  Goes to a particular object in the module.  

CTRL+H  Formal module  Edits the Object Heading attribute for the current 
object.  

CTRL+I  DOORS 
Explorer  

Moves focus between the toolbar, favorites, location, 
DOORS Explorer pane and Contents pane.  



Centers for Medicare & Medicaid Services  
  

290  

 
Keys Context Description 

 Formal module  Starts a link.  

CTRL+K  Formal module  Runs the spelling checker.  

CTRL+L  DOORS 
Explorer  

Creates a new link module.  

 Formal module  Creates a new object one level below the current 
object.  

 Link module  Creates a new linkset.  

CTRL+M  Formal module  Makes a data change (accepts the edits you made to 
the current object; they are stored in memory).  

CTRL+N  Formal module  Creates a new object at the same level as the current 
object.  

 Link module  Creates a new link.  

CTRL+O  DOORS 
Explorer  

Opens the Customize Toolbars dialog box.  

 Any module  Opens the Customize Toolbars dialog box.  

CTRL+P  Formal module  Prints the module.  

CTRL+R  DOORS 
Explorer  

Opens the selected module Read only.  

 Formal Module  Removes the contents of an attribute when it is open 
for in-place edit.  

CTRL+S  DOORS 
Explorer  

Opens the selected module in Shareable edit mode  

 Any module  Saves the module.  

CTRL+T  Formal module  Edits the Object Text attribute of the current object.  

CTRL+V  DOORS 
Explorer  

Pastes the contents of the DOORS Explorer clipboard 
to the DOORS Explorer.  
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Keys Context Description 

 Formal module  If you’re editing an object, it pastes the contents of 
the system clipboard. Otherwise it pastes the 
contents of the module’s object clipboard. New 
objects are created at the same level as the current 
object.  

CTRL+X  DOORS 
Explorer  

Cuts the currently selected items, and places them 
on the DOORS Explorer clipboard.  

 Formal module  Cuts the currently selected objects to the module’s 
object clipboard. If you’re editing an object, it copies 
the currently selected text to the system clipboard.  

CTRL+Z  Any module  Undoes your last edit.  

CTRL+RETURN  DOORS 
Explorer  

Opens selected module in default edit mode.  

 Formal module  Creates an object at the same level as the current 
object, when you’re editing in-place.  

CTRL+LEFT 
ARROW  

Formal module  Goes to the current object’s parent. If you’re editing 
text, moves the insertion point one word to the left  

CTRL+RIGHT 
ARROW  

Formal module  Goes to the current object’s first child. If you’re 
editing text, moves the insertion point one word to 
the right  

CTRL+HOME  Formal Module  When editing text, moves the insertion point to the 
start of the attribute  

CTRL+END  Formal Module  When editing text, moves the insertion point to the 
end of the attribute.  

CTRL+ Double-click 
on attribute  

Formal Module  Goes to Edit Value editor of that attribute  
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Keys Context Description 
RETURN  Formal Module  When editing attributes goes to same attribute for 

the next object (for enumerated lists only)  

CTRL+Right SHIFT  Formal Module  When in-place editing, right aligns the attribute value 
for right-to-left reading order.  

CTRL+Left SHIFT  Formal Module  When in-place editing, left aligns the attribute value 
for left-to-right reading order.  

CTRL+SHIFT+F  Formal Module  When a link start is defined, creates a link from the 
start object  

CTRL+SHIFT+M  Formal Module  When a link start is defined, creates  
a link to the start object.  

Rich text 
The functions in the following table are only available when you are editing 
attributes of type text or string in a formal module: 

Keys Description 

CTRL+B  Makes the currently selected text bold.  

CTRL+I  Makes the currently selected text italic.  

CTRL+U  Makes the currently selected text underlined.  
 

Function keys 
The functions in the following table are available in formal modules and the 
DOORS Explorer: 
 

Key Description With CTRL 

F1  Displays help in the DOORS 
Explorer and in module windows, 
but not in dialog boxes.  

F2  DOORS Explorer - Displays the 
properties sheet of the item 
selected in the right pane.  
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Key Description With CTRL 

F2  In Module - Add the current 
object to a selection. For 
example, you can use F2 to 
select object 1 then use F2 to 
select object 5, and all the objects 
in between will be selected. You 
can then use F2 to select object 9 
and all the objects between 
object 5 and object 9 will be 
added to the selection.  

Clears the current selection.  

SHIFT+F2  Clears the current selection.   

F3  In Module - Select  In Module - Deselect  

F3  Finds the next object in the 
module when using the Find 
function.  

 

SHIFT+F3  Finds the previous object in the 
module when using the Find 
function.  

 

F4  Deletes the current object.   

F5  Refreshes the screen.   

SHIFT+F5  Refreshes the module   

F6  Compresses the current object if 
outlining is turned on.  

Uncompresses the current object if outlining 
is turned on.  

SHIFT+F10  In the DOORS Explorer and in 
module windows, displays the 
context menu (equivalent to right-
clicking).  

 

 

Keypad keys 
The functions in the following table only work if you turn the NUM LOCK off 
by pressing NUM LOCK. 

 
 

Keypad 
key Description With CTRL 

HOME 7  Moves to the first object in a 
formal module.  

When editing text, 
moves the insertion 
point to the start of the 
attribute  
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Keypad 
key Description With CTRL 

END 1  Moves to the last object in a 
formal module.  

When editing text, 
moves the insertion 
point to the end of the 
attribute  

 
 
 
 
 

Navigation Keys 
The following table lists the navigation key shortcuts: 
 
 

Press To 
INSERT  Create an object one level below the current object.  

CTRL+INSERT  Create an object at the same level as the current object.  

HOME  Go to the first object in the module.  

END  Go to the last object in the module.  
CTRL+HOME  If you are editing text, moves the insertion point to the start of the 

attribute.  
CTRL+END  If you are editing text, moves the insertion point to the end of the 

attribute.  
PAGE UP  If you’re in Document mode, scroll up one screen. If you’re in Graphics 

mode, rotate the tree clockwise through 90 degrees.  

PAGE DOWN  If you’re in Document mode, scroll down one screen. If you’re in 
Graphics mode, rotates the objects clockwise.  

UP ARROW  
If you’re in Document mode, go to the next or previous object.  

DOWN ARROW  If you’re in Graphics mode, move up or down the tree hierarchy. 
CTRL+UP ARROW, 
CTRL+DOWN 
ARROW  

Move from the current object to the sibling above or below it. If the 
focus is on the left pane of the module explorer, they scroll. If you are 
editing text, moves the insertion point to the start or end of the attribute.  
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Press To 

CTRL+SHIFT+UP  
ARROW,  
CTRL+SHIFT+DOWN  
ARROW  

Scrolls smoothly through the module contents.  

CTRL+LEFT 
ARROW, 
CTRL+RIGHT 
ARROW  

Go to the current objects parent (left arrow) or first child (right arrow). If 
the focus is on the left pane of the module explorer, they scroll. If you 
are editing text, moves the insertion point to the start or end of the 
previous or next word.  

SHIFT+RETURN  If you’re in document mode, edit the current object in-place. If you’re 
already editing the current object, goes to the next object.  
It does nothing if you are in Graphics mode, or if the focus is on the left 
pane of the Module Explorer.  

MENU  
In the DOORS Explorer and in module windows,  
displays the context menu (equivalent to right-clicking or  
SHIFT+F10).  
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Chapter  22  Contacting Customer Support 
 

This chapter contains the following topics: 
• What to do before you contact customer support 
• How to contact customer support 
• Sending an automated problem report form 
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What to do before you contact customer support 
If your site has a designated on-site support person, please contact that person 
before you contact our customer support team. 
To help our customer support team solve your problem, please have the 
following information available: 

• Your name, title, company name, e-mail address, fax number and 
telephone number. 

• Your Telelogic support ID and Telelogic support password. 
• The version and build number of DOORS that you’re running. 

To get this information, run DOORS, and click Help > About DOORS. 
• The operating system you’re running DOORS on, for example, 

Windows XP 
• What operating system your DOORS database is running on, if 

different. 
• If you are reporting a new problem, please have a clear statement of 

the problem, including the exact text of any error messages produced 
by DOORS, your operating system, or any other tools that were running 
when the problem occurred. 

• If you are calling about a problem you reported earlier, you need the 
original tracking number the customer support team assigned to your 
problem. 

How to contact customer support 
Visit the support center on our web site at http://support.telelogic.com. 
Alternatively, you can e-mail or telephone us. For up-to-date contact 
information, visit http://support.telelogic.com/contact/support/. 

 

Sending an automated problem report form 
To send an automated problem report to customer support: 

1. Select Help > Generate Support Request. 
The Telelogic Support Information dialog box is displayed with some of 
your product information automatically included. 
Review the information to make sure it’s accurate. 

2. From the Impact drop down list box, select the severity of the problem. 
3. In the Summary box, summarize the problem. 
4. In the Problem box, type a detailed description of the problem. 
5. If available, attach a snapshot. 

Click either DOORS Window Snapshot or Screen Snapshot, whichever 
is applicable, and select the snapshot from your machine. 

6. If possible, add files, and/or a video capture by using the buttons in the 
Attachment Information area. 

7. Add any additional items or information to help the customer support 
resolve the problem. 

8. You can either: 
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• Display the information you’ve entered in a new window so that you 
can copy it. For example, you may want to add this information to 
someone else’s information. 
Click Just Text (No Email). 

• Open the email to edit it before sending it to customer support. 
Click Preview and Send to submit the report. 

Guidelines for writing a problem report 
• Be as specific as possible when you summarize the problem in the 

Summary box and when you explain the situation and provide 
details in the Problem box. For example, “The system crashed 
when I tried to add an attribute” is more helpful than “It crashed.” 

• Indicate if there were any system changes, such as customizations 
or upgrades, before the problem occurred. 

• If the problem is reproducible, list the specific steps to be followed 
in order to demonstrate the problem and also indicate the model you 
are using to perform the steps. 

• In the problem description, include anything different or unusual 
that you observed before the problem happened. 

• Make screen captures of anything that you feel will help and attach 
them to the problem report. 

• Include any error messages and code samples you have related to 
the problem. 

• If you have multiple unrelated questions or issues, please submit 
them separately. 

Automatic responses and recording defects 
When you send the online form to customer support, the customer service 
system immediately searches the Knowledge Base based on the Summary and 
Problem descriptions you entered. If there is an exact match of your problem in 
the knowledge base, the system automatically sends an email to you with a 
pointer to the most likely solution. 
 
The problem is also automatically recorded in the defect tracking system as 
assigned to a support representative. This representative works with you to be 
certain that your problem is solved. The defect tracking system also records new 
problems with their solutions in the Knowledge Base to provide rapid assistance 
for other customers. 

 

Automatically generated problem reports 
If your DOORS system crashes, it displays a message asking if you want to send 
a problem report about the crash to DOORS Support. 
If you decide to send this generated report, the system displays the same online 
form that is available from Help > Generate Support Request. In this case, 
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the form contains information about the crash condition, in addition to the 
information that is usually filled in describing your system. 
Add any more information that you can to help the customer support staff 
identify the problem before you click the Preview and Send button. 

 
 
 
 
 
 
 
 
 
 




