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1 Introduction 

The Bid Pricing Tool (BPT) is a Microsoft Excel based application, enhanced with specific 
features such as the BPT Finalization and Circle Invalid functions. In order to effectively use 
these functions, we recommend you read this document thoroughly before using the Bid Pricing 
Tool. 

Three types of BPT workbooks will be discussed in the following sections: 
• BPT working file – A BPT file that is read-write enabled and allows you to update and 

save changes to the file. 
• BPT backup file – A read-only BPT file generated as part of the finalized save process. 

The backup BPT file name is created using the standard naming convention (see Section 
2.4.2) and appended with the word “backup” and a timestamp. All BPT functionalities 
are disabled. The data in the back up file will be the same as that in the working file. 
Removal of the text “backup” from the backup file name will make the file editable. 

• BPT finalized file – A read-only BPT file generated from the finalized save process. The 
file is generated following a standard naming convention. All BPT functionalities are 
disabled and all formulas are removed. The finalized save process will delete or 
standardize some of the data in the finalized file according to specified business rules. 
The finalized save process will not change the data in the working file. 

New features for CY2009 

The following is a list of new BPT functions implemented for CY2009. These sections will also 
be noted as “New for CY2009” throughout the document. 

1. Hide/Unhide Non-Validation Cell Label – Section 2.3.6 

2. Print Defined Worksheets – Section 2.3.7 

3. Batch Update PD (Prescription Drug) National Average – Section 2.8.4 

4. Batch Update MA (Medicare Advantage) with PD Premiums – Section 2.8.5 

5. MA, MSA (Medical Savings Account) new critical validations – Section 5.1 and 5.2 

6. Excel 2007 will be supported for CY09 BPT files. – Section 2.1.1, 2.2.1, 2.2.4, 2.3.10, 
2.4, 2.8.1  

Key points for working with BPT files in Excel 2007: 

a. You can open and work with a BPT file in Excel 2003 format in Excel 2007 
compatibility mode.  

b. You must save and finalize a BPT in the .xls format. 

c. When you close a BPT file, you must also close the Excel window before you 
open another BPT file. 

d. The Batch Process Tool is not supported in Excel 2007. 

e. Uncheck the compatibility check checkbox when you save the BPT the first time 
and before you run the Batch Process Tool. 
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7. The BPT Batch Tool is not currently supported in the Vista Operating System.  There are 

known conflicts between the Batch Tool and the Vista OS that we are working to 
resolve.  We cannot guarantee that the Batch Tool will perform as intended with Vista.  
We recommend you run the tool only under Windows XP or Windows 2000.  
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2 Bid Pricing Tool Functions 

2.1 Download and Installation   

2.1.1 Configuration Requirement 

For the BPT to work properly, you must configure your PC to satisfy the following requirements: 

• Have Microsoft Excel 2000 or greater installed.  

• Have Microsoft Excel 2002 or greater installed if you intend to use the Batch Process 
Tool. 

• Create a C:\Program Files\BPT2009 folder on your PC. 

Note:  If you are using Windows XP Home Edition you may need to unhide your 
C:\Program Files directory. 

• Enable your Excel Standard Toolbar. 

Note: All of the BPT-specific icons are loaded with the Excel Standard Toolbar... 

• For Excel 2000-2003, set your Excel Macro Security Settings to Medium 
(recommended). You can do this by selecting Tools->Macro->Security command from 
your Excel menu bar.   

• For Excel 2007, set your Excel Macro Security Settings to “Disable all macros with 
notifications”. You can do this by selecting Office Button->Excel Option->Trust Center-
>Trust Center Settings->Macro Settings. 

• Enable macros when you open the BPT workbook. 

• Install the BPT add-in (BPT.xla) in the C:\Program Files\BPT2009 folder.   

2.1.2 Installing the add-in file 

The CY2009 BPT is comprised of the following two Microsoft Excel file types: 

• Workbooks: MA, PD, MSA and MA Two Year Look-back (.xls files).  

• Macro code:  BPT Add-In (.xla file).  

The BPT workbook file contains the editable BPT worksheets. The BPT add-in contains the code 
that supports the BPT workbook functionality. 

The BPT workbooks and the BPT add-in files can be downloaded as part of the Plan Benefit 
Package (PBP) software or as separate stand-alone files: 

• The BPT workbooks and the BPT add-in files can be downloaded with the PBP software, 
which contains MA, MSA and PD benefit information. To download the BPT workbooks 
as part of PBP, go to the Health Plan Management System (HPMS) website->Plan Bids-> 
Bid Submission->Contract Year 2009->PBP Data Entry Software. 
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The initial PBP installation will save the BPT workbooks to the C:\Program 
Files\PBP2009 folder. The BPT add-in file will be saved in the C:\Program 
Files\BPT2009 folder. This installation process will support BPT data pre-population 
from the PBP.  

• You can also download the BPT add-in file and a blank BPT workbook separately to 
your PC. To download the BPT add-in file and blank BPT workbooks, go to the HPMS 
website->Plan Bids->Bid Submission->Contract Year 2009->Download->BPT 
Spreadsheets. 

o You must create the C:\Program Files\BPT2009 folder and save the BPT 
add-in file to the BPT2009 folder. This installation process will not support 
data pre-population from the PBP (i.e., the workbooks will be blank). If there 
is an existing BPT2009.xla file in the C:\Program Files\BPT2009 folder, you 
must always overwrite the existing BPT add-in (BPT2009.xla) file saved on 
your PC with the most current version. (Do NOT move/copy the add-in to 
another location on your PC.) 

If you do not save the BPT add-in file in the designated folder, you will receive a message within 
the BPT workbook stating that the BPT2009.xla (BPT add-in) file cannot be found. The BPT 
will open in read-only mode. If the BPT add-in is not saved in the correct folder, you will not 
be able to use the BPT. 

The BPT add-in will not interfere with any non-BPT files. 

For users that prepared BPTs for previous contract years, the CY2007 and CY2008 BPT add-in 
file should be left in place from previous years (saved on your PC under C:\Program 
Files\BPT2007\BPT.xla or BPT2008\BPT2008.xla). 

For Excel 2007 (New for CY2009) 

When extracting the BPT2009.xla file from the zip file, you will need to use the Copy and Paste 
function to save the add-in file into the C:\Program Files\BPT2009 folder. If you selected the 
Save function (or the Save As function), the add-in file will have an incorrect file extension 
.xlam. THIS IS ONLY RELEVANT FOR EXCEL 2007. 

2.2 Opening the BPT 

2.2.1 Macro Security Level Setting  

For Excel 2000 – Excel 2003 

The BPT workbooks use macros to perform the built-in BPT functions including the validation 
and finalization processes.  

For security purposes, it is highly recommended that the Macro Security Level Setting be set at 
Medium. You can do so by selecting Tools->Macro->Security command from the Excel menu 
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bar. You will not be able to open the BPT if your macro security settings are set to High or Very 
High. 

If your Macro Security setting is set to Medium, you will be prompted to enable or disable 
macros when you open the workbook. You must ”Enable macros” to correctly open the BPT. If 
you “Disable macros”, the workbook will display a screen stating that the macros must be 
enabled in order to use the BPT. You will have to close and then reopen the workbook to enable 
macros. 

For Excel 2007 (New for CY2009) 

For CY2009, BPT working files are supported in Excel 2007. The BPT files on HPMS available 
for download are in the Excel 2003 format. You will be able to open and work with the BPT files 
in Excel 2007 in compatibility mode. You MUST save and/or finalize the BPT files in the 
Excel 2003 (.xls) format once you are finished. You will only be able to upload an .xls BPT 
file to HPMS.  

Note: If a BPT file is saved in the Excel 2007 (.xlsm) format, an error will occur when you 
attempt to reopen the file. Please do not save the BPT file in .xlsm format. This applies to 
working files as well. 

For Excel 2007, the security setting options are “Disable all macros without notification”, 
“Disable all macros with notification”, “Disable all macros except digitally signed macros” and 
“Enable all macros”. For security reasons, it is recommended that you set the setting to “Disable 
all macros with notification”.  

When the security setting is set to “Disable all macros with notification”, the workbook will open 
with a Splash screen (i.e. static information screen) and you will see “Security Warnings. Macros 
have been disabled.” and an Option button. You will need to click the Option button and select 
“Enable this content”. The workbook will then open with the add-in loaded. You will see all the 
add-in icons in the Add-In tab on the Toolbar.  

Under the same security settings (Disable all macros with notification), it is possible that the 
workbook will open and be editable without the add-in loaded. This may be due to previous 
Excel instances not closed correctly. You will still need to select “Enable this content” to load 
the add-in in this situation. Do NOT save any changes in the workbook until you select the 
“Enable Macros” option. The BPT file will not function properly until the add-in is loaded 
(when all add-in icons appear on the Add-in Toolbar.) 

You will be able to open and work with multiple BPT files in the same Excel 2007 instance. But 
if you want to close a BPT file and open another one, you should close the existing Excel 
window and open the next BPT file in a new Excel window. There are known issues related to 
Excel 2007 when you open a file in an existing Excel window. If you encounter any issues when 
opening a BPT file, close the Excel window, go to Task Manager, delete any existing Excel 
processes, then open a BPT file in a new Excel window. 
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2.2.2 Version Compatibility  

The previous year working files (e.g., CY2008 or CY2007) and CY2009 working files will 
NOT work properly in the same Excel instance (i.e., window). You must open and work with 
a CY2008 working BPT file and a CY2009 working BPT file in two different Excel instances 
(Select Start->Programs, open a different Excel instance and open the CY2009 file). You may 
move between both workbooks. 

Note: It is not sufficient to close a CY2008 working BPT prior to opening a CY2009 
workbook within the same instance of Excel. The CY2009 workbook MUST be opened in a 
different instance of Excel by closing Excel before opening the CY2009 workbook. 
Otherwise you will encounter a “subscript out of range” error. This error will disappear once you 
close the CY2008 instance and re-open the CY2009 instance. 

You must open the working files for the same contract year in the same Excel instance, 
otherwise, you will receive an error message stating the BPT add-in file is read-only because it is 
already open in another Excel instance. 

Note: You will be able to open a read-only file, such as a finalized or backup file (CY2008 or 
2009) and a working file (CY2008 or CY2009) in the same Excel instance.  

For returning BPT users (i.e., those that used the CY2008 BPT), you may receive the following 
error message upon opening the CY2009 BPT for the first time you access the CY2009 BPT: 

"There was a general error when attempting to open the workbook.  9: Subscript out of 
range" 

If this error occurs, select the Tools->Add-in and un-check the “BPT2008” box Verify that the 
“BPT2009” box is checked. This will resolve the error when opening the CY2009 BPT 
thereafter. 

If you encounter any errors when opening the BPT files, please refer to Section 4.1 for more 
instructions. 

2.2.3 Data Pre-population 

When you open a BPT workbook that was downloaded with the PBP software, a subset of data 
(e.g., MA, PD and MSA BPT Worksheet 1, Section I-General Information) will be populated for 
you. Pre-population of each BPT workbook will only occur once. If pre-populated information in 
the header section is inaccurate, you can update the data in the BPT. The yellow highlighted cells 
in the header section are unprotected to allow you to change values if necessary.  

Note: After the data pre-population, any information updated on the HPMS website or PBP will 
not be automatically reflected in the BPT. You must update the BPT manually to maintain data 
consistency. 

If you download a blank BPT directly from HPMS, the BPT header section will be blank. We 
recommend that you enter the header information before entering other data.  

7 



 

CY2009 Bid Pricing Tool Technical Instructions 
2.2.4 BPT Commands 

After you successfully open a working BPT, the macros will load seven BPT-specific icons in 
the Excel Standard Toolbar. These icons are only available if the Standard Toolbar is enabled. If 
you reset the Toolbar to its default setting, these icons will disappear and you must close the BPT 
and reopen to restore these icons. You can also access these commands from the File menu. A 
list of short cut key combinations listed on the File menu allows you to use the keyboard to 
trigger these functions.   

For Excel 2007, these functions are located in the Add-In menu on the Toolbar. 

 

Icon names (from left to right): 

• Finalize BPT: Ctrl+Shift+S 

• Circle Invalid: Ctrl+Shift+C 

• BPT Refresh: Ctrl+Shift+R 

• Validation Report: Ctrl+Shift+I 

• Hide/Unhide Non-Validation Input Cell Label: Ctrl+Shift+L 

• Hide/Unhide Rate Books: Ctrl+Shift+B 

• Change Links: Ctrl+Shift+K 

• Hide/Unhide Validation Cell Label: Ctrl+Shift+M (New for CY2009) 

• Print Defined Worksheets: Ctrl+Shift+P(New for CY2009) 

2.3 Completing the BPT working file 

2.3.1 Data Entry Formatting 

All data entry fields are highlighted in yellow. This includes pre-populated cells. When you need 
to complete BPTs for similar plans, you can make a copy of your working BPT workbook and 
make the necessary changes to the header section on worksheet 1 to decrease the need to enter 
duplicate data. 

When the data is pre-populated, the formatting is adjusted to display leading zeros on certain 
entries for a subset of cells (e.g., Plan ID). If you are manually inputting data in the following 
user-entered fields, we recommend that you add the apostrophe (‘) and leading zeros as part of 
each value. This applies to all BPTs.  

• Plan ID (Worksheet 1, Section 1, General Information) 

• Segment ID (Worksheet 1, Section 1, General Information) 
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• Region ID (Worksheet 1, Section 1, General Information) 

• County Code (MA Worksheet 5) 

Examples: 
Region 5 - Input the value ‘05..05 will be displayed in the BPT. 
Plan ID 30 - Input the value ‘030. 030 will be displayed in the BPT. 
If you do not use an apostrophe when entering these data, the finalized BPT will display all 
leading zeros for applicable cells. 
 
Note: If you select PD regions 01-09 from the drop down list, it will display as 1-9 and the red 
circle will display in the working file. You can correct it by entering ’01, ’02 etc in the cell. If 
you do not manually correct the value, it will be corrected when you finalize the BPT. 

If you copy and paste cells in any of the BPT worksheets, we recommend using Excel’s 
PASTE SPECIAL feature with the PASTE VALUES or PASTE FORMULAS option. This 
will eliminate the possibility of altering the cells’ predefined format through the use of the 
standard paste command. You should not use the “Cut” function in the BPT file, because it will 
remove the cell formatting. 

Note: You should use the Delete key instead of the Space bar to delete cell values from the BPT. 

2.3.2 Cell Validation 

A subset of user-entered data is validated for accuracy. For example, the MA Base G5 validation 
rule is “The Organization Name cannot be blank”. There are two ways to view failed validations: 
the Circle Invalid function or the Validation Report function. 

2.3.2.1 Circle Invalid 

The Circle Invalid function is available in all BPT workbooks (MA, MSA, PD and 2YLB). You 
can either click the icon  on the Toolbar or select “Circle Invalid” from the File Menu. When 
clicked, all failed validations in the workbook will have a red circle around them. The Circle 
Invalid function will also execute automatically upon opening, saving and finalizing a BPT 
workbook. 

If your cursor is on a cell with a red circle, a small message box will appear and display the cell 
location and validation rule for that cell. You may move this input message box to any section of 
your screen by clicking and dragging the box. The error message will remain open until you 
select another cell.  

The Excel validation function will not be triggered automatically when a cell is updated. You 
must always click the Circle Invalid icon to re-validate the cell(s) and refresh the workbook.  

• If you are updating a cell with red circle, the red circles may disappear as soon as a valid 
value is entered into a cell. But in some situations (e.g., when the validation is based on 
values in other cells or when you have copied and pasted data into the BPT), you will 
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need to click on the Circle Invalid icon to trigger the validation function again, which will 
remove the red circle for the corrected cell.   

2.3.2.2 Validation Report  

The Validation Report function is available for all BPT workbooks (MA, MSA, PD and 2YLB). 
You can click the icon  on the Toolbar or select “Validation Report” from the File menu. This 
function will allow you to create two reports: the Failed Validation Report and the Active Cell 
Validation Report. These reports will appear on a new worksheet in the BPT. 

The Failed Validation report will display a list of cells that failed validations and corresponding 
information such as cell location and input message (validation rule). If the error is one of the 
critical validations that will prevent you from finalizing a BPT, you will see “Yes” displayed in 
the Critical error column. You will not be able to modify the report, but you can copy and paste 
the data into another document if needed.  

Note: If a cell has both critical and non-critical error checks, and the critical error logic passes, 
but non-critical error logic fails, the “Yes” will display in the report. You will be able to finalize 
the file in this scenario.  

The Validation Report function will also trigger the Circle Invalid function. If you generate the 
Validation Report you will also generate the red circles in the workbooks.  

The Active Cell Validation is designed to assist vision-impaired users who use a screen reader. It 
reports the validation status (Passed, Failed or No Validation) for the active cell on which the 
cursor is placed.   

The validation report worksheet will be hidden when you save, close or finalize a BPT. You can 
re-generate the report by clicking the icon on the Toolbar. 

The reports are not “refreshed” automatically if you make changes to the worksheets. You must 
re-generate the report to refresh the results. 

2.3.3 BPT Refresh 

The BPT Refresh function will refresh a workbook based on the logic below. If any of the 
following data points are linked to a data source and the data source file is updated, you will 
need to run the BPT Refresh function. This icon  is available in the MA, MSA and PD 
workbooks. This function will also be triggered when you open or save a BPT file.  

• Plan Type on MA Worksheet 1 Cell G7 

o If the Plan Type is RPPO, the MA Region field will be editable; otherwise it 
will be protected and display N/A. 

o If the Plan Type is RPPO, the MA Benchmark Plan Bid Component (w5, 
K17) will be editable; otherwise the field will be protected and display N/A. 
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• MA-PD indicator on MA Worksheet 1 Cell G8 and Plan ID on Worksheet 1 D6 

o If Plan ID is < 800 and MA-PD indicator is “No”, the MA Bid Summary Plan 
Intention for target Part D basic premium (w6 R47) will be protected and display a 
value of “N/A – MA only plan”. 

o If Plan ID is < 800 and MA-PD indicator is “Yes”, MA W6 R47 will contain a drop 
down list. 

o If Plan ID is >800, MA W6 R47 will be protected and display “N/A - EGWP bid”. 

• Plan Type on PD Worksheet 1 Cell I6 

o If the Plan Type is PDP or ED PDP, cell F32 on PD Summary (w7) will be 
enterable and have a drop-down list displaying values 0.10 and 0.50; for all 
other plan types, this cell will be protected and display value 0.10. 

o If the Plan Type is PDP, ED PDP or Fall Back, the Enrollee Type field (w1 
I7) will be protected. Otherwise, this cell will be editable. 

• PD Benefit Type on PD Worksheet 1, N6 

o If the PD Benefit Type is EA, PD worksheet 4 will be hidden; 

o If the PD Benefit Type is DS, both PD worksheet 4 and 5 will be hidden; 

o If the PD Benefit Type is BA, PD worksheet 4 will be hidden; 

o If the PD Benefit Type is AE, PD worksheet 5 will be hidden. 

o If the PD Benefit Type is DS, PD worksheet 6 columns I, J, K in section II 
will be shaded and protected. 

• Use of ISAR factor on MA Worksheet 5 G31 

o If the ISAR factor is Yes, cells G39 to G3333 will be editable; otherwise these 
cells will be protected. 

• MSA Plan Type on MSA Worksheet 1 G7 

o If the Plan Type is MSA, rows 32-34 on W4 are hidden; otherwise, these rows 
will display. 

o If the Plan Type is MSA, cell G38 on MSA worksheet 4 will have the formula 
=G30; otherwise, the formula will be =G30+G32-G33. 

• MA Plan ID on MA Worksheet 1 D6 
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o If the Plan ID is equal to or greater than 800, the employer PMPM input on 

Worksheet 4 cell Q58 is enterable; otherwise it is protected. 

Note: The BPT Refresh does not run the BPT validation rules. Use Circle Invalid function or 
Validation Report function if you want to refresh the red-circle display. 

2.3.4 Hide/Unhide Non-Validation Input Cell Label 

This function assists vision-impaired users who use screen readers when working with BPTs. 
This function will be available in all BPT workbooks (MA, MSA, PD and 2YLB). To identify all 
input cells, with or without validation, you can enable this function by clicking the  icon on 
the Toolbar or by selecting “Hide/Unhide Non-Validation Input Cell Label” from the File menu. 
All cells that do not have validations will display a pop-up input message with the cell location 
and cell label. When you navigate through each cell, the screen reader will be able to identify 
which cells are input cells. For example, MA Base cell G27 will be recognized by the screen 
reader as “G27 Input Cell Annualized Util/1000 for Inpatient Facility”. This function will be 
turned off by default when a BPT file is first opened. 

2.3.5 Hide/Unhide Rates worksheets 

This function allows you to hide or unhide the Rates worksheet in the MA and MSA BPTs and 
the Statutory Rates worksheet in the MA BPT. You can enable this function by clicking the  
icon on the Toolbar or by selecting “Hide/Unhide Rate Books” from the File menu. These 
worksheets will be hidden in the finalized BPT file. You will be able to copy and paste the data 
to another document if needed.  

Note: If you are pasting into an Excel workbook that is open in the same instance as the BPT, 
you will need to open the Office Clipboard by selecting Edit->Office Clipboard, before you copy 
and paste. You will not need to open the Office Clipboard if the destination file is open in a 
different Excel instance or if the document is not an Excel document. 

2.3.6 Hide/Unhide Validation Cell Label – New for CY2009 

This function allows you to turn on or off the input cell labels (input messages that display the 
validation rules) for all validation cells, including input and protected cells in the workbook. The 
validation input messages will display by default when you first open the BPT workbook. For 
example, for MA Base G5, the input message states “The Organization Name cannot be blank.” 
You can turn off these input messages by clicking the  icon on the Toolbar or by selecting 
“Hide/Unhide Validation Cell Label” from the File menu. All the input messages for validation 
cells will disappear in the MA workbook. You may turn them back on by clicking the same 
button on the Toolbar. When a BPT file is first opened, all the validation input cell labels will be 
turned on by default. 

Note: This function controls turning on and off input messages for validation cells only. The 
cells that do not have validations cell label input messages are controlled by the Hide/Unhide 
Non Validation Input Cell Label function. 
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2.3.7 Print Defined Worksheets – New for CY2009 

This function allows you to print a predefined set of worksheets. When you open a CY09 BPT 
file, and click the  icon on the Toolbar or select “Print Defined Worksheets” from the File 
menu, the following sets of worksheets will be printed for each type of workbook: 

o MA - Worksheets 1, 2, 3, 4, 6 and 1st page of worksheet 5 

o PD - All visible worksheets based on benefit type  

o MSA - Worksheets 1,2, 4 and 1st page of worksheet 3 

This function will not be available for 2YLB workbook. 

Note: The validation report, when visible, will not be printed in the MA, PD and MSA 
workbooks.  

2.3.8 Data Linking 

You will be able to link information from other workbooks into the BPT worksheets. See Section 
2.3.3, BPT Refresh, for additional information.  

As indicated in previous sections, the red-circle validations are not updated automatically. If 
changes are made to the source file, the validations of the linked BPT may not recognize the 
changes. Therefore, you should re-run the Circle Invalid function or the Validation Report to 
update the validations. 

2.3.8.1 Linked data entry formatting 

You will need to follow specific instructions to link information into the BPT for the following 
cells: 

o Plan ID (Worksheet 1, Section 1, General Information) 

o Segment ID (Worksheet 1, Section 1, General Information) 

o MA or PD Region (Worksheet 1, Section 1, General Information) 

o County Code (MA Worksheet 5, MSA Worksheet 3) 

When linking data into these cells, you will need to format the cells in your non-BPT workbook 
as General and place an apostrophe (') and leading zeroes prior to the actual value. The 
apostrophe is an Excel formatting character and will not be displayed in the BPT.  

Examples: 
Region 5 - Your input workbook must have the value ‘05. 05 will be displayed in the BPT. 
Plan ID 30 - Your input workbook must have the value ‘030. 030 will be displayed in the BPT 

2.3.8.2 Change Link  

This new function will allow you to change the link source using the standard Excel Edit link 
function. If you have one or more data links in the workbook and need to update the link source, 
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you can enable this function by clicking the icon  or by selecting “Change Link” from the 
File menu. The Excel Edit Link pop-up window will display. If you have not set up any data 
links, you will receive a message stating that this function will only be available if you have at 
least one data link in the workbook. 

Note: If there are a large amount of links in the BPT, it may take some time (e.g., 10-15 minutes) 
for the Excel Change Link function to complete. 

2.3.8.3 MA and MSA County Code Section 

This section addresses the following cells:  

o MA worksheet 5, rows 39 to 3333 columns B through W 

o MSA worksheet 3, rows 39 to 3333 columns B through H. 

 The following macro functions are applicable to these sections: 

1. The MA and MSA will support 3,295 lines of county codes (MA w5 and MSA w3 row 
39-3333). 

2. Row 39 contains the formulae in a blank BPT. 
3. When a county code is entered in column B (any row between row 39-row 3333), the 

formulae in  

a. MA worksheet 5 columns C, D and H-W will populate. 
b. MSA worksheet 3 columns C, D, G and H will populate. 

4. All county codes in Column B should be entered as a 5 digit number preceded by an 
apostrophe. You may see “#N/A” errors displayed if you enter a 5 digit number without 
an apostrophe. You cannot finalize a file if there are #N/A errors caused by an invalid 
county code. You must correct these errors and finalize the BPT again. 

5. When a county code is deleted from column B (any row between row 39-row 3333), the 
formulae in  

a. MA worksheet 5 columns C, D and H-W will be deleted. 

b. MSA worksheet 3 columns C, D, G and H will be deleted. 
6. All county codes will be sorted in the finalized file in descending order. See Section 

2.4.1, Finalization Process for more details.  

7. If the county codes are imported as a batch from another tool and they include spaces or 
special characters, these spaces and special characters will be sorted as non-blank rows. 
As a result, you may see some blank lines in the finalized file at the top of the county 
code section. You should open the working files and remove these lines and re-finalize 
the BPT.  

8. In the MA and MSA county code sections, if there is a non-zero value in the Projected 
Member Month column (Column E), there must be a non-zero value in the County code 
(Column B) and a non-zero value in the Projected Risk Factor column (Column F) for the 
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corresponding row. Otherwise, you will receive an error message and you will need to 
correct it before finalizing the file again. 

2.3.9 Undo Function 

The CY2009 BPT will support the Excel undo functionality with some exceptions. Modifying 
any of the cells listed below will cause the actions/states stored in your undo history* to be 
deleted. This means that after entering, changing, or deleting a value in any of the following 
cells, you will not be able to undo your previous actions.  

o Plan Type on MA Worksheet 1 Cell G7  

o Plan Type on PD Worksheet 1 Cell I6 

o MA-PD indicator on MA Worksheet 1 Cell G8 

o PD Benefit Type on PD Worksheet 1, N6 

o Use of ISAR factor on MA Worksheet 5 G31 

o MSA Plan Type on MSA Worksheet 1 G7 

o County Codes 

o Any cell composed of a drop down box  

o Any cell that has a validation error removed due to a correction in the user entered 
data  

A new undo history will begin to compile after each of these cells are modified. 

* The “undo history” is a Microsoft Excel feature that keeps a record of changes made to a 
workbook. This allows you to step backwards through a list of applied changes. Other built-
in Excel functions, including some of those used by the BPT, erase this information 
automatically due to the large amounts of memory required to maintain the undo history list.   

Note: If you have enabled the Excel 2003 Auto Recovery feature, your undo history will be 
deleted whenever the Auto Recovery feature runs.   

2.3.10 Save Function 

There are two save processes available within the BPT: a non-finalized and a finalized save. A 
non-finalized save can be invoked by clicking on the Excel Save icon on the Excel Standard 
Toolbar or by selecting File->Save from the Excel menu. This save process will save any 
changes you have made to the BPT workbook (also referred to as the working file).  

If you are ready to complete your BPT (and upload it to HPMS), you will need to perform a 
finalized save by invoking the BPT Finalize functionality. Please refer to section 2.4, Finalizing 
the BPT for Submission, for more details. 

If you are working in Excel 2007, you will be able to save and finalize a BPT once it is 
complete. When you click the Save button, the file will be saved in the Excel 2003 format. When 
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you click the “Finalize” button, the system will also save the working in Excel 2003 format and 
create a finalized and backup file in .xls format. 

You will receive a compatibility check information message after you click “Save” or “Finalize”: 

 

Please uncheck the box “Check compatibility when saving this workbook” and click “Continue”. 
The popup will not appear next time you save a BPT. It is also recommended that you perform 
this step before you execute the Batch Process Tool to avoid any popup in the batch process. 

2.4 Finalizing the BPT for submission 

This function is available in the MA, PD, MSA and MA 2YLB BPT workbooks.  

You must finalize your workbooks before packaging them with the PBP data for upload to 
HPMS. You may do so by clicking on the Finalize BPT icon  on the Excel Standard Toolbar 
or by selecting “Finalize BPT” from the File menu.   

Before you finalize a BPT file, it is highly recommended that you click the Validation 
Report or Circle Invalid function to check for any critical errors. If these critical errors are 
not corrected, you will receive an error message and the BPT file will not finalize. 

If you are working with a BPT in Excel 2007, when you click the Finalize button, the system 
will also save the working in Excel 2003 format and create a finalized and backup file in .xls 
format. Do not change the file format. You can only upload a BPT file in .xls format. 

2.4.1 Finalization Process 

When the finalization function is triggered, the system will perform the following actions: 
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• Check the critical validations for the MA, PD and MSA workbooks; 

o Refer to Appendix A for a list of critical error checks for the MA, MSA, MA 
2YLB and PD workbooks. 

o To locate the errors, please generate the Validation Report to view all failed 
validations. The critical errors will have a “Yes” indicator in the Critical Error 
column. All critical errors must be corrected for a file to be successfully finalized. 

• Save the working file; 

• Create a backup file; 

o The backup file will contain the same data as in the working file.  

o This file is read-only. If you need to use the backup file to restore data, refer to 
section 3.7, How to use the backup file to restore a prior version of the BPT. 

• Check the required fields. All of the following fields need to be entered for a BPT file to 
be successfully finalized: 

o MA Base: Contract Number, Plan ID, MA-PD, Plan Type, Enrollee Type, SNP,  
MA Region 

o MA Bid Summary: Name, Phone, Email for Plan Bid Contact and Certifying 
Actuary:  D39:D41, D45:D47 

o PD Base: Contract Number, Plan ID, Plan Type, Enrollee Type (when plan type is 
not PDP, ED PDP or Fall Back), SNP, PD Benefit Type, Payment Demo Type 

o PD Summary: Name, Phone, Email for Plan Bid Contact and Certifying Actuary:  
C36-38, C40-42 

o MSA Base: Contract Number, Plan ID, Plan Type 

o MSA Benchmark: Name, Phone, Email for Plan Bid Contact and Certifying 
Actuary:  D14-D16, D20-22 

o MA 2YLB: Contract Number 

• Create a finalized file with the following features: 

o The Plan ID, Segment ID, region and county codes in the applicable BPT 
workbook will be padded with leading zeros to display the required digits of 
numbers. For example, if you enter 2 for Plan ID, the finalized file will display 
‘002’. 

o All PD worksheets will display in the finalized file but only the relevant 
worksheets based on the PD Benefit type will contain data. For example, if you 
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select BA as Benefit type and enter data in PD worksheet (WS) 5, and later 
change the Benefit type to AE, all data entered in WS5 will be deleted. 

o All county codes entered in MA WS5 and MSA WS3 will be sorted in descending 
order. –Note: The data in the working file and the backup file will retain the 
original order. 

o All formulae will be removed in the finalized file. You can open the working file 
or the backup file and view the formulae if needed. 

o MA and MSA Workbook – County Code Section: If there is a non-zero value in 
the Projected Member Month cell for a given row(Column E), there must be a 
non-zero value in the associated (i.e. same row) County Code and Projected Risk 
Factor cells (Columns B and F). Otherwise, you will receive an error message and 
you will need to correct it before finalizing the file again. – New for CY2009. 

o If the PD region is blank in the working BPT file, the finalized BPT will display 
“N/A”. Note, the region field in the working BPT remains blank. 

o Red circles are displayed for those cells that do not pass validation rules. Note: 
You will be able to finalize the file if the red circled cell is not one of the critical 
errors.  

o Validation Report and Rate sheets will be hidden. You can open the working file 
and create the report or unhide the Rate sheets if needed. 

2.4.2 File Naming Convention 

Finalized BPT workbooks are saved with the standardized file name required for a successful bid 
upload to the HPMS (i.e., ContractNo+PlanID+SegmentID+WorkbookType.xls). In order for the 
Plan Benefit Package to validate your bid submission file, your BPT workbooks must be 
finalized and named using this naming convention. 

The finalized and backup files will be saved with the following naming convention: 

• Finalized File: ContractNo+PlanID+SegmentID+WorkbookType.xls (except for 2YLB) 

Example:  H1111001001MA.xls, H2222002002PD.xls, H3333003003MSA.xls 

Example for 2YLB : R5555_2YRLB.xls 

• Backup File:  ContractNo+PlanID+SegmentID+WorkbookType+”_Backup_”-YYYY-
MM-DD-HHmm.xls 

Example:  H1111001001MA_Backup_2006-5-20-1000.xls 

Example for 2YLB : R5555_2YRLB_Backup_2007-1-10-1548.xls 

Note:  This back up file will be saved in the same directory where the working file is 
located. 
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The working file name can be changed at any time. The finalized and backup BPTs are read-only 
files. If you need to make additional changes prior to your bid submission (i.e., upload to 
HPMS), you should modify your working file. Once complete, you can finalize the BPT again. 
Your previous finalized file will be overwritten. A new backup file will be created. Backup files 
will not be overwritten (as they are time-stamped). If you need to use the backup file to recover 
any saved data, see Section 3.7, How to use the backup file to restore a prior version of the BPT. 

2.5 Password Protection 

You may not make changes to the structure of the BPT workbook and worksheets. Each data 
item must be in its pre-defined cell location for successful processing by the HPMS. 

The BPT is password protected. Tampering with the BPT protection, including but not 
limited to un-protecting and re-protecting any parts of a BPT workbook, will permanently 
compromise the file and prevent you from finalizing that BPT workbook. In this situation, 
you will need to discard the tampered BPT, download and complete a new BPT.  

2.6 Print Functionality 

For CY2009, there is a new Print button that allows you to print a pre-defined set of worksheets, 
see Section 2.3.7. Print Defined Worksheets – New for CY2009 

You may also use the Excel Print function by using the File->Print menu option. You can also 
print individual worksheets by using the Print icon on the Toolbar. You will be able to print 
multiple worksheets by selecting worksheet tabs and printing.  

2.7 New Releases 

If necessary, the Centers for Medicare and Medicaid Services may deploy a new version of the 
BPT add-in file to update the BPT workbooks. The new version will be made available to the 
user community through the HPMS. HPMS will send an auto-generated email to certain HPMS 
users to announce that a new BPT add-in is available for download from HPMS.   

If there is an updated version of the BPT add-in (BPT2009.xla) file, you will need to download 
this file from the HPMS website. It is imperative that you overwrite the existing BPT add-in 
with the most current version in the C:\Program Files\BPT2009 folder. If you save multiple 
versions of the BPT add-in to the BPT2009 folder and elsewhere on your personal computer 
(PC), you may experience technical difficulties with the BPT.  

Note: If you receive the BPT add-in file via email and it is saved to your temporary directory as 
part of the email download process, you must delete it from the temporary directory. 

To verify that the BPT workbooks are using the latest version of the add-in file, compare the 
version number given during the add-in download process to the version number in the upper 
right corner of the BPT worksheets (e.g., “MA-2009.2” indicates that the BPT is using version 2 
of the add-in). 
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You will need to update all of your BPT workbooks (MA, PD, MSA and 2YLB) with the latest 
BPT add-in file. If you have finalized a BPT but not yet uploaded it, you must apply the add-in 
to the working version and re-finalize the BPT.  

The BPT workbook is updated automatically when you first open it after downloading the new 
BPT add-in file. When you receive a message stating that the BPT is out of date, click “OK” to 
start the update process. As part of the update process, a back up version of your previous BPT 
will be saved to a C:\Program Files\BPT2009\Update Backup Version (version number) folder.  

You will not need to transfer any data from one workbook to another to apply a BPT add-in 
update. For step by step instructions on downloading an update, see Sections 3.3, How to Update 
the BPT Add-In and 3.4, How to Update the Add-In for Multiple BPT Workbooks using the 
Batch Tool. 

2.8 Batch Process 

The Batch Process Tool is supported in Excel 2002 and 2003. It is not supported in Excel 
2000 or Excel 2007. 

The Batch Process Tool is not currently supported in the Vista Operating System.  There 
are known conflicts between the Batch Process Tool and the Vista OS that we are working 
to resolve.  We cannot guarantee that the Batch Tool will perform as intended with Vista.  
We recommend you run the tool only under Windows XP or Windows 2000.  

A Batch Process Tool is available to assist you to update, finalize or check validation errors for 
multiple BPT workbooks. The estimated execution time for the process can vary greatly based 
on the number of workbooks in the batch, the size of each workbook (e.g., MA workbooks with 
a large number of county codes) and your PC’s processing power. It is recommended that you 
initially run a small batch of five to ten workbooks to assess the execution time specific to your 
PC. The Batch Process Tool is available for download from the HPMS Bid Submission module. 
You must close all BPT workbooks before running the batch process. Failing to do so will 
prevent you from running the batch process. After the batch process is completed, you should 
close the Batch Process Tool before opening a stand-alone BPT file. This will avoid any 
potential conflict between the files. 

Note: You must have Excel 2002 or greater installed to use the Batch Process Tool. If you have 
Excel 2007, you will be able to run all batch functions except Validation Report. You 
may however, still run the validation report function in a stand-alone BPT file. 

The CY2009 Batch Process Tool will not process a previous contract year BPT, a finalized BPT, 
a backup BPT (files with “backup” in their file name) or a non-BPT file. The Batch Process Tool 
will skip these files if they are selected.    

Before using the Batch Process Tool, open an Excel window and select Tools->Macros-
>Security and on the Trusted Publishers tab, make sure the two check boxes “Trust all installed 
add-ins and templates” and “Trust access to Visual Basic Project” are checked. 
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Note:  The Batch Process Tool will set the BPT Calculation flag (located in the Tools->Options-

> Calculation tab) to “Automatic”. If you prefer to set this flag to “Manual”, you must 
open the stand-alone BPT after the batch process is completed and manually reset the 
flag. 

2.8.1 Batch Validation Report  

This function will allow you to generate a validation report for one or more BPT files. To enable 
this function, you will launch the Batch Process Tool and select the “Validation Report” and 
click “Next”. Browse through your folder structure and select the BPT files (with file extension 
.xls) to be processed. The Batch Process Tool will disable all icons that may disrupt its 
execution. The execution status of the batch process will be displayed in the Batch Process Tool 
status window. A success or failure message is displayed for each of the BPT workbooks. You 
will receive a confirmation message when the process is completed that indicates the number of 
files that passed, failed or were not processed. You will find the report in the same folder where 
the selected BPT files are located. You may open the report and view the Index Page, which lists 
the file names and the contract, plan and segment ID associated with the report. A hyperlink next 
to each file will take you to the corresponding report worksheet.  

Note: If the BPT files selected to be processed are at a lower version of the add-in file, the files 
will be updated first and then processed.  

The Batch Process Tool will skip processing the following files: 

o Non-BPT Excel workbook 

o Backup BPT file 

o Finalized version of BPT 

o Working BPT with different contract year (e.g., CY2008 working file) 

2.8.2 Batch Update Process 

If a new version of the BPT add-in is downloaded from the HPMS, the Batch Process Tool will 
allow you to update all of your working BPT files to the latest BPT add-in. To enable this 
function, you will launch the Batch Process Tool and select the “Update BPT” option and click 
“Next”. Browse through your folder structure and select the BPT files (with file extension .xls) 
to be updated with the new version of the BPT add-in. Click “Update” to start the batch process. 
The Batch Process Tool will disable all icons that may disrupt its execution. The execution status 
of the batch process will be displayed in the Batch Process Tool status window. A success or 
failure message is displayed for each of the BPT workbooks. If any updates fail, an associated 
error message will be displayed. You will receive a confirmation message when the process is 
completed that indicates the number of files that passed, failed or were not processed. You will 
find the updated files in the same folder where the selected BPT files are located. 

The Batch Process Tool will skip processing the following files: 

o Non-BPT Excel workbook 
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o Backup BPT file 

o Finalized version of BPT 

o Working BPT with different contract year (e.g., CY2008 working file) 

See Section 3.4, How to Update the Add-In for Multiple BPT workbooks using the Batch Tool 
for detailed instructions. 

To verify that the BPT workbooks are using the latest version of the add-in file, compare the 
version number given during the add-in download process to the version number in the upper 
right corner of the BPT worksheets (e.g., “MA-2009.2” indicates that the BPT is using version 2 
of the add-in). 

2.8.3 Batch Finalize Process 

You can use the Batch Process Tool to finalize multiple BPT workbooks. Launch the Batch 
Process Tool and select the “Finalize BPT” option. Browse through your folder structure and 
select the BPT files (with file extension .xls) to be finalized. Click “Finalize” to start the batch 
process. Once you start the process, the execution status of the batch process will display in the 
Batch Process Tool status window. The Batch Process Tool will disable all icons that may 
disrupt its execution. The execution status of the batch process will be displayed in the Batch 
Process Tool status window. A success or failure message is displayed for each of the BPT 
workbooks. If any workbooks fail to be finalized, an associated error message will display. You 
will receive a confirmation message when the process is completed that indicates the number of 
files that passed, failed or were not processed. You will find the finalized files in the same folder 
where the selected BPT files are located.  

Note: If the BPT files selected to be finalized are at a lower version of the add-in file, the files 
will be updated first and then finalized.  

The batch process will skip processing the following files: 

• Non-BPT Excel workbook 

• Backup BPT file 

• Finalized version of BPT 

• Working BPT with different contract year (e.g., CY2008 working file) 

2.8.4 Batch Update PD National Average Process – New for CY2009 

You can use the Batch Process Tool to update the PD National Average values (PD W7 F16 and 
F17) in multiple BPT workbooks. Launch the Batch Process Tool and select the “Update PD 
National Average” option. In the two input fields, enter the values for PD National Average 
Monthly Bid Amount (PD W7 F16) and the Base Beneficiary Premium (PD W7 F17). Browse 
through your folder structure and select the PD BPT files (with file extension .xls) to be updated. 
Click the “Update National Avg” button to start the batch process. Once you start the process, 
the system will start writing these two input values into the selected PD files.  
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The Batch Process Tool will disable all icons that may disrupt its execution. The execution status 
of the batch process will be displayed in the Batch Process Tool status window. A success or 
failure message is displayed for each of the BPT workbooks. If any workbooks fail to be 
finalized, an associated error message will display. You will receive a confirmation message 
when the process is completed that indicates the number of files that passed, failed or were not 
processed.  

A report will be generated and saved in the same folder where the selected PD files are located. 
In the report, you will see the file names for all files that are successfully updated. The report 
will also display the rounded PD Basic Premiums (PD W7 F21) before and after the updates for 
each workbook.  

The system will skip processing the following files: 

• Non-BPT Excel workbook 

• MA, 2YLB or MSA workbook type 

• Backup BPT file 

• Finalized BPT file 

• Working BPT with different contract year (e.g., CY2008 working file) 

• PD workbooks with blank Contract Number, Plan ID values. 

Skipped files will be displayed in the report within the section titled: “The following files were 
not updated because they are not valid CY2009 PD files or contain blank Contract and Plan 
IDs”. 

2.8.5 Batch Update MA BPT with PD Premiums – New for CY2009 

You can use the Batch Process Tool to copy the rounded PD premiums (PD W7 F21, F25) from 
multiple PD BPT files and into the corresponding MA BPT files (MA W6 R34, R40), (i.e., the 
BPTs that contain the same Contract, Plan and Segment IDs). Launch the Batch Process Tool 
and select the “Update MA with PD Premiums” option. On the top section of the screen, browse 
through your folder structure and select the PD files (with file extension .xls) to be used in the 
update. On the bottom file selection window, select the MA files that you want to update with 
the PD premiums. Click the “Update MA with PD Premiums” button to start the batch process. 
Once you start the process, the system will copy the values from the PD file, and into the 
matched corresponding MA file (i.e., the MA file with the same Contract Number, Plan ID and 
Segment ID).  

The Batch Process Tool will disable all icons that may disrupt its execution. The execution status 
of the batch process will be displayed in the Batch Process Tool status window. A success or 
failure message is displayed for each of the BPT workbooks. If any workbooks fail to be 
finalized, an associated error message will display. You will receive a confirmation message 
when the process is completed that indicates the number of files that passed, failed or were not 
processed.  
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A report will be generated and saved in the same folder where the selected MA files are located. 
In the report, you will see the PD file and matched MA files that were successfully updated. You 
will also view the PD Premiums in each processed MA file (MA W6 R34 and R40) before and 
after the updates. If an MA file is a duplicate (same Contract, Plan and Segment ID) of another 
matched MA file, the duplicate file will also be updated with the PD premiums and displayed in 
the top section of the report. The following files will not be processed: 

• If a PD file is a duplicate (i.e., same Contract, Plan, Segment) to a PD file that has 
already been processed in the current batch process; the duplicate file will not be 
processed and will be displayed in the report under the section titled: “The following PD 
files were not processed because they are a duplicate to a processed PD file”. That is, the 
PD premiums in the duplicate PD BPT will not be copied into the corresponding MA 
BPT via the Batch Process Tool. 

• If an MA file is not matched to any selected PD file (based on Contract Number, Plan ID 
and Segment ID), the file will not be processed and will be displayed in the section titled: 
“The following MA files were not matched to the selected PD source files”. That is, the 
PD premiums in the MA BPT will not have been updated/changed via the Batch Process 
Tool. 

• If a PD file is not matched to any selected MA file (based on Contract Number, Plan ID 
and Segment ID), the file will not be processed and will be displayed in the section titled: 
“The following PD files were not matched to the selected MA target files”. That is, the 
PD premiums in the PD BPT will not be copied into any MA BPTs via the Batch Process 
Tool. 

The system will also skip processing the following files. These will be displayed in the section 
titled: “The following files were not processed because they are not valid CY2009 MA or PD 
files”: 

• Non-BPT Excel workbook 

• 2YLB or MSA workbook type 

• Backup BPT file 

• Finalized BPT file 

• Working BPT with different contract year (e.g., CY2008 working file) 

• MA or PD workbooks with blank Contract Number, Plan ID values. 

2.8.6 Batch Process termination handling 

If the Batch Process Tool is terminated abnormally before the process is completed, you must 
close all Excel instances (i.e., windows) before you re-run the batch process. See Section 3.8, 
How to re-start the Batch process if it terminated abnormally for detailed instructions.  
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3 How To… 

3.1 How to download a blank stand-alone BPT file 

1. Go to CY2009 Bid Submission Module in the HPMS Website. 

2. Select “Download”. 

3. Select “BPT Spreadsheets”. 

4. Select “MA”, “MSA”, “PD”, or “2YLB” workbook. 

5. Click “Download”. 

6. Save the BPT files in a folder on the local C: drive on your PC. 

3.2 How to download the Batch Process tool 

1. Go to CY2009 Bid Submission Module in the HPMS Website. 

2. Select “Download”. 

3. Select “BPT Batch Tool”. 

4. Read the download instructions and click the download button to begin the process. 

5. When prompted to “Save” or “Run” the file, BPT2009BatchProcess.exe, choose “Save” 
and select a local directory on your PC.   

6. If there is an older version of the file in the same folder, click “Yes” when prompted to 
replace the older version of the file. The older version will be overwritten by the updated 
file.  

3.3 How to Update the BPT Add-In  

1. In Windows Explorer, navigate to C:\Program Files\BPT2009 folder. 

2. Delete the existing BPT2009.xla file. 

3. Go to CY2009 Bid Submission Module in the HPMS Website. 

4. Select “Download”. 

5. Select “BPT Spreadsheets”. 

7. Read the download instructions and click the download button to begin the process. 

6. Save the file in the C:\Program Files\BPT2009 folder. For Excel 2007 users, make sure 
the add-in file extension is .xla, not .xlam. See Section 2.1.2, Installing the add-in file for 
more information. 

7. Open a BPT, select “Enable Macros”. (Only applicable if Macro security is set to 
Medium.) 

8. Click “OK” when you see the message:  “The current version of this BPT file is version 
n. This is not the most update to date version. Updating to version x.” 

9. Verify that the BPT has been updated to the newer version by checking the version 
number in the upper right hand corner of the first worksheet in the workbook. The 
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version number is located in cell P7 for 2YLB, cell N3 for PD, cell P3 for MA and cell 
P3 for MSA workbook. The number after the period reflects the current version (e.g., 
MA-2009.2 indicates the BPT is using version 2 of the add-in).  

Note: If you download the PBP software from the HPMS website, the BPT add-in file will be 
automatically saved in the C:\Program Files\BPT2009 folder. 

3.4 How to Update the Add-In for Multiple BPT workbooks using the Batch Tool 

1. Double-click the BPT Batch Process icon or the BPT2009BatchProcess.exe file name to 
start the application. 

2. On the Select Process Option screen, select “Update BPT”. 

3. Click “Next”. 

4. Using the files search window, navigate to the location where you saved BPT workbook 
(.xls) files.   

5. Select the BPTs. You can use the Shift or Ctrl key to select multiple files. 

6. Click “Update”. 

7. Review success/failure messages for the selected BPTs. 

8. After the batch process completes, verify that the BPTs have been updated to the newer 
version by checking the version number in the upper right corner of the worksheets in the 
workbook. The version # is located in P7 for 2YLB, cell N3 for PD, cell P3 for MA and 
cell P3 for MSA workbook. The number after the period reflects the current version (e.g., 
MA-2009.2 indicates the BPT is using version 2 of the add-in.) 

3.5 How to finalize a single BPT 

1. Open a completed BPT. 

2. Select “Enable Macros” when prompted. (Only applicable if Macro security is set to 
Medium.) 

3. Click the Finalize BPT icon on the tool bar or select the “Finalize BPT” option from the 
File menu. 

4. If you receive any critical validation error messages, you must resolve the errors before 
attempting to re-finalize your BPT. See Section 2.4.1, Finalization Process for more 
detail on the finalization process. 

5. Verify that the working version BPT is saved, and finalized and back-up BPT files are 
created in the same folder.    

3.6 How to Finalize Multiple BPT workbooks using the Batch Tool 

1. Double-click the BPT Batch Process icon or the BPT2009BatchProcess.exe file name to 
start the application. 

2. On the Select Process Option screen, select “Finalize BPT”. 

3. Click “Next”. 
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4. Using the files search window, navigate to the location where you saved BPT workbook 

(.xls) files.   

5. Select the BPT files. You can use the Shift or Ctrl key to select multiple files. 

6. Click “Finalize”. 

7. Review success/failure messages for the selected BPTs. 

8. After the batch completes, verify that the finalized and back-up BPT files have been 
created in the same folder.   

3.7 How to use the backup file to restore a prior version of the BPT 

If the working version of the BPT has been corrupted or you need to roll back to a prior version 
of your BPT, you may use a back-up version of your BPT.   

1. In Windows Explorer, locate the backup file in the same directory where the working 
BPT is saved. 

2. Right-click on the backup file name.  

3. Select “Rename” from the menu.  

4. Remove the word Backup from the file name. 

5. Open the file and verify that the file is editable. 

3.8 How to re-start the Batch process if it terminated abnormally 

1. Save and close any open non-BPT Excel workbooks. 

2. Launch Task Manager, select the Processes tab, and click the “Image Name” column to 
sort the processes names.   

3. Select EXCEL.EXE and click “End Process” button. If more than one EXCEL.EXE 
process is found, repeat this step to end all the EXCEL.EXE processes. 

4. Double click the BPT Batch Process application icon or the BPT2009BatchProcess.exe 
file name to re-start the Batch Process. 

3.9 How to update PD National Averages in multiple PD files 

1. Double click the BPT Batch Process icon or the BPT2009BatchProcess.exe file name to 
start the application. 

2. On the Select Process Option screen, select “Update PD National Average”. 

3. Click “Next”. 

4. Enter values in the input fields for the PD National Average Monthly Bid Amount (PD 
W7 F16) and the Base Beneficiary Premium (PD W7 F17). 

27 



 

CY2009 Bid Pricing Tool Technical Instructions 
5. Using the files search window, navigate to the location where you saved PD workbook 

(.xls) files.   

6. Select the PD files. You can use the Shift or Ctrl key to select multiple files. 

7. Click the “Update PD National Average” button. 

8. Review success/failure messages for the selected BPTs. 

9. After the process completes, verify that the PD files are updated correctly. A report will 
be available in the same folder where the PD files are located. 

3.10 How to update multiple MA files with PD Premiums  

1. Double click the BPT Batch Process icon or the BPT2009BatchProcess.exe file name to 
start the application. 

2. On the Select Process Option screen, select “Update PD Premiums in MA”. 

3. Click “Next”. 

4. Using the top files search window, navigate to the location where you saved PD 
workbook (.xls) files.   

5. Select the PD files. You can use the Shift or Ctrl key to select multiple files. 

6. Using the bottom files search window, navigate to the location where you saved MA 
workbook (.xls) files. Note: The MA files should match to the PD files selected above 
(same Contract Number, Plan ID and Segment ID). 

7. Click the “Update PD Premiums in MA” button. 

8. Review success/failure messages for the selected BPTs. 

9. After the process completes, verify that the MA files are updated correctly. A report will 
be available in the same folder where the MA files are located. 
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4 Troubleshooting and FAQ 

4.1 Problems with the Add-In File  

If you are having difficulty opening, saving or finalizing a BPT, the most likely culprit is having 
more than one copy of the CY2009 add-in file on your PC. To ensure you only have the latest 
copy of the CY2009 add-in file, stored in the correct location, perform the following: 

1. Delete any existing BPT2009.xla file(s) in the C:\Program Files\BPT2009 folder. 

2. Download the BPT2009.xla file from the HPMS website and save it in the C:\Program 
Files\BPT2009 folder. For Excel 2007 users, make sure the add-in file extension is .xla, 
not .xlam. See Section 2.1.2 for more information. 

3. Confirm the macro security setting is set to Medium. 

a. Open an Excel window. 

b. Go to Tools->Option->Security->Macro Security. 

c. Verify that the setting is Medium. 

d. Close the Excel window. 

4. Confirm the add-in is unloaded properly. 

a. Open an Excel window. 

b. Go to Tools->Add-ins. 

c. Verify that both the CY2008 and CY2009 add-ins are unchecked. 

d. Close the Excel window. 

5. Close all Excel windows on your PC. 

6. Launch the Task Manager, select Processes tab, select EXCEL.EXE and click “End 
Process” if applicable. Repeat for each instance of EXCEL.EXE. 

7. Confirm that there is only one BPT add-in on the PC. 

a. Click on “Start” and select Search->For Files or Folders 

b. Enter BPT2009.xla in the Search for Files and Folders name box. 

c. Select Local Hard Drive C: in the Look In dropdown box. 

d. If multiple files are found, delete the BPT2009.xla in any other folders and keep 
only one BPT2009.xla file in the C:\Program Files\BPT2009 folder. 
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e. Repeat step c for any other local hard drives (e.g., D:\) that might contain the 

BPT2009.xla file.  

8. Check the workbook to see if the issue is resolved. 
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4.2 FAQ’s 

Question 1:  When I open a BPT file, I only see the BPT SplashScreen. Where are the other 
worksheets? 

Answer:  It’s likely that you either have multiple BPTs open in separate instances (i.e., windows) 
of Excel, or your add-in file is corrupted. Close all but one BPT file and/or re-install the add-in. 
Follow the steps in Section 4.1, Problems with the Add-In File, to re-load the add-in.  

Question 2:  Why can’t I find the BPT commands, such as BPT Finalize, Circle Invalid and BPT 
Refresh icons, on my Excel Toolbar? 

Answer:  The BPT icons are loaded with the Excel Standard Toolbar and they only appear when 
the Excel Standard Toolbar is enabled. Follow the steps below to load the Standard Toolbar.  

1. On the Excel file menu, select View->Toolbars and select “Standard Toolbar”. 

2. Close the Excel window. 

3. Open the BPT. 

Question 3:  I have entered multiple entries of the county codes in MA Worksheet 5 (WS5) (or 
MSA WS3) , why are the formulae not copied into row B40 and down? 

Answer:  This may be due to the BPT add-in not being properly loaded in the BPT. Follow the 
steps in Section 4.1, Problems with the Add-In File, to re-load the add-in.  

Question 4:  The Macro Security setting on my PC is set to “Low” but I don’t see the prompt 
when opening the BPT. Do I need to enable the Macros in another way? 

Answer:  If the Macro security setting is “Low”, the BPT add-in file will automatically run when 
you open the BPT; therefore, you don’t see the prompt to enable macros. For security purposes, 
the Macro Security Level should be set to “Medium”. 

Question 5: I encountered the following error(s) when finalizing the BPT, what should I do? 

Error Message 1 in MA BPT: 
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Error Message 2 in MSA BPT: 

 

Error Message 3 in PD BPT: 

  

Error Message 4 in MA, PD, MSA or 2YLB: 

There was an error when finalizing the BPT. 
Error 13: Type mismatch 

Answer: 

If you receive any of these messages, check the workbook cells and verify that they do not 
contain # VALUE, # N/A, # REF, text, or #DIV/0!. 

If these cells do not contain invalid values, please check the entire workbook for cells that either 
contains the #ERROR message or text values instead of numeric values. These need to be 
corrected before you can finalize the BPT workbook. 

Question 6: I received a “subscript out of range” error. What should I do? 

Answer: CY08 and CY09 working files cannot be open in the same Excel instances (window). 
Please see Section 2.2.2, Version Compatibilit, for details. Please open the CY08 working file in 
a different Excel instance by opening a new Excel window. If this does not resolve the issue, 
open an Excel window, select Tools->Add-in, and uncheck the check box for BPT2008 and/or 
BPT2009. Open the BPT file in this Excel window. 
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For returning BPT users (i.e., those that used the CY2008 BPT), you may receive this error 
message upon opening the CY2009 BPT for the very first time. If this error occurs, select the 
“Tools” menu in Excel, select “Add-in” and un-check the “BPT2008” box. Verify that the 
“BPT2009” box is checked. This will resolve the error when opening the CY2009 BPT 
thereafter. 

Question 7: I receive the following Run Time Error when opening BPT files in Excel 2007. 
What should I do? 

 

Answer: This may happen if the Excel process does not load the BPT add-in properly before you 
open and save a working BPT in the same Excel window. You can open an Excel window and 
click the Excel icon in the top left corner. Click Excel Options->Add-ins. Click “Go” next to the 
Manage Excel add-in box.  In the list of add-ins, select the checkbox for BPT2009. Close the 
existing Excel window and re-open the BPT file. If this does not resolve the issue, follow the 
steps in Section 4.1, Problems with the Add-In File, to re-load the add-in. 

4.3 Support 

HPMS Help Desk 

If you need additional assistance, please contact the HPMS Help Desk at 1-800-220-2028 or via 
e-mail at hpms@cms.hhs.gov. 
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5 Appendix A – Critical Errors 

5.1 MA Critical Errors and Related Error Messages 

1. "Unallocated rebates" cell (w6, L31) must equal zero. (Red circle validation) 

 Error message: All rebates (WS6 L31) must be allocated.  

2. Part B and D rebate allocations (WS6, L27-29) must be rounded to one decimal (i.e., no 
pennies). (Red circle validation) 

Error message: Part B and D rebate allocations (WS6 L27, L28 and L29) must be 
rounded to one decimal point. 

3. Premiums cannot be negative (w6, R31, R43, R45) (i.e., must be greater than or equal to 
zero) WITH THE EXCEPTION OF PT D BASIC PREMIUM which CAN BE 
NEGATIVE. (Red circle validation) 

 Error message: Premiums (WS6 R31, R43 and R45) must not be negative. 

4. Rebate allocations (w6, L25-L29) cannot exceed maximum values (w6, M25-M29). Note 
the following two exceptions:  if M25 is negative, then L25 is permitted to be zero (or 
blank), and if M28 is negative, then L28 is permitted to be zero (or blank). (Red circle 
validation) 

Error message: Allocated rebates (WS6 L25-L29) must not exceed maximum values 
(WS6 M25-M29). 

5. Rebate allocations (w6, L25-29) must not be negative. (Red circle validation) 

Error message: Rebate allocations (WS6 L25-L29) must be greater than or equal to zero.  

6. For EGWP bids (i.e., plan IDs 800 or higher), Part D rebates (w6, L28-L29) must be 
zero. (Red circle validation) 

Error message: For 800 series plans, Part D rebates (WS6 L28-L29) must be equal to 
zero. 

7. For MA-only bids (i.e., MA-PD indicator = "N"), Part D rebates (w6, L28-29) must be 
zero. (Red circle validation) 

 Error message: For MA-only plans, Part D rebates (WS6 L28-L29) must be zero. 

8. For MA-only bids (i.e., MA-PD indicator = "N"), Part D premiums (w6, R34, R40) must 
be zero or blank. (Red circle validation) 
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Error message:  For MA-only plans, Part D premiums (WS6 R34, R40) must be zero or 
blank. 

9. MA rebates allocations (w6, L25-26) must be rounded to TWO decimal points.  (Red 
circle validation) 

Error message: MA rebates allocations (WS6 L25-26) must be rounded to 2 decimal 
points. 

10. Valid target premium (w6 R47) must be selected from drop-down menu options (i.e., 
cannot be left blank for MA-PD plans). (Red circle validation) 

Error message: For MA-PD plans, the Plan Intention for Part D premium (WS6 R47) 
must not be blank.   

11. Plan A/B Benchmark and Bid (WS5, E17 and E18) must be greater than zero. (Red circle 
validation) – New for CY2009 

Error message: The Plan A/B Benchmark (WS5 E17) and Plan A/B Bid (WS5 E18) must 
not be blank.   

12. For Employer bids (i.e., 800 series Plan IDs), Part D basic and supplemental premiums 
(WS6 R37 and R43) must be zero. (Red circle validation) – New for CY2009 

Error message: For Employer bids (i.e., 800 series Plan IDs), Part D basic and 
supplemental premiums (WS6 R37 and R43) must be zero. 

13. In the MA county code section, if there is a non-zero value in the Projected Member 
Month column (Column E), there must be a non-zero value in the County code (Column 
B) and a non-zero value in the Projected Risk Factor column (Column F) for the 
corresponding row. – New for CY2009 

Error Message: In the MA Benchmark worksheet, county level detail and service area 
summary section, if there is a non-zero value in Projected Member Month (column 
E) there must be a valid non-zero value in County code (column B) and Projected Risk 
Factors (column F) in the corresponding row. 

14. An error message will display if the county code section (W5 Column H-W, Row39-
3333) contain any invalid values, such as #N/A, DIV! errors etc. See error message for 
Item 15. 

15. The following cells should not contain invalid values: W5 E25, W6 L23, R16, L25-29, 
L31, M25-29, R31, R43, and R45. 

Error message:  
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5.2 MSA Critical Errors and Related Error Messages 

1. For MSA Demo plan type, MSA worksheet 1 Cell G8 Deductible Amount should be 
greater than or equal to Minimum deductible ($2,200) and less than or equal to Maximum 
deductible ($10,500). 

Error message: For the MSA Demo plan type, the MSA Base Deductible Amount (WS1 
G8) must be greater than or equal to $2,200 (Minimum Deductible amount) and less than 
or equal to $10,500 (Maximum deductible amount). 

2. For the MSA Demo plan type, the MSA worksheet 4 Cell G48 Monthly Enrollee Deposit 
times 12 (Annual Deposit) must be at least 1000 less than the Deductible Amount cell G8 
of Worksheet 1. 

Error message: For MSA Demo plan type, Monthly Enrollee Deposit (WS4 G48) times 
12 (Annual Deposit) must be at least 1000 less than the Deductible Amount (WS1 G8). 

3. For MSA plan type, MSA worksheet 1 Cell G8 Deductible Amount should be less than or 
equal to the Maximum deductible amount $10,500. 

Error message: For the MSA plan type, the Deductible Amount (WS1 G8) should be less 
than or equal to the Maximum deductible amount $10,500. 

4. In the MSA Benchmark worksheet, county level detail and service area summary section, 
if there is a non-zero value in Projected Member Month (column E) there must be a valid 
non-zero value in County code (column B) and Projected Risk Factors (column F) in the 
corresponding row. New for CY2009 

Error message: In the MSA Benchmark worksheet, county level detail and service area 
summary section, if there is a non-zero value in Projected Member Month (column 
E) there must be a valid non-zero value in County code (column B) and Projected Risk 
Factors (column F) in the corresponding row. 
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5. An error message will display during finalization if the county code section (W3 Column 

G-H, Row39-3333) contains invalid values, such as #N/A, DIV! errors etc. See error 
message for Item 6. 

6. The following cells should not contain invalid values: W3 G36, W4 H48, H53, I48 and 
I53. 

Error message:  

 

5.3 PD Critical Errors and Related Error Messages 

1. For WS4 E59 and E60:  The Actuarial Equivalence tests should equal ‘Yes” if the PD 
benefit type is ‘AE’.  

Error message: The Actuarial Equivalence tests (WS4 E59-E60) should equal ‘Yes” if the 
PD benefit type is ‘AE’. 

2. For WS5 G68:  Total Coverage test should be ‘Yes” if PD Benefit Type is ‘BA’ or ‘EA’.  

Error message:  The total Coverage test (WS5 G68),Unsubsidized Value test (WS5 G69), 
Average Cost test (WS5 G70), Deductible test (WS5 G71) and Average Catastrophic 
Cost Sharing test (WS5 G72) should be ‘Yes” if PD benefit type is ‘BA’ or ‘EA’. 

3. For WS5 G69:  Unsubsidized Value test should be ‘Yes” if PD benefit type is ‘BA’ or 
‘EA’. 

Error message: The total Coverage test (WS5 G68), Unsubsidized Value test (WS5 G69), 
Average Cost test (WS5 G70), Deductible test (WS5 G71) and Average Catastrophic 
Cost Sharing test (WS5 G72) should be ‘Yes” if PD benefit type is ‘BA’ or ‘EA’. 

4. For WS5 G70:  Average Cost at Initial Coverage Limit test should be ‘Yes” if PD benefit 
type is ‘BA’ or ‘EA’. 

Error message: The total Coverage test (WS5 G68), Unsubsidized Value test (WS5 G69), 
Average Cost test (WS5 G70), Deductible test (WS5 G71) and Average Catastrophic 
Cost Sharing test (WS5 G72) should be ‘Yes” if PD benefit type is ‘BA’ or ‘EA’. 
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5. For WS5 G71:  Deductible test should be ‘Yes” if PD benefit type is ‘BA’ or ‘EA’. 

Error message: The total Coverage test (WS5 G68), Unsubsidized Value test (WS5 G69), 
Average Cost test (WS5 G70), Deductible test (WS5 G71) and Average Catastrophic 
Cost Sharing test (WS5 G72) should be ‘Yes’ if PD benefit type is ‘BA’ or ‘EA’.  

6. For WS5 G72:  Average Catastrophic Cost Sharing test should be ‘Yes” if PD benefit 
type is ‘BA’ or ‘EA’. Error message: The total Coverage test (WS5 G68), Unsubsidized 
Value test (WS5 G69), Average Cost test (WS5 G70), Deductible test (WS5 G71) and 
Average Catastrophic Cost Sharing test (WS5 G72) should be ‘Yes’ if PD benefit type is 
‘BA’ or ‘EA’. 

7. For WS5 O76:  Development of Supplemental Premium should be 0 if PD benefit type is 
‘BA’ or greater than 0 if it is ‘EA’. 

Error message: The Development of Supplemental Premium (WS5 O76) should be zero 
if the PD benefit type is ‘BA’.  

Error message: The Development of Supplemental Premium (WS5 O76) should be 
greater than zero if PD Benefit type is ‘EA’. 

8. For WS7, the following cells, F15, F25, F27, F28, F32 should not have any invalid values 
such as #VALUE, #DIV/0! or #N/A.   

Error Message: 
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